LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General > LinuxQuestions.org Member Success Stories
User Name
Password
LinuxQuestions.org Member Success Stories Just spent four hours configuring your favorite program? Just figured out a Linux problem that has been stumping you for months?
Post your Linux Success Stories here.

Notices

Reply
 
Search this Thread
Old 01-11-2005, 06:55 AM   #16
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Original Poster
Rep: Reputation: 55

Idle, no problem here with the blog and firefox. Try deleting the cache (edit. pref, priv, cache) Not sure what else to suggest. Also try starting firefox from the command line to see if it gives any error messages before it craps out. Also try it as another user - if this works you can delete the .firefox directory in your home folder - save your bookmarks first. I will create a new one and that may clear up the issue.

HTH
 
Old 01-11-2005, 07:29 AM   #17
Idle
LQ Newbie
 
Registered: Nov 2002
Location: Iceland
Distribution: RHEL, CentOS, Slackware
Posts: 26

Rep: Reputation: 15
I tried what you suggested, including deleting the firefox directory, but nothing works. When I run it from the command line, I get this error:
"/opt/firefox/run-mozilla.sh: line 159: 11701 Segmentation fault "$prog" ${1+"$@"}"

Don't trouble yourself, I'll figure something out. Thanks.
 
Old 01-14-2005, 06:49 PM   #18
lemuel
Member
 
Registered: Nov 2003
Location: Cebu, Philippines
Distribution: Ubuntu
Posts: 73

Rep: Reputation: 15
Thank you very much for your how-to franklin. I bow before thee!

I'm so glad I was able to read this thread. Now I dont have to suffer looking at the ugly fonts in Suse. I think the only thing I ever miss in Xp are the fonts, but now i dont have to anymore thanks to you!

I tried it in Suse 9.2 and Ubuntu and it worked for both distros.

You should transfer this how-to to the tutorial section so it can get better exposure and many more will be able to recieve help from it.

by the way, to those who still dont know, M$ true type core fonts can now be downloaded under the EULA license in this site

http://thelinuxbox.org/Downloads.php

just scroll down to the bottom of the webpage where you can download the fonts. there you can even download 6760 FONTS IN A SINGLE FILE WHOOOHOOO!! check it out!
 
Old 01-15-2005, 09:16 AM   #19
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Original Poster
Rep: Reputation: 55
Glad things worked for you lemuel.

I think that this is a fine place for this thread for a couple reasons:

1. It seems to be getting plenty of views.
2. I labled the thread such that anyone willing to do a search will find it.
3. While it works for me and the few who have also confirmed success, I have only tested
this on a handful of distros and was not confident that this was a general "fix".
4. Placing a thread like this in the "Answers" forum might make LQ look as though it
endorses doing things that might be "problematic" depending on a users situation.

If a mod sees it and suggests moving it so be it. It's not for me to decide and, like I said, it seems to be getting some views where it is.

By the way, no bowing required:

Much of this can be found in other places on the web anyway, I just tried to consolidate it a bit and add a couple tweaks I came up with. Must give credit where credit is due.

The Dropline-Gnome forum has a font-FAQ that discusses some of this.
Also, do a search in Google <groups> under alt.os.linux.suse for posts by softedges. He had some pages posted that go into some more detail regarding font.config files etc in SuSE 8.2. Also varius font-deuglification Howto's (tho many are dated) are a must read as well.
 
Old 01-15-2005, 10:08 AM   #20
pnellesen
Member
 
Registered: Oct 2004
Location: Missouri, USA
Distribution: Slackware 12.2, Xubuntu 9.10
Posts: 371

Rep: Reputation: 31
Quote:
Originally posted by Idle
Marvellous! Thanks for the tips, it works just fine for me. There's one small problem after the changes, though. Firefox doesn't seem to like my blog anymore, it just crashes when I try to view it (idleblog.iceware.net, if someone else wants to try). Seems to be the only page I have the problem with. Ideas, anyone?
You may need to change the permissions on your TrueType fonts (or whatever font you're using in your Blog)? I had the exact same thing happen to me, and discovered only root had any permissions at all on those fonts.
 
Old 01-16-2005, 10:28 PM   #21
puffinman
Member
 
Registered: Jan 2005
Location: Atlanta, GA
Distribution: Gentoo, Slackware
Posts: 217

Rep: Reputation: 30
Amazing

Wow, wow, all I can say is wow.

Worked great on Mandrake 10.1 / GNOME 2.6. Thanks for such a clear and thorough walkthrough. Seems like I was in the same boat with a lot of folks; love Linux but get headaches from the fonts. That is, I USED to get headaches.

Thanks again, Franklin.
 
Old 01-23-2005, 09:00 AM   #22
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Original Poster
Rep: Reputation: 55
Missing Konsole font: a solution

This problem has plagued me off and on since I started with linux it seems 2 1/2
years ago. I often solve the problem, as do others, through some other action
(read 'by accident' ) and am left with no reproduceable solution. This also
appears to be the case with many related threads I found through google which
appear to end either without resolution or "I don't know why, but when I did
"X" it fixed itself". I offer this as a definitive fix. Hope it helps others.

Problem:

For some unknown reason, trying to set the font in Konsole (KDE) to type "Linux" will
result in the following error message:

Font:

`-misc-console-medium-r-normal--16-160-72-72-c-80-iso10646-1'

not found.

Check README.linux.console for help.


Of course, README.linux.console, once I found it (not on my system by the way)
was of no use whatsoever.

After much googling I found a post that identified the missing font(s) as:

console8x16.pcf.gx and/or
console8x8.pcf.gz

Clearly this font was missing from the "misc" font directory.

Performing a locate, the fonts were found at:

/opt/kde/share/fonts

I first tried to add this location to my font paths but this did not seem to
help. I then used the KDE Font installer in the Control Panel (as root), selected the
"misc" font directory as my destination directory and /opt/kde/share/fonts as my
source directory, selected the 2 fonts and restarted X. Since the only people having
this issue will be using KDE, this is likely the simplest procedure.

Problem solved.

HTH someone. This always pissed me off.

Last edited by Franklin; 01-23-2005 at 09:02 AM.
 
Old 01-23-2005, 03:42 PM   #23
madiyaan
Member
 
Registered: Apr 2003
Posts: 69

Rep: Reputation: 15
Amazing screenshots.

I'm running Fedora Core 3 and Gnome 2.8 (that comes with it) and all default configs.
Your screenshots look amazing, and even better than Windows.
Here's what I did:
http://distributions.linux.com/howto...OWTO/fix.shtml
I used the recompiled RPM for Fedora Core 3 (cause I don't like to recompile; recompiling has always given me issues). I did not follow your step (B), cause I hate to mess around with the text files myself (I'm a Linux Newbie). But it's still not giving me the right results. Font's aren't crisp at all... in fact they're very very fuzzy, and I don't see any striking difference b/w these fonts and the fonts rendered by freetype that was compiled without bci. I also installed the truetype fonts, which were equally ugly.
Also, I looked around Gnome font manager (click the foot icon, preferences, fonts), and there's no option to uncheck anti-aliasing. I think my biggest problem is that AA is set to on for every font (even smaller ones, or even truetype ones). So is there a way to disable AA thru' Gnome (graphical GUI method preferred over text method)?
I'm asking this cause you have a screenshot with Gnome... which means you probably turned off AA in Gnome too. I'm pretty sure there is a way to do it, but I just can't find the option to turn it off! Also tell me which is better; Best Contrast or Best Shapes? (I'm talking about the Gnome font manager GUI)
Regards,
 
Old 01-23-2005, 05:01 PM   #24
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Original Poster
Rep: Reputation: 55
To turn off antialiasing in Gnome, choose Desktop Prefs - Font.
Then click the details button and choose "None" for both Smoothing and Hinting.
This will automagically turn of the radio buttons on the first page of the font rendering
dialogue box.

Generally, edits made in KDE's Control Panel for font preferences will carry into Gnome -
I "think" they both edit the same /home/<user>/font.conf xml file, but don't hold me to that

You may also want to cd to the /usr/lib directory and run the command:

ls -la libfreetype* to make sure the symlinks are pointing to the new libs.

Mine reads as follows:
Code:
steve@peggyo:~$ cd /usr/lib
steve@peggyo:/usr/lib$ ls -la libfreetype*
-rw-r--r--  1 root root 2431914 2005-01-22 18:35 libfreetype.a
-rwxr-xr-x  1 root root     816 2005-01-22 18:35 libfreetype.la
lrwxrwxrwx  1 root root      20 2005-01-22 18:35 libfreetype.so -> libfreetype.so.6.3.7
lrwxrwxrwx  1 root root      20 2005-01-22 18:35 libfreetype.so.6 -> libfreetype.so.6.3.7
-rwxr-xr-x  1 root root  415008 2004-06-05 17:48 libfreetype.so.6.3.5
-rwxr-xr-x  1 root root 1521734 2005-01-22 18:35 libfreetype.so.6.3.7
As you can see, there is an old lib present, but my symlinks piont to the new lib.

Quote:
I used the recompiled RPM for Fedora Core 3 (cause I don't like to recompile; recompiling has always given me issues). I did not follow your step (B), cause I hate to mess around with the text files myself (I'm a Linux Newbie).
While I understand how you feel, I would strongly suggest you get past this. It's far easier to control your system this way.

HTH
 
Old 01-23-2005, 09:41 PM   #25
madiyaan
Member
 
Registered: Apr 2003
Posts: 69

Rep: Reputation: 15
I still can't figure it out!

Okay, I downloaded and installed the bci-enabled rpm from this website:
http://www.tldp.org/HOWTO/Font-HOWTO/fix.html
When I run this command, I get the following output:

Code:
[madiyaan@r57h63 ~]$ rpm -q freetype
freetype-2.1.9-1.bci
[madiyaan@r57h63 ~]$
When I check my /usr/lib section, I get this:
Code:
[madiyaan@r57h63 lib]$ ls -la libfreetype*
lrwxrwxrwx  1 root root      20 Jan 23 22:05 libfreetype.so.6 -> libfreetype.so.6.3.7
-rwxr-xr-x  1 root root 1236799 Nov 10 22:09 libfreetype.so.6.3.7
[madiyaan@r57h63 lib]$
Seems to me that everything's right. Now I change my gnome options to no hinting and no smoothing and I get very very ugly fonts. As you can see in the screenshot below, I find text EXTREMELY hard to read.

http://www.prism.gatech.edu/~gtg839f...ots/bci_aa.jpg

Can you please help me by telling me what I'm missing?
 
Old 01-23-2005, 10:09 PM   #26
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Original Poster
Rep: Reputation: 55
As I cannot speak for the whether the RPM is indeed correctly compiled, the only thing I can suggest is that you compile from source as I outlined. Looking at your screenshot, it's clear that the bytecode interpreter is either still disabled, or you are still linking to your old lib from your old RPM which likely is the same release of freetype so you won't see a version number difference.

If you are determined not to compile from source and you trust the RPM (you know for a fact that it has worked as advertised for others), then I would uninstall and hunt down every trace of freetype on the box that might have been left behind and delete them. Then reinstall the RPM before rebooting (Gnome will not boot without freetype installed).

I have used my method with Suse in the past - another RPM based distro - and had success. I have also had trouble with Debian Sid, but have not played with it enough to figure why.

Also, I have found that restarting X may not be enough. Try rebooting and/or running ldconfig as root. Other than that, you'll just have to play around with it. An earlier post indicated that it worked for fedora, so we know it's possible.

Good luck.
 
Old 01-24-2005, 07:54 PM   #27
madiyaan
Member
 
Registered: Apr 2003
Posts: 69

Rep: Reputation: 15
I think I figured it out...

I tinkered a bit with freetype2, but was unable to install it properly with bci enabled*. But I figured the guys at the website I quoted earlier in this thread (the site that had a link to the bci enabled) have no motive of fooling people by placing bci-disabled rpm's there.
http://distributions.linux.com/howto...OWTO/fix.shtml
This site.

So I went ahead and browsed my font preferences, went into details, and disabled smoothing, but ENABLED hinting. After all, bci is a type of hinting, I figured.
Now results are way better (by the way, this particular configuration of hinting enabled and smoothing disabled is the monochrome option in the first font config GUI).
Here's the screenshot:
http://www.prism.gatech.edu/~gtg839f...s/bci_mono.png

I think this is the limit Linux can go to. Tell me if this screenshot is up to mark, if not, I guess I'll keep on trying until I succeed. :-) If possible, can you somehow email me a link to the bci-enabled BINARY rpm file? In other words, can you build one for Fedora Core 3? I have AIM so you can transfer it to me thru' there, or email me at my address.






* You said that when I would do ./configure and make, I would get a bunch of messages. I got messages for about 50 seconds (that's a lot of screenful of messages), and many of them were errors. So I could not rebuild my source into binary.
Then I tried a different method; I downloaded .src.rpm and then a rpm -i freetype2.src.rpm. This caused a bunch of files to be copied to /usr/src/redhat/ directory tree. I went into /usr/src/redhat/SPECS and edited the file freetype2.spec. The first line in that spec file had this:
disable bci 1
I changed it to 0, and did rpmbuild -ba freetype2.spec. I got a lot of error messages (which I think are the same as the ones I got with your other method). And again it said that it cannot build the rpm. So I just gave up!
 
Old 01-27-2005, 08:00 AM   #28
sys7em
Member
 
Registered: Oct 2004
Location: Germany
Distribution: Slackware
Posts: 158

Rep: Reputation: 30
Quote:
Originally posted by Idle
I tried what you suggested, including deleting the firefox directory, but nothing works. When I run it from the command line, I get this error:
"/opt/firefox/run-mozilla.sh: line 159: 11701 Segmentation fault "$prog" ${1+"$@"}"

Don't trouble yourself, I'll figure something out. Thanks.
This howto rox .... Thanks Franklin ...
I've follwed everything in this howto ..and now the fonts look great ... but ..When I try to start firefox .,..the following error comes out ...

sys7em@mx:~/firefox$ ./firefox
./run-mozilla.sh: line 451: 11260 Segmentation fault "$prog" ${1+"$@"}
sys7em@mx:~/firefox$

The same error as idle's ...does someone know how to fix that .... In other browser (like mozilla ..which I'm using right now) the fonts look great ...and there is no problems at all ... but firefox crashes ...

sys7em
 
Old 01-27-2005, 03:11 PM   #29
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Original Poster
Rep: Reputation: 55
I think Idle may have solved his problem in another thread in the slackware forum. I have seen in other places where one of the later upgrades in current (glibc ? can't remember) caused a firefox problem as well. One of these was easily fixed by a reinstall of firefox. I use the firefox-installer script from the Mozilla site, but some of the people with issues are using a linuxpackages.net .tgz. I don't know what your situation is, but I have had no issues with firefox at all. Perhaps it the .tgz ?

What many people seem to not realize is that using the slack-10 packages on a current install can cause problems in some packages the farther current gets from the last stable release.

My 2 cents
 
Old 01-27-2005, 07:49 PM   #30
Franklin
Senior Member
 
Registered: Oct 2002
Distribution: Slackware, WinXP, Windows 7
Posts: 1,253

Original Poster
Rep: Reputation: 55
Making Open Office display fonts like the rest of your system.

Now that you've gone to all the trouble of making all your fonts look nice without antialiasing, you go and load OpenOffice and IT DOESN'T BEHAVE!!!

This is easy to fix.

Open up OpenOffice (duh)
Tools-Options-View
Uncheck the box labled "Screen Font Antialiasing" or set your desired range.

Then,

Tools-Options-Accessability
Make sure the "Use system font for user interface" option IS checked.

Done

 
  


Reply

Tags
antialiasing, fonts, howto, openoffice.org, resolution, screen


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
xft2 not antialiased fonts look ugly pijulius Linux - Software 0 02-20-2004 09:53 AM
No antialiased fonts in Mozilla 1.6? misfit-x Linux - Software 13 02-10-2004 06:57 AM
Fuzzy antialiased fonts in Slackware 9.0 Kovacs Slackware 1 11-23-2003 08:12 AM
too blurry antialiased fonts oski Mandriva 4 10-12-2003 01:22 PM
How to make the GDM to use the antialiased fonts? Xterminator Conectiva 1 11-22-2002 08:10 PM


All times are GMT -5. The time now is 05:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration