LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General > LinuxQuestions.org Member Success Stories
User Name
Password
LinuxQuestions.org Member Success Stories Just spent four hours configuring your favorite program? Just figured out a Linux problem that has been stumping you for months?
Post your Linux Success Stories here.

Notices



Reply
 
Search this Thread
Old 09-15-2011, 06:12 PM   #1
TB0ne
Guru
 
Registered: Jul 2003
Location: Birmingham, Alabama
Distribution: SuSE, RedHat, Slack,CentOS
Posts: 15,107

Rep: Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720Reputation: 2720
KDE 4.X and Blueproximity Screen Lock


Running openSUSE 11.4, with KDE 4.6, although this *SHOULD* work on any Linux distro with KDE 4.X.

Since this is about getting Blueproximity to work with KDE4, I'll assume you've already got a working Bluetooth adapter, and know how to pair a device. Also, this assumes you're using one of the KDE Screensavers.

Step one: pair whatever device you have in mind, with your workstation. Doesn't matter what it is, as long as it's paired. In my case, I'm using an iPhone.

Step two: Run blueproximity, and make sure your device is in 'Discoverable' mode. In the "Bluetooth Device" tab, click on the "Scan for devices" button...since your device is discoverable, it'll pop up in a second or two. Then select the device, and click "Use selected device".

Under the "Proximity Details" tab, set the Locking values to 7 and 3, and the Unlocking values to 3 and 2.

Here's where it gets interesting. Since blueproximity is a Gnome application, you've got to tell it to use KDE.

Locking Command - qdbus org.freedesktop.ScreenSaver /ScreenSaver Lock
Unlocking Command - killall -9 kscreenlocker

leave the proximity command alone. Click CLOSE. The app should minimize to the system tray, and you'll see it poll your device every now and then. To test it, you have to take your device away from your workstation, and sit it down...don't just turn Bluetooth on the device off. When you go back to your workstation, the screen saver should be running. To turn it off...go back and get your device, and walk up to your computer, and you should see the screen saver go back off.
 
Old 12-23-2012, 08:30 AM   #2
eldaria
LQ Newbie
 
Registered: Feb 2004
Posts: 22

Rep: Reputation: 15
Proximity

Thank you for this, I was looking for a good solution to get this working and it seems to work.

For Proximity, I have set this one: qdbus org.freedesktop.ScreenSaver /ScreenSaver SimulateUserActivity
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Disable lock session (lock screen) when switch user in KDE 4.x Murz Linux - Desktop 4 12-01-2010 09:28 AM
[SOLVED] KDE 4.4.5 - no lock screen, no screen saver dc_eros Slackware 1 08-23-2010 04:04 PM
kde 3.2 logout/lock screen trollman Linux - Newbie 5 11-14-2004 11:43 PM
kde lock screen shortcut firestomper41 Linux - Software 2 09-17-2004 01:34 PM
Installed KDE 3.2 and no more lock screen... moo083 Linux - Software 2 02-11-2004 12:19 AM


All times are GMT -5. The time now is 02:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration