Go Job Hunting at the LQ Job Marketplace
Go Back > Forums > Linux Forums > Linux - General > LinuxAnswers Discussion
User Name
LinuxAnswers Discussion This forum is to discuss articles posted to LinuxAnswers.


  Search this Thread
Old 05-07-2007, 01:39 PM   #1
Registered: Feb 2007
Location: Dallas
Distribution: Gentoo x86 & x86_64
Posts: 190

Rep: Reputation: 30
Setting up Broadcom wireless networking under Slackware 11

A new la entry has been added:

Setting up Broadcom wireless networking under Slackware 11

I am going to start right off with a warning. These instructions are going to be a bit long-winded. In order to make sure that I am as complete as possible, I will put forth every step I took in getting my wireless network running under Slackware Linux 11.0. Many of these steps will cross over into other Linux distributions. However, some steps and file names are exclusive to Slackware. If you find a file or a directory that isn't in your particular distribution, you will have to know which files in your distribution are analogous to the files named herein.
Old 10-08-2007, 11:33 AM   #2
LQ Newbie
Registered: Aug 2007
Posts: 1

Rep: Reputation: 0
setting up broadcom

Hello Pappy id like to thank u for this , im on slackware 12 , was wondering it its the same , because i get to the point where i have to Type "wpa_supplicant -iwlan0 -c/etc/wpa_supplicant.conf -d, and i get stuck at EAPOL: startWhen --> 0 and it freezes there ???

WPA: Key negotiation completed with 00:13:46:a4:c6:8a [PTK=TKIP GTK=TKIP]
Cancelling authentication timeout
EAPOL: External notification - portValid=1
EAPOL: External notification - EAP success=1
EAP: EAP entering state DISABLED
Old 01-01-2008, 10:58 AM   #3
LQ Newbie
Registered: May 2006
Posts: 1

Rep: Reputation: 0
I ran across the same problem. What I did was to run wpa_cli when the output of the wpa_supplicant stops. I then entered the "passphrase *ssid* *passphrase*" command and everything went honky dory. The wpa_supplicant output started to repeat itself and then I hit cntrl-C in that window. Everything else went on without a hitch. Thanks Pappy for your excellent help!!
Old 01-23-2008, 12:32 PM   #4
LQ Newbie
Registered: Jan 2008
Posts: 1

Rep: Reputation: 0
Thank you!!!

it worked great for me. I have DELL INSPIRON 6400.
Blessings to you.
Old 01-04-2009, 07:07 AM   #5
LQ Newbie
Registered: Sep 2008
Distribution: Kubuntu
Posts: 6

Rep: Reputation: 0
Hey! I have an Acer Aspire 3680 and am running Kubuntu 8.10. I didn't follow your how tow, but then again, that was because I hadn't come across it at the time. However, the steps I performed are the same as 2 of yours, finding the XP Driver and installing ndiswrapper. Prior to that I changed my network manager to Wicd, and that supports WPA, so I didn't install wpa_supplicant.

Excellent how to. Much easier to follow than the ones I came across. I ended up finding multiple instructions that I had to piece together. Wasn't easy being new to linux. This forum is great!

Last edited by shewasoctober; 01-04-2009 at 07:08 AM.
Old 01-14-2009, 09:33 PM   #6
LQ Newbie
Registered: Jan 2009
Posts: 6

Rep: Reputation: 0
whenever i get to the "make" command for ndiswrapper i get this error

make[3]: *** [/root/Desktop/ndiswrapper-1.53/driver/iw_ndis.o] Error 1
make[2]: *** [_module_/root/Desktop/ndiswrapper-1.53/driver] Error 2
make[2]: Leaving directory `/usr/src/linux-'
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/root/Desktop/ndiswrapper-1.53/driver'
make: *** [all] Error 2

any advise?


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Making Broadcom wireless adapters work under Slackware. pappy_mcfae Slackware 0 05-07-2007 02:24 AM
setting up Wireless networking on mandrake 10.1 Darknet7 Linux - Newbie 4 03-15-2005 05:24 PM
Setting wireless networking with mickeyboa Fedora 0 06-06-2004 11:08 AM

All times are GMT -5. The time now is 06:52 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration