LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General > LinuxAnswers Discussion
User Name
Password
LinuxAnswers Discussion This forum is to discuss articles posted to LinuxAnswers.

Notices

Reply
 
Search this Thread
Old 06-03-2004, 11:56 AM   #1
HolyLiaison
LQ Newbie
 
Registered: Feb 2004
Location: Lakeville, MN
Distribution: Fedora Core 1
Posts: 3

Rep: Reputation: 0
Post DISCUSSION: Installing new accelerated Nvidia Linux Drivers in 5 EASY Steps


This thread is to discuss the article titled: Installing new accelerated Nvidia Linux Drivers in 5 EASY Steps
 
Old 06-03-2004, 09:48 PM   #2
General_Tso
Member
 
Registered: Jan 2003
Location: New York, NY, USA
Distribution: Mac OS X (10.4.6), Ubuntu 6.06
Posts: 183

Rep: Reputation: 30
Is this different with Fedora Core 2 and X.org? The "init 3" command didn't work on my machine, so I figured I'd just leave well enough alone until I read some more about it.

--Tso
 
Old 06-04-2004, 12:59 AM   #3
GufyMike
Member
 
Registered: Apr 2004
Location: Los(t) Angeles
Distribution: Fedora Core2, RH9, FreeBSD, Debian, Knoppix,
Posts: 53

Rep: Reputation: 15
General when trying to boot into runlevel 3 in FC2 I find that hitting e and editting the kernel argument in GRUB before booting and adding 3 to the end of it it will boot to CLI without X

kernel /boot/vmlinuz-2.6.6 ro root=LABEL=\

add the 3 to the end so it looks like this:

kernel /boot/vmlinuz-2.6.6 ro root=LABEL=\ 3

Then boot.
 
Old 06-04-2004, 09:09 AM   #4
General_Tso
Member
 
Registered: Jan 2003
Location: New York, NY, USA
Distribution: Mac OS X (10.4.6), Ubuntu 6.06
Posts: 183

Rep: Reputation: 30
Oh, cool. Thanks! Any other divergences from the tutorial for those of us with X.org?

Thanks again,

--Tso
 
Old 06-04-2004, 09:18 AM   #5
GufyMike
Member
 
Registered: Apr 2004
Location: Los(t) Angeles
Distribution: Fedora Core2, RH9, FreeBSD, Debian, Knoppix,
Posts: 53

Rep: Reputation: 15
Well for FC2 its not that simple, you need to recompile a non distro specific kernel and make sure #4KSTACKS and REGPARM are set to NO.

Then install the drivers as HolyLiaison says in his How-To.


For more on compil;ing and installing nvidia drivers on FC2 check this out.
http://www.linuxquestions.org/questi...hlight=REGPARM
 
Old 06-04-2004, 10:16 AM   #6
General_Tso
Member
 
Registered: Jan 2003
Location: New York, NY, USA
Distribution: Mac OS X (10.4.6), Ubuntu 6.06
Posts: 183

Rep: Reputation: 30
Excellent. That'll be my project when I get home from work today. Fedora Core 2 seems faster than FC1 to me, but the display seemed a bit sluggish so I thought the drivers would pep things up.

Thanks again!

--Tso
 
Old 06-09-2004, 01:12 PM   #7
penguin4
Senior Member
 
Registered: May 2004
Location: california
Distribution: mdklinux8.1
Posts: 1,209

Rep: Reputation: 45
HL,GT&GM, Thanks Guys, teaching & learning is what makes any linux distro
the only way to go. learned on W95-W98 wasted time, having to turn to
msw spport for assistance, even then not always correct. they were looking
at books with ms kernel and protocol. oh well 1 given did learn to operate
pc not all lost cause. But wasted time Yes!
 
Old 06-12-2004, 10:24 AM   #8
adonai
LQ Newbie
 
Registered: Jun 2004
Distribution: Slackware
Posts: 22

Rep: Reputation: 15
hi, I just got SuSE 9.0 and I installed the package from http://nvidia.com, it is a package updated on Feb 20, 2004.
I installed it and entered used the #sax2 -m 0=video command
my graphic card is nvidia geforce mx440 and it doesn't work, it is just as it was before, there is a message telling me to download and install the driver from nvidia.com...
I checked the XF86Config file and it's ok
still i can't enable the graphical acceleration..
 
Old 06-26-2004, 01:26 AM   #9
bootsy
LQ Newbie
 
Registered: Jan 2004
Location: Sydney, Aust
Distribution: Suse 9.1
Posts: 27

Rep: Reputation: 15
help - binutils probs

Pls be nice - newbie having lotsa trouble.

Just been trying this install procedure (for about the last 5hours). When I run the NVIDIA-Linux-x86-1.0-4620-pkg1.run

ERROR: Unable to find the system utility `ld`; please make sure you have the
package 'binutils' installed. If you do have binutils installed,
then please check that `ld` is in your PATH.

Ok, so fair enough - I checked and can't find binutils. So I downloaded binutils-2.15.tar.gz and got to work on it. When I go to configure and make I get this error
[root@localhost binutils-2.15]# ./configure

loading cache ./config.cache
checking host system type... i686-pc-linux-gnuoldld
checking target system type... i686-pc-linux-gnuoldld
checking build system type... i686-pc-linux-gnuoldld
checking for a BSD compatible install... /usr/bin/install -c
./configure: line 2343: cc: command not found
*** The command 'cc -o conftest -g conftest.c' failed.
*** You must set the environment variable CC to a working compiler.

So being a good little noobie I went to the Readme and found something that said to try
"CC=gcc ./configure
make

A similar example using csh:

setenv CC gcc
./configure
make"

[root@localhost binutils-2.15]# CC=gcc ./configure
loading cache ./config.cache
checking host system type... i686-pc-linux-gnuoldld
checking target system type... i686-pc-linux-gnuoldld
checking build system type... i686-pc-linux-gnuoldld
checking for a BSD compatible install... /usr/bin/install -c
./configure: line 2232: gcc: command not found
./configure: line 2343: gcc: command not found
*** The command 'gcc -o conftest -g conftest.c' failed.
*** You must set the environment variable CC to a working compiler.


I'm dying here. Anyone who can help - it would be greatly appreciated. Does this mean I don't have something called gcc (yes, you can laugh at what a silly noobie I am) and if so how do I get it.


My system specs are:
Intel P4 3g, nvidia GeForce FX5700, M-audio audiophile 2496, 1g RAM running Fedora Core 1.
 
Old 06-26-2004, 03:34 PM   #10
penguin4
Senior Member
 
Registered: May 2004
Location: california
Distribution: mdklinux8.1
Posts: 1,209

Rep: Reputation: 45
adonai & bootsy; newbie too but have either or both tried the ldp site. this one:http://www.tldp.org/HOWTO/HOWTO-INDEX, scroll through till 4.3hardware then4.3.3 video cards/4.3.9 graphic tablets,on to #5 single list
of HowTos scroll through till finding help there. sorry lots of work but learning is valuable! not easy like Ws but this is not W!?
 
Old 07-06-2004, 08:21 AM   #11
GreenBanditAtWo
LQ Newbie
 
Registered: Jul 2004
Location: Derbyshire, UK
Distribution: MKD10 OE
Posts: 1

Rep: Reputation: 0
Thumbs up How I got nVidia drivers working

Just in case this helps anyone else, my system locked up & totally black screen froze when I tried to restart the GUI & the problem was due to AGPGART incompatabilities.

The solution was to edit the /etc/X11/XF86Config-4 file & add the line
Option "NvAgp" "0"
in the same section as the line
Driver "nvidia" (this line read Driver "nv" prior to editing it as per the nVidia instructions).

If at this point you can't get into the GUI, you might have to use non-GUI editirs such as emacs or vi.

On my system, the relevant part of the XF86Config-4 file is now

Driver "nvidia"
Option "DPMS
Option "NvAgp" "0"
Endsection

You could also try
Option "NvAgp" "1" to get some level of AGP support

I have a SiS741GX chipset & Option "NvAGP" "1" worked for me, but I understand that it might not work for all chipsets.


The rationale behind this is:-
Look at Appendix F of the nVidia README file (on the same page as where their driver is downloaded, currently
http://www.nvidia.com/object/linux_d..._1.0-5336.html
If your chipset is not listed, try what I described above.
 
Old 07-06-2004, 09:44 AM   #12
penguin4
Senior Member
 
Registered: May 2004
Location: california
Distribution: mdklinux8.1
Posts: 1,209

Rep: Reputation: 45
greenbanditatwo; thank you on workaround with nvidia. keep the linux,s
moving! good job!
 
Old 08-16-2004, 03:09 AM   #13
jwwatters
LQ Newbie
 
Registered: Nov 2003
Posts: 9

Rep: Reputation: 0
Similar problem with enabling the #D acceleration with SuSE Linux 9.0

I have gotten everything working with the installation of my NVidia card except that the Sax2 refuses to acknowledge that I do have the drivers from Nvidia installed. When attempting to select the "Enable 3D acceleration" option within Yast2, and Sax2, it tells me I first have to install the drivers from Nvidia.

I've looked over the above threads and checked out their references, but haven't been able to find anything that's helped. Granted some of the stuff is over my head. You can also email me at crackhippo@hotmail.com if you'd like to help.

Thanks.
 
Old 08-17-2004, 11:42 AM   #14
LinuxLala
Senior Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: Fedora 7
Posts: 1,305

Rep: Reputation: 45
Nice read, nice thread discussions. I believe some of you folks could make an entry in Success Stories
 
Old 08-23-2004, 01:32 PM   #15
mkaman
Member
 
Registered: Oct 2003
Location: spain
Distribution: fc2, fc3
Posts: 54

Rep: Reputation: 16
In red hat to change the runlevel is as easy as type "telinit 3" as root. The X systems runs only in the level 5.And "telinit 5" to come back.

I did all the necesary changes in the XF86Config file and i also added this script in the /etc/X11/xinit/xinitrc.d to make all the display configuration changes automaticaly available after each boot:
------------------------------------------------------------------------

#!/bin/sh

#/etc/X11/xinit/xinitrc.d/nvidia-gforce2-mx

#This loads the configuration
nvidia-settings --load-config-only &

-------------------------------------------------------------------------

Once finished i typed "telinit 5" and the nvidia logo appeared in the screen.

But when i shut down the machine and then i restart it an error happen and the X system prompt me with a blue screen saying that there is no screen available.
When i take a loot to the error log i see that the nvidia kernel has failed to initialize. But when i instaled the drivers it worked!!

And this is what happens each time i install the drivers. I re-install, it works, but when i restart i have to re-install.

I'm using an asus motherboard with nforce2 chipset but i haven't installed any driver yet. So i think if this have something to do with my problem.

Any idea of what happens?

RH linux 9
Linux localhost.localdomain 2.4.20-31.9 #1 Tue Apr 13 18:04:23 EDT 2004 i686 athlon i386 GNU/Linux
MB: Asus a7n8x-x
Drivers: NVIDIA-Linux-x86-1.0-6111-pkg1.run
CPU: Athlon xp 2600+
512 MB DDR 400
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DISCUSSION: HOWTO install NVIDIA drivers on FC3 sdat1333 LinuxAnswers Discussion 3 02-10-2006 04:15 AM
6 not so easy steps to linux mdk Linux - Newbie 9 09-01-2004 11:52 PM
Installing NVidia Drivers - Easy? vi0lat0r Slackware 29 03-30-2004 09:09 PM
Accelerated NVidia Drivers (2.6.1) arrruken Slackware 3 01-28-2004 09:53 PM
Problems running accelerated fullscreen with nvidia drivers SilentStrike Linux - Hardware 1 06-28-2003 05:37 PM


All times are GMT -5. The time now is 11:03 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration