LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 05-12-2005, 09:30 PM   #1
worldgnat
Member
 
Registered: Oct 2004
Posts: 337

Rep: Reputation: 30
WPC54G Connects to the router but not the net


I am installing a Linksys WPC54G on SuSE 9.2 with ndiswrapper, and I got it to recognise my wireless router, but the problem now is that when I type:

Code:
ping -c 3 www.yahoo.com
I get

Code:
ping: unknown host www.yahoo.com
Any ideas? I know my WEP key is right, but I may not have the ifcfg-wlan0 file configured. Here it is:

Code:
BOOTPROTO='dhcp'
MTU=''
REMOTE_IPADDR=''
STARTMODE='auto'
USERCONTROL='no'
WIRELESS_AP='linksys'
WIRELESS_AUTH_MODE='WPA_PSK'
WIRELESS_BITRATE='auto'
WIRELESS_CHANNEL='6'
WIRELESS_DEFAULT_KEY='0'
WIRELESS_ESSID='linksys'
WIRELESS_FREQUENCY=''
WIRELESS_KEY='**************************'
WIRELESS_KEY_0='**************************'
WIRELESS_KEY_1=''
WIRELESS_KEY_2=''
WIRELESS_KEY_3=''
WIRELESS_KEY_LENGTH='128'
WIRELESS_MODE='Managed'
WIRELESS_NICK=''
WIRELESS_NWID=''
WIRELESS_POWER='yes'
WIRELESS_WPA_PSK='**************************'
_nm_name='static-0'
I pasted my 128 WEP key (starred out because my parents would shoot me if I pasted the actual key, even though I admin the router) in several places just in case. The

WIRELESS_AUTH_MODE variable is the one that I think is the troublesome one, but if anyone knows otherwise, let me know.

-Peter
 
Old 05-12-2005, 09:32 PM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
Well, if you have associated with the access point, please post the output of both 'iwconfig' and 'ifconfig'. When posting the output of iwconfig, don't forget to obfuscate your key again, please.
 
Old 05-12-2005, 09:51 PM   #3
worldgnat
Member
 
Registered: Oct 2004
Posts: 337

Original Poster
Rep: Reputation: 30
Ok, here's iwconfig:


Code:
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.

wlan0     IEEE 802.11g  ESSID:"linksys"  Nickname:"linux"
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:0C:41:BE:6F:5B
          Bit Rate=54 Mb/s   Tx-Power:25 dBm
          RTS thr=2347 B   Fragment thr=2346 B
          Encryption key:****-****-****-****-****-****-**   Security mode:restricted
cted
          Power Management:off
          Link Quality:100/100  Signal level:-36 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:656   Missed beacon:0
and ifconfig:

Code:
eth0      Link encap:Ethernet  HWaddr 00:90:96:16:8B:EE
          inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::290:96ff:fe16:8bee/64 Scope:Link
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:15492 errors:232 dropped:0 overruns:0 frame:232
          TX packets:3 errors:13667 dropped:0 overruns:0 carrier:30529
          collisions:0 txqueuelen:1000
          RX bytes:16495765 (15.7 Mb)  TX bytes:679 (679.0 b)
          Interrupt:11 Base address:0x1400

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:18910 errors:0 dropped:0 overruns:0 frame:0
          TX packets:18910 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:2206937 (2.1 Mb)  TX bytes:2206937 (2.1 Mb)

wlan0     Link encap:Ethernet  HWaddr 00:12:17:3D:EE:88
          inet addr:192.168.1.103  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::212:17ff:fe3d:ee88/64 Scope:Link
          UP BROADCAST NOTRAILERS RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:1372 errors:0 dropped:0 overruns:0 frame:0
          TX packets:52 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:87818 (85.7 Kb)  TX bytes:12116 (11.8 Kb)
          Interrupt:11 Memory:10800000-10801fff
Hope it means something...

-Peter
 
Old 05-12-2005, 10:18 PM   #4
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
Looks like you are associated and have an IP, which is very good. Is your hardwired network card (eth0) connected to anything? If not, try 'ifconfig eth0 down' and then try to ping again.
 
Old 05-13-2005, 02:50 AM   #5
paul.hugill
LQ Newbie
 
Registered: Feb 2005
Location: London UK
Distribution: Suse 9.1 Pro
Posts: 21

Rep: Reputation: 15
I had the same trouble with this card on Suse 9.2. I figured out that I had to set the DNS and Routing info even tho I had it set to get that info from dhcp. For me this setting was easy Network Device or DNS and Hostname modules in Yast. Hope this helps. I only found this out because KInternet told me it couldnt find any DNS or routing info.
 
Old 05-13-2005, 06:12 AM   #6
baldy3105
Member
 
Registered: Jan 2003
Location: Cambridgeshire, UK
Distribution: Mint (Desktop), Debian (Server)
Posts: 876

Rep: Reputation: 184Reputation: 184
get ping to the internet directly working first, rather than use DNS as its adds a whole layer of potential problems.

Try 158.152.1.65 which is Demons primary DNS server, its always there.

If this fails you have a routing problem so forget DNS for the second.

If you can ping your internet router which I'm guessing is 192.168.1.1 then probably the problem is that the Wireless software seems to have trouble translating the Default Gateway provided by DHCP to a default route in the routing table. If you do 'route' you'll probably find that 0.0.0.0 is missing.

If so do 'route add default gateway 192.168.1.1' and it should all work.
 
Old 05-13-2005, 12:40 PM   #7
worldgnat
Member
 
Registered: Oct 2004
Posts: 337

Original Poster
Rep: Reputation: 30
My eth0 is working fine, in fact my other posts were made using the eth0 device, but the problem is the wlan0. I also have other wireless computers working on the network.

-Peter
 
Old 07-11-2005, 09:10 PM   #8
worldgnat
Member
 
Registered: Oct 2004
Posts: 337

Original Poster
Rep: Reputation: 30
Ok, I scrapped SuSE 9.3 on my laptop, but.... I just installed it on my mom's laptop, and I can connect to the internet, 64.233.161.104 brings me to google in my browser, and I can ping other sites, but..... I can't use DNS. I'm smart enough to read what you said about DNS, but I have no idea how to configure it. As always any help appreciated.

Thanks,
-Peter
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Connects to router, but no internet Lee_B_H Linux - Wireless Networking 4 01-08-2005 08:54 PM
Wireless card connects to lan but not net gbrad Linux - Hardware 0 05-26-2004 10:50 AM
weird...wireless connects to router but not internet apu95 Linux - Wireless Networking 4 04-24-2004 10:24 PM
Net Conncetion / Router / Firewall Help Giallo998 Linux - Networking 2 11-06-2003 12:18 PM
Linux router -Mac connects -WinPC doesnt thepez Linux - Networking 12 09-12-2003 11:21 AM


All times are GMT -5. The time now is 04:22 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration