LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 06-27-2003, 12:46 PM   #121
pijulius
Member
 
Registered: Jun 2003
Distribution: RedHat 9
Posts: 33

Rep: Reputation: 15

Quote:
Originally posted by bkflamer
Hi Julius, did you also set authtype=opensystem ?
I disabled WEP on my network, only changed wepmode=off and I get similar behaviour. If I also change authtype=opensystem it works fine.

Brian
Now yes, but it's not working anyway, i will try out with my one router and wil set no limits (nothing) just a open router to receive signals

Thanks for your help, i will tell you the result of my test.
Julius
 
Old 06-27-2003, 01:37 PM   #122
timmy82
LQ Newbie
 
Registered: Jun 2003
Distribution: debian
Posts: 5

Rep: Reputation: 0
i successfully compiled a new kernel (wow, what many options )

i compiled the driver but when i try the insmod call i get this:
Quote:
# insmod -f rtl8180_24x.o
Warning: loading rtl8180_24x.o will taint the kernel: forced load
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
Segmentation fault
this makes me sad,
have i made something wrong when compiling the kernel???
 
Old 06-27-2003, 03:50 PM   #123
tychob
LQ Newbie
 
Registered: Jun 2003
Location: Tucson, AZ
Distribution: Fedora 9
Posts: 10

Rep: Reputation: 0
Every time you use the -f option you will get that informational message. Ignore it and move forward.
 
Old 06-28-2003, 08:36 AM   #124
pijulius
Member
 
Registered: Jun 2003
Distribution: RedHat 9
Posts: 33

Rep: Reputation: 15
Thumbs up

Hi all

First i want to thank you for all the help i get here, Thanks for all finegan, bkflamer, and all others, i have now successfully tested and now is running my WPC11 ver.4 on the rehdat 9 linux , the problem was that i need to use the original Router that comes with the wireles pcmcia card, i have pluged in the router and the card and all was working fine without any probleme, so it mybe something is wrong with the 54g Router, but for me now this is enought, i have a router and a pcmcia card that are working so Thanks Again and i wish a nice Weekend to all.

Julius

Last edited by pijulius; 06-28-2003 at 08:38 AM.
 
Old 06-29-2003, 10:34 AM   #125
155092376
LQ Newbie
 
Registered: Jun 2003
Posts: 7

Rep: Reputation: 0
How do I make my RTL8180L card ready for hotplug ?
I think I need a line in modules.pcimap.
How ?
 
Old 06-29-2003, 07:52 PM   #126
treth
LQ Newbie
 
Registered: Mar 2003
Distribution: Gentoo
Posts: 14

Rep: Reputation: 0
The end is near!!

Well, interesting news. The RealTek part was right. When you insert a WPC11 v.4 card, you are NOT inserting a Prism II card--you are inserting an RTL8180L card. RealTek has a driver for this processing unit on its website, though I haven't tested it just yet.

ftp://152.104.125.40/cn/wlan/rtl8180...v_v12_rh73.zip

And also. If ANY of you out there see what I have seen, e.g. Linux gurus telling poor, confused newbs that if the card registers as a RealTek anything that it ISN'T a WLAN card . . . be sure to set 'em straight. Nicely.

~Treth
 
Old 06-30-2003, 02:51 AM   #127
ucntcme
Member
 
Registered: Jun 2002
Location: Boise, Idaho
Distribution: RedHat 7.2,8.0,9, RHAS2.1
Posts: 41

Rep: Reputation: 15
Quote:
Originally posted by 155092376
How do I make my RTL8180L card ready for hotplug ?
I think I need a line in modules.pcimap.
How ?
Not sure, hotplug just worked for me.
 
Old 06-30-2003, 05:30 PM   #128
finegan
Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
Quote:
Originally posted by 155092376
How do I make my RTL8180L card ready for hotplug ?
I think I need a line in modules.pcimap.
How ?
First copy the module into /lib/modules/2.4.??/kernel/drivers/net/wireless (actually, anywhere in there after 2.4.?? is fine, but that's where the other kids are.

run:

depmod -a

Now... do you have hotplugging running, hmm... I'm going to assume RedHat, SuSe or Mandrake here: check to see if you have the init script for the hotplugging daemon, it should be living in /etc/rc.d/init.d/ and be called something as simple as "hotplug" or "hotplugging". If you do, then its probably running at startup and all you needed to do was run that depmod.

If not, you can install it from RPM or by hand from source, again for RPMs it depends on distro, if its Debian, its only a few dozen apt-gets away.

Cheers,

Finegan
 
Old 07-03-2003, 10:11 PM   #129
blunck2
LQ Newbie
 
Registered: Jul 2003
Posts: 2

Rep: Reputation: 0
Has anyone gotten this to work with 128bit WEP? (104)?

I try and fail miserably. About to try w/out WEP - am thinking I'll succeed.
 
Old 07-04-2003, 06:25 PM   #130
bostonben
Member
 
Registered: Jun 2003
Location: Boston
Distribution: Red Hat 7.1
Posts: 31

Rep: Reputation: 15
Quote:
I wrote
T\
Incidentally, I'm still running the older version (2003-5-22) of the driver, since the new one won't work for me: I get a "unable to handle kernel paging request" oops in one of the driver's internal functions when I "insmod" it. Sigh.
Well, at least I figured out *why* the new drivers won't work
for me. Late in the 2.4.19 release, somebody added a new field
to the 'struct net_device' type in include/linux/netdevice.h. As a
result, the "priv" field that this driver uses moved. So a "priv_part.o"
compiled against 2.4.18 won't work on a kernel 2.4.20 because
it looks for "priv" in the wrong place (it ends up pulling two 'short'
fields and trying to use them as the priv address), leading to kernel
oops like:

Unable to handle kernel paging request at virtual address 000e0109

Currently, there are 3 versions of the driver on the RealTek site:
rtl8180_linuxdrv_v12_rh73.zip: kernel 2.4.18-3
rtl8180_linuxdrv_v12_rh80.zip: kernel 2.4.18-14
rtl8180_24x_suse82.zip : kernel 2.4.20-4GB

So if you're running a 2.4.20 kernel (and probably any 2.4.19 kernel),
you'll want to use the "Suse" version. If you've got
a 2.4.18 or earlier kernel, try the other two.

I realize this is more than any of you wanted to know...
 
Old 07-05-2003, 01:35 PM   #131
kermy20
LQ Newbie
 
Registered: Jul 2003
Location: Austin, TX
Distribution: RedHat9
Posts: 1

Rep: Reputation: 0
So, I've been struggling to get my WPC11 working over the past couple days on my RedHat9 install.

The compile went fine and I set up the wlanup file, ahd cardctl/lspci seem to recognize the card fine. I was noticing that I was getting No DHCPOFFERS received message when I was trying to actually connect.

I turned on msglevel 2 and crux of the messages is:

RTL8180: Authenticate failed!


I wouldn't have been so suprised if WEP wasn't enabled on the router.
I have:

insmod -f rtl8180_24x.o

/sbin/iwpriv wlan0 msglevel 2
/sbin/iwpriv wlan0 wlan_para ssid2scan=default
/sbin/iwpriv wlan0 wlan_para wepmode=off
/sbin/iwpriv wlan0 wlan_para networktype=infra
/sbin/iwpriv wlan0 wlan_para authtype=opensystem

/sbin/ifconfig wlan0 up
/sbin/iwpriv wlan0 enable


If I check/proc/rtl8180/status, it shows the MAC of my card and of the access point (it gives me the LAN mac, not the Wireless mac, though), so the ssid scan seems to work, but somehow it's not getting a real connection.

The card itself is powered up, but the link light just flashes.


Any ideas?
 
Old 07-09-2003, 07:17 PM   #132
bostonben
Member
 
Registered: Jun 2003
Location: Boston
Distribution: Red Hat 7.1
Posts: 31

Rep: Reputation: 15
Quote:
Originally posted by kermy20


I turned on msglevel 2 and crux of the messages is:

RTL8180: Authenticate failed!


I wouldn't have been so suprised if WEP wasn't enabled on the router.
The 802.11b protocol specifies that an Authenticate frame
gets sent to the AP even if WEP isn't being used. That way the
AP can reject the sender if it doesn't support "opensystem"
clients.

grepping through my old syslogs, I did get this particular message
once, but I can't quite make out what I was doing at the time.
Judging from other messages, it looks like the Authenticate frame
didn't get a response within the drivers time limit (5 seconds), thus
the message.

I'm not really sure why the scan would find your AP but the
Authenticate frame gets lost or it's response delayed.
Maybe you're just near the limit of your AP's range? Maybe
your AP is really slow?
 
Old 07-17-2003, 01:11 PM   #133
sld
LQ Newbie
 
Registered: Jul 2003
Posts: 5

Rep: Reputation: 0
Question adhoc connection problems

Hi,
I've been following this thread and installed RH9 after problems with other distrubutions. But I still can't get my adhoc network to work (without an AP).
Drivers installed OK.

Here is the start-up script I've used:

/sbin/insmod rtl8180_24x.o
/sbin/iwpriv wlan0 wlan_para ssid=mynet
/sbin/iwpriv wlan0 wlan_para ssid2scan=mynet
/sbin/iwpriv wlan0 wlan_para networktype=adhoc
/sbin/iwpriv wlan0 wlan_para authtype=opensystem
/sbin/iwpriv wlan0 wlan_para wepmode=off

#/sbin/iwpriv wlan0 wlan_para hiddenAP=true ??
/sbin/iwpriv wlan0 enable
sleep 10

/sbin/ifconfig wlan0 192,168.0.180 netmask 255.255.255.0

then when I try to ping 192.68.0.1, I get "destination host unreachable".

on my other machine, I can sometimes see a "realtek2" network but i can't connect to it or ping the laptop...

I guess there's not much to do but if you have any ideas, let me know...

Cheers,
Sylvain
 
Old 07-17-2003, 01:28 PM   #134
finegan
Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
This may sound really silly, the whole list looks right, although I just leave out the authtype line as I think the default is "auto" and I think that works right, but...

/sbin/ifconfig wlan0 192.168.0.180 netmask 255.255.255.0 up

Cheers,

Finegan
 
Old 07-17-2003, 02:07 PM   #135
sld
LQ Newbie
 
Registered: Jul 2003
Posts: 5

Rep: Reputation: 0
Hur-ah

well many thanks finegan,
it now works
You are a genius !
or rather I am an idiot , or both

Thanks a lot,
Sylvain
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linksys WPC11 version 4 aover25 Linux - Wireless Networking 5 02-12-2006 10:01 PM
WPC11 version 3 chiatello Linux - Networking 0 10-28-2003 08:32 PM
Linksys WPC11 version 4 kronixx Linux - Networking 1 06-07-2003 09:25 PM
WPC11 Version 4 StarCat Linux - Networking 1 05-03-2003 11:13 AM
Linksys WPC11 Version 3 haqtiq Linux - Networking 3 01-15-2003 10:33 PM


All times are GMT -5. The time now is 11:11 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration