LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 10-11-2003, 05:12 AM   #301
MadMax2ooo
LQ Newbie
 
Registered: Oct 2003
Distribution: Slackware 9.1 / SuSE 8.2
Posts: 1

Rep: Reputation: 0

Hello all!

I've read the whole thread more then one time. But i need more help. I have a No-Name Card with the RTL8180 Chipset.

I have a Slackware 9.1 on a Dell Latitude Laptop.
I've compiled the Kernel Modul from the Realtek Website and copied it to /lib/modules/2.4.22/wlan. So there is no problem.

My wlanup Script looks like the others here in this thread. And dmesg says no error. My "Link" LED blinks, but not my "Tx/Rx" LED.

Why does my WLAN Card not connect to the AP? If you need more Information, so say it, i give all needed informations.

Sorry for my bad english!

Maddy
 
Old 10-11-2003, 02:12 PM   #302
Cimmerian
Member
 
Registered: Sep 2003
Location: Trondheim, Norway
Distribution: Slackware10 + Dropline Gnome
Posts: 47

Rep: Reputation: 15
Hi,

If you are using slackware 9.1, you have to recompile an older kernel than the stock 2.4.22. I had the same problem, everything looked fine, except it didn't work. Compile a 2.4.21 kernel, you can just use the 2.4.22 configuration, and try to compile the module then. It works great here on a dell inspiron 5150 with a linksys wpc card.

Jrgen
 
Old 10-11-2003, 11:52 PM   #303
argh
LQ Newbie
 
Registered: Oct 2003
Posts: 19

Rep: Reputation: 0
You're right, Cimmerian. I'd been down this path before, but apparently not far enough. I had installed the misleading named
kernel-2.4.20-20.9.src.rpm.
It turns out this only contains the patches for a new kernel. After much googling, I finallly determined that if you want the actual source (+ headers needed to compile the driver), you have to get
kernel-source-2.4.20-20.9.i386.rpm.

In case anyone else is banging their head against this, it can be found at
ftp://updates.redhat.com/9/en/os/i386
Good luck trying to find it by using Redhat's search tool.

Well, now that the driver's compiled I guess the real fun starts...


p.s. Is the Cimmerian handle in homage to your new governator?
 
Old 10-12-2003, 04:17 AM   #304
ongakugainochi
LQ Newbie
 
Registered: Jan 2003
Distribution: Debian
Posts: 6

Rep: Reputation: 0
I'm very glad I found this thread as it ended up walking me through mostly everything. It still wasn't the greatest experience as far as hardware and linux goes... but, in the end, I got everything working (104/128 bit wep included.... but no dhcp. Ah well

My experience:

running debian unstable, kernel 2.4.22-1-686 ("debianized" kernel optimized for 686 machines).
Dl'ed the newest driver from the realtek site (updated 9/4/03).
Built according to instructions.
insmoded...
tried some iwpriv stuff. finally enabled... My machine (dell i8500) hardlocked... same as some ppl, my led's were blinking, and absolutely no response.
After playing around with a few options and generally crashing my computer left and right, I decided to try recompiling against a debian 2.4.20 kernel.
So, I apt-get install'ed 2.4.20-3-686 + source + kernel headers.
After some fiddling... (had to recompile my blankety nvidia drivers, and the broadcom driver for the built-in ethernet *sigh*), I threw around some more iwpriv commands, and... it worked. My set of iwpriv commands (note: I'm implying and omitting iwpriv wlan0 wlan_para in the next few lines.

networktype=infra
ssid=<name of my ssid>
channel=<channel #>
ssid2scan=<name of my ssid>
wepmod=wep104
wepkey104_1=<my key>
wepdkeyid=0
authtype=sharedkey

and then I did
ifconfig wlan0 up (probably not necessary, but, it's what I did.

iwpriv wlan0 enable
ifconfig wlan0 <ip> netmas <netmask> up
route add gw <ip>

And.... that did the trick. =) I was able to unplug my ethernet cable and ping,browse,etc., etc., etc. just fine from there. =)
 
Old 10-12-2003, 04:20 AM   #305
ongakugainochi
LQ Newbie
 
Registered: Jan 2003
Distribution: Debian
Posts: 6

Rep: Reputation: 0
Correction: dhcp works fine. I just had to add the interface to /etc/network/interfaces. (I forgot that I had commented it out before. .
 
Old 10-12-2003, 05:53 AM   #306
wacek79
LQ Newbie
 
Registered: Oct 2003
Posts: 7

Rep: Reputation: 0
now i changed my kernel configuration and the card works, it gets an irq assigned and connects to my ap, i didn't even change anything in the wlanup script, and the card has a much better connection than in windows

thanks for your help :-)
 
Old 10-13-2003, 08:44 PM   #307
neoh
LQ Newbie
 
Registered: Oct 2003
Location: Vancouver, BC.
Distribution: Knoppix (debian) 2.2.20 kernel
Posts: 9

Rep: Reputation: 0
alright.. I just have to post.
I have been going through this forum like a bible for the last 16 hours (sleep would be nice!) I am, just like everyone else - trying to get my WPC11 V4 PCMCIA card working.

I have done almost everything I can possibly think of, all the new drivers (through I couldent get the SuSE one, I guess that was discontinued) and still, no luck.

At this point, I really dont know where to go.

I am currently running kernel 2.4.20-3-686
I insmod the rtl GCC 3.x with -f (after editing the makefile to add /usr/src/linux-2.4.20/include) - and it seems to go up.

I battled long and hard to get the pcmcia-cs package working, now that I have pcmcia_core as a module, I can finaly get the card on.

root@angela:/wlan/rtl-3.x# insmod rtl8180_24x.o
rtl8180_24x.o: kernel-module version mismatch
rtl8180_24x.o was compiled for kernel version 2.4.21
while this kernel is version 2.4.20-3-686.
root@angela:/wlan/rtl-3.x# insmod -f rtl8180_24x.o
Warning: kernel-module version mismatch
rtl8180_24x.o was compiled for kernel version 2.4.21
while this kernel is version 2.4.20-3-686
Warning: loading rtl8180_24x.o will taint the kernel: forced load
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
Module rtl8180_24x loaded, with warnings
root@angela:/wlan/rtl-3.x#

And, this is what I get in syslog:

-------- snip ------------------------------------------
Oct 13 18:36:05 angela kernel: ******** RTL8180 Wireless Lan Driver 2003-06-11 loaded********
Oct 13 18:36:05 angela kernel: RTL8180: 03:00.0: region #0 IS a PIO resource!
Oct 13 18:36:05 angela kernel: RTL8180: request_region(0x00004000,0x00000100) !
Oct 13 18:36:05 angela kernel: RTL8180: STA is NOT acting as AP!
Oct 13 18:36:05 angela kernel: RTL8180: LITTLE_ENDIAN memory access
Oct 13 18:36:05 angela kernel: RTL8180: station mode eeprom info
Oct 13 18:36:05 angela kernel: RTL8180: EEpromAddressSize = 8!
Oct 13 18:36:05 angela kernel: RTL8180: eepromID = 0x8129
Oct 13 18:36:05 angela kernel: RTL8180: EEPROMVersion = 0x0102
Oct 13 18:36:05 angela kernel: RTL8180: Tx Power Level, channel 0 = 0x24
Oct 13 18:36:05 angela kernel: RTL8180: Tx Power Level, channel 1 = 0x24
Oct 13 18:36:05 angela kernel: RTL8180: Tx Power Level, channel 2 = 0x24
Oct 13 18:36:05 angela kernel: RTL8180: Tx Power Level, channel 3 = 0x24
Oct 13 18:36:05 angela kernel: RTL8180: Tx Power Level, channel 4 = 0x24
Oct 13 18:36:05 angela kernel: RTL8180: Tx Power Level, channel 5 = 0x24
Oct 13 18:36:05 angela kernel: RTL8180: Tx Power Level, channel 6 = 0x24
Oct 13 18:36:05 angela kernel: RTL8180: Tx Power Level, channel 7 = 0x24
Oct 13 18:36:05 angela kernel: RTL8180: Tx Power Level, channel 8 = 0x24
Oct 13 18:36:05 angela kernel: RTL8180: Tx Power Level, channel 9 = 0x24
Oct 13 18:36:05 angela kernel: RTL8180: Tx Power Level, channel 10 = 0x24
Oct 13 18:36:05 angela kernel: RTL8180: Tx Power Level, channel 11 = 0x24
Oct 13 18:36:05 angela kernel: RTL8180: Tx Power Level, channel 12 = 0x24
Oct 13 18:36:05 angela kernel: RTL8180: Tx Power Level, channel 13 = 0x24
Oct 13 18:36:05 angela kernel: RTL8180: ChannelPlan = 0x0000
Oct 13 18:36:05 angela kernel: RTL8180: RFChipID = 0x0004
Oct 13 18:36:05 angela kernel: RTL8180: EEPROMVersion > 0x0101
Oct 13 18:36:05 angela kernel: RTL8180: AntennaDiversity = TRUE
Oct 13 18:36:05 angela kernel: RTL8180: CSThreshold = 0x000a
Oct 13 18:36:05 angela kernel: RTL8180: DigitalPhy = TRUE
Oct 13 18:36:05 angela kernel: RTL8180: DefaultAntennaB = FALSE
Oct 13 18:36:05 angela kernel: RTL8180: CSMethod = RCR_EnCS1
Oct 13 18:36:05 angela kernel: RTL8180: wlan driver loaded. ioaddr=0x4000, irq=11, MAC_addr=0:6:25:2e:fb:4
-------- snip ------------------------------------------

So, now that the module is loaded:
Module Size Used by Tainted: GF
rtl8180_24x 244112 0 (unused)

I can now show the ifconfig info:

root@angela:/wlan/rtl-3.x# ifconfig wlan0
wlan0 Link encap:Ethernet HWaddr 00:06:25:2E:FB:04
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:11 Base address:0x4000


Now, this is a new error I have been getting:

root@angela:/wlan/rtl-3.x# iwpriv wlan0 wlan_para ssid2scan=linksys
Invalid command : wlan_para

I tried reloading the wireless-tools package, no luck.

If I run iwpriv on its own, I get this new jargon;

-------- snip ------------------------------------------
root@angela:/wlan/rtl-3.x# iwpriv
lo no private ioctls.

eth0 no private ioctls.

wlan0 Available private ioctl :
P?q (0000) : set 1159 & get 0
s@s@ (BFFFEB60) : set 319 (null) & get 0 int
(0000) : set 32 & get 0
U@ (40052060) : set 1088 byte & get 4 int
z (40015774) : set 888 & get 5 int
N@ (4004B160) : set 960 addr & get 2047
`@U@ (3F8AD4FB) : set 0 & get 0
s@0?q (BFFFEC20) : set 319 (null) & get 0 int
(804856C) : set 32 & get 0
U@ (40052060) : set 1088 byte & get 4 int
z (40014ED4) : set 1434 & get 4
N@ (80483C4) : set 1152 addr & get 2047
X@ (0001) : set 2 & get 0
a@{ (BFFFECA8) : set 911 (null) & get 10 int
@ (0000) : set 569 addr & get 1 int
f (0001) : set 0 & get 0
j (0001) : set 0 & get 0
`@
(BFFFED80) : set 123 & get 0
-------- snip ------------------------------------------

If I run iwconfig for it, i get this:

-------- snip ------------------------------------------
root@angela:/wlan/rtl-3.x# iwconfig wlan0
Warning: Driver for device wlan0 has been compiled with version 0
of Wireless Extension, while this program is using version 16.
Some things may be broken...

wlan0 ESSIDff/any Nickname:""
NWID:0 Channel:0 Access Point: FF:BF:21:00:00:00
Bit Rate=-1.07374e+06kb/s Tx-Power=-1073743228 dBm Sensitivity:0/0
Retryn RTS thr=-1073743228 B Fragment thr=-1073743228 B
Encryption key:0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000-0000
Power Managementn
-------- snip ------------------------------------------

iwspy looks like this:

wlan0 Statistics collected:
FF:BF0:AD:00:40 : Quality:0/0 Signal level:-62 dBm Noise level:-252 dBm
00:00:BE:61:01:40 : Quality:144/0 Signal level:-7 dBm Noise level:-1 dBm (updated)
FF:BF:BE:61:01:40 : Quality:255/0 Signal level:-253 dBm Noise level:-256 dBm
00:00:39:62:01:40 : Quality:10 Signal level:0 Noise level:0
00:00:00:C2:04:08 : Quality:1 Signal level:0 Noise level:0
04:08:90:F9:FF:BF : Quality:0 Signal level:0 Noise level:0
00:00:00:00:00:00 : Quality:80/0 Signal level:-75 dBm Noise level:-252 dBm
FF:BF:F8:0F:17:40 : Quality:1 Signal level:0 Noise level:0




When I restart pcmcia (/etc/init.d/pcmcia restart) - I get the following:

Oct 13 18:40:45 angela kernel: Yenta IRQ list 06b8, PCI irq11
Oct 13 18:40:45 angela kernel: Socket status: 30000020
Oct 13 18:40:45 angela kernel: Yenta IRQ list 06b8, PCI irq11
Oct 13 18:40:45 angela kernel: Socket status: 30000006
Oct 13 18:40:46 angela kernel: cs: cb_alloc(bus 3): vendor 0x10ec, device 0x8180
Oct 13 18:40:46 angela kernel: PCI: Enabling device 03:00.0 (0000 -> 0003)
Oct 13 18:40:46 angela kernel: PCI: Setting latency timer of device 03:00.0 to 64
Oct 13 18:40:46 angela kernel: RTL8180: 03:00.0: region #0 IS a PIO resource!
Oct 13 18:40:46 angela kernel: RTL8180: request_region(0x00004000,0x00000100) !
Oct 13 18:40:46 angela kernel: RTL8180: STA is NOT acting as AP!
Oct 13 18:40:46 angela kernel: RTL8180: LITTLE_ENDIAN memory access
Oct 13 18:40:46 angela kernel: RTL8180: station mode eeprom info
Oct 13 18:40:46 angela kernel: RTL8180: EEpromAddressSize = 8!
Oct 13 18:40:46 angela kernel: RTL8180: eepromID = 0x8129
Oct 13 18:40:46 angela kernel: RTL8180: EEPROMVersion = 0x0102
Oct 13 18:40:46 angela kernel: RTL8180: Tx Power Level, channel 0 = 0x24
Oct 13 18:40:46 angela kernel: RTL8180: Tx Power Level, channel 1 = 0x24
Oct 13 18:40:46 angela kernel: RTL8180: Tx Power Level, channel 2 = 0x24
Oct 13 18:40:46 angela kernel: RTL8180: Tx Power Level, channel 3 = 0x24
Oct 13 18:40:46 angela kernel: RTL8180: Tx Power Level, channel 4 = 0x24
Oct 13 18:40:46 angela kernel: RTL8180: Tx Power Level, channel 5 = 0x24
Oct 13 18:40:46 angela kernel: RTL8180: Tx Power Level, channel 6 = 0x24
Oct 13 18:40:46 angela kernel: RTL8180: Tx Power Level, channel 7 = 0x24
Oct 13 18:40:46 angela kernel: RTL8180: Tx Power Level, channel 8 = 0x24
Oct 13 18:40:46 angela kernel: RTL8180: Tx Power Level, channel 9 = 0x24
Oct 13 18:40:46 angela kernel: RTL8180: Tx Power Level, channel 10 = 0x24
Oct 13 18:40:46 angela kernel: RTL8180: Tx Power Level, channel 11 = 0x24
Oct 13 18:40:46 angela kernel: RTL8180: Tx Power Level, channel 12 = 0x24
Oct 13 18:40:46 angela kernel: RTL8180: Tx Power Level, channel 13 = 0x24
Oct 13 18:40:46 angela kernel: RTL8180: ChannelPlan = 0x0000
Oct 13 18:40:46 angela kernel: RTL8180: RFChipID = 0x0004
Oct 13 18:40:46 angela kernel: RTL8180: EEPROMVersion > 0x0101
Oct 13 18:40:46 angela kernel: RTL8180: AntennaDiversity = TRUE
Oct 13 18:40:46 angela kernel: RTL8180: CSThreshold = 0x000a
Oct 13 18:40:46 angela kernel: RTL8180: DigitalPhy = TRUE
Oct 13 18:40:46 angela kernel: RTL8180: DefaultAntennaB = FALSE
Oct 13 18:40:46 angela kernel: RTL8180: CSMethod = RCR_EnCS1
Oct 13 18:40:46 angela kernel: RTL8180: wlan driver loaded. ioaddr=0x4000, irq=11, MAC_addr=0:6:25:2e:fb:4
Oct 13 18:40:46 angela cardmgr[925]: watching 2 sockets
Oct 13 18:40:46 angela kernel: cs: IO port probe 0x0c00-0x0cff: clean.
Oct 13 18:40:46 angela kernel: cs: IO port probe 0x0820-0x08ff: clean.
Oct 13 18:40:46 angela kernel: cs: IO port probe 0x0800-0x080f: clean.
Oct 13 18:40:46 angela kernel: cs: IO port probe 0x0100-0x04ff: excluding 0x378-0x37f 0x480-0x48f 0x4d0-0x4d7
Oct 13 18:40:46 angela kernel: cs: IO port probe 0x0a00-0x0aff: clean.
Oct 13 18:40:46 angela cardmgr[927]: starting, version is 3.2.2
Oct 13 18:40:46 angela cardmgr[927]: socket 0: CardBus hotplug device
Oct 13 18:40:46 angela pci.agent[924]: ... no modules for PCI slot 03:00.0
Oct 13 18:41:00 angela modprobe: modprobe: Can't locate module -a
Oct 13 18:41:00 angela modprobe: modprobe: Can't locate module -a
Oct 13 18:41:03 angela modprobe: modprobe: Can't locate module wlam0



I am so confused, and so lost.
All the other modules I try to install lock up my machine.

I didint have this problemin 2.4.22-xfs, I could ping my ip (card would flash) - but nothing would work, no matter what I tried. tcpdump reported it would constantly do arp requests (millions of them)

I'm at a loss.
Is there another package I should be installing?

If I run wlanup, it gets an ip address, shows wlan0, then I get a NULL pointer kernel panic and need to restart my machine.

Luckily I use ext3, or this would be a very lengthy process.

Someone, please help! :\ I am dying here!

- neoh
 
Old 10-14-2003, 01:49 AM   #308
neoh
LQ Newbie
 
Registered: Oct 2003
Location: Vancouver, BC.
Distribution: Knoppix (debian) 2.2.20 kernel
Posts: 9

Rep: Reputation: 0
aha..
I got it.

I found the old SuSE module and insmoded it - insmoded fine, iwpriv worked from there, and had no other problems.

In fact, I tried all the steps on a different machine (fresh install) - got it working in about 8 minutes.

.. maybe i'll write a HOWTO?


 
Old 10-14-2003, 01:27 PM   #309
KBellve
LQ Newbie
 
Registered: Oct 2003
Posts: 1

Rep: Reputation: 0
Ok...I have followed the discussion and thanks to it, I have gotten a RWL-650 working in DHCP and in static mode.

The question I have is how to integrate it into Redhat's Network Device control?

This is for a nonlinux user who needs to switch between DHCP and static IPs depending upon her location. I am a linux user but I wont be around to help her all the time.
 
Old 10-14-2003, 02:01 PM   #310
davidfrahm
LQ Newbie
 
Registered: Sep 2003
Location: United States
Distribution: Red Hat 9
Posts: 4

Rep: Reputation: 0
That's what the wlanup and wlandown scripts are for. I combined them into a service script in init.d, but if you want to choose then you wouldn't want to run it as a service.

Although if most of the time you run one configuration then you could just run that as a service and just manually stop it and run another script when you needed the other configuration.

PS
I am a total Linux newbie, so take my advice with caution ;-) All I know is what worked for me on one Dell laptop using default RH9.
 
Old 10-14-2003, 11:39 PM   #311
halmsx
LQ Newbie
 
Registered: Oct 2003
Posts: 2

Rep: Reputation: 0
wpc0101+slack9.1

heyyah,


previously i wuz on slack9.0, i used the driver i got in the cd that comes with my wpc11 card, it worked fine with 'insmod -f' command...


now that i upgraded to slack9.1, when i tried to use the same driver, i couldnt get into the AP. i tried to compile it, but got these errors...


gcc -O6 -Wall -DMODULE -D__KERNEL__ -DLINUX -I /usr/src/linux/include/ -DRTL_IO_MAP -DRTL_LITTLE_ENDIAN -DRTL_ACT_AS_STA -c -o r8180_pci_init.o r8180_pci_init.c
In file included from r8180_pci_init.c:40:
r8180_if.h:87: syntax error before '*' token
r8180_if.h:88: syntax error before '*' token
r8180_if.h:89: syntax error before '*' token
make: *** [r8180_pci_init.o] Error 1


im not that good at gcc, anyone can help?


later, i dloaded the new driver i found in realtek's website, and tried to use the ones for gcc3 compiler, loaded it up, but this time, i too only managed to get the link light blinking...
RTL8180: Turn on RTL_DDEBUG_OUTINFO
RTL8180: ------ Enable wlan driver ------
RTL8180: WLAN driver version 1.3
RTL8180: wireless LAN controller RTL8180 + philips RF.
RTL8180: PHILIPS_Config()
RTL8180: PHILIPS_Config() - Analog mode
RTL8180: ENABLE_RTL_DCST
RTL8180: Set dot11PrivacyInvoked = 0.
RTL8180: encryptmode = RTL_ENC_NONE
RTL8180: wepkeymode = WEP_MODE_OFF
RTL8180: Select a BSS and Join it at channel 6.
RTL8180: ----------------------------------------------------------
RTL8180: wlan0 Link status:
RTL8180: Channel number = 6
RTL8180: beacon period = 100
RTL8180: BSSID = 0x00:0xc0:0x02:0xdc:0x61:0x5c
RTL8180: SSID = m3m
RTL8180: Capability = 0x41
RTL8180: AID = 0x03
RTL8180: Operational rate = 0x0F <bit 0~3 = 1~11 Mbps>
RTL8180: ----------------------------------------------------------


ok, its up... but how come im not connected? uh? its just the link light blinkin'...


halms/
 
Old 10-15-2003, 02:32 AM   #312
neoh
LQ Newbie
 
Registered: Oct 2003
Location: Vancouver, BC.
Distribution: Knoppix (debian) 2.2.20 kernel
Posts: 9

Rep: Reputation: 0
halsx,

this is where you do the iwpriv commands.

my script to get everything up and running is the following:

#!/bin/sh
insmod -f suse/rtl8180_24x.o
iwpriv wlan0 wlan_para ssid=linksys
iwpriv wlan0 wlan_para ssid2scan=linksys
iwpriv wlan0 wlan_para channel=6
iwpriv wlan0 wlan_para wepmode=off
iwpriv wlan0 wlan_para networktype=infra
iwpriv wlan0 enable
ifdown eth0
pump -i wlan0
ifconfig wlan0 10.0.0.101 netmask 255.255.255.0
route add default gw 10.0.0.1
ping google.com

exit 1

I got it running with kernel 2.4.20, but no others for some reason.
Nor could I get it running with the drivers from the linksys website. I found the drivers from some chinese website, and they worked magically.

I have it at http://users.resentment.org/neoh/rtl8180_24x_SuSE.zip

wget it, unzip it, edit the Makefile to point to the linux-2-4.20 (or whatever kernel you have)'s dir.. then make, then use insmod -f rtl8180_24x.o

should work fine.

give it a try.

- neoh
 
Old 10-15-2003, 03:36 AM   #313
halmsx
LQ Newbie
 
Registered: Oct 2003
Posts: 2

Rep: Reputation: 0
heyyah,


thanks fer the reply, but still havink the same problem. the module seems to load up well... ok, but the iwpriv commands returns these...


Code:
RTL8180:  ------ Enable wlan driver ------
RTL8180: wireless LAN controller RTL8180 + philips RF.
RTL8180: PHILIPS_Config() 
RTL8180: PHILIPS_Config() - Analog mode
RTL8180: ENABLE_RTL_DCST
RTL8180:  Set dot11PrivacyInvoked = 0. 
RTL8180:  encryptmode = RTL_ENC_NONE
RTL8180:  wepkeymode = WEP_MODE_OFF
RTL8180: Scan PHY channel number = 1
RTL8180: Scan PHY channel number = 2
RTL8180: Scan PHY channel number = 3
RTL8180: Scan PHY channel number = 4
RTL8180: Scan PHY channel number = 5
RTL8180: Scan PHY channel number = 6
RTL8180: Scan PHY channel number = 7
RTL8180: Scan PHY channel number = 8
RTL8180: Scan PHY channel number = 9
RTL8180: Scan PHY channel number = 10
RTL8180: Scan PHY channel number = 11
RTL8180: Neither joining a BSS or starting an IBSS

uh? bug sumeher? i did the commands just as yours, except the ssid & ssid2scan is m3m, my AP.


is this caused by the module or whut? im not sure, tries to recompile source code fro the zip file ya gave, i got this...

root@m3vaio:/home/halmi/stor/tmp# make
gcc -O6 -Wall -DMODULE -D__KERNEL__ -DLINUX -I /usr/src/linux/include/ -DRTL_IO_MAP -DRTL_LITTLE_ENDIAN -DRTL_ACT_AS_STA -c -o r8180_pci_init.o r8180_pci_init.c
In file included from r8180_pci_init.c:40:
r8180_if.h:87: syntax error before '*' token
r8180_if.h:88: syntax error before '*' token
r8180_if.h:89: syntax error before '*' token
make: *** [r8180_pci_init.o] Error 1





halms/
 
Old 10-15-2003, 11:37 PM   #314
neoh
LQ Newbie
 
Registered: Oct 2003
Location: Vancouver, BC.
Distribution: Knoppix (debian) 2.2.20 kernel
Posts: 9

Rep: Reputation: 0
what kernel are you running?
when you typed the iwpriv commands, did it give anything back?


- neoh
 
Old 10-16-2003, 03:42 AM   #315
rdicosmo
LQ Newbie
 
Registered: Oct 2003
Location: France
Distribution: Debian, Mandrake
Posts: 2

Rep: Reputation: 0
Hi everybody, I own a Peabird wireless card that has a nice "Linux supported"
line on the box, yet I tried all the drivers over the past 4 months and all of them
simply froze my machine after a few seconds (vanilla kernel 2.4.20 here, there
is a post on linux-kernel reporting the same problem on 2.4.22)...

I eneded up politely protesting with RealTek, asking them to make the driver open source, or to release the specification... Up to now they did not make the driver open source, but
they sent me the full specifications, that I uploaded to http://www.dicosmo.org/RTL8180spec_1_3.pdf

If there is anybody willing to start adapting another driver using these specs, so we will have finally a real, efficient, full fledged open source driver for our cards, he is very
welcome to get the documentation, and I am also happy to lend a hand...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linksys WPC11 version 4 aover25 Linux - Wireless Networking 5 02-12-2006 10:01 PM
WPC11 version 3 chiatello Linux - Networking 0 10-28-2003 08:32 PM
Linksys WPC11 version 4 kronixx Linux - Networking 1 06-07-2003 09:25 PM
WPC11 Version 4 StarCat Linux - Networking 1 05-03-2003 11:13 AM
Linksys WPC11 Version 3 haqtiq Linux - Networking 3 01-15-2003 10:33 PM


All times are GMT -5. The time now is 02:00 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration