LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 09-15-2003, 04:51 PM   #241
darrellk
LQ Newbie
 
Registered: Sep 2003
Location: Sussex, UK
Posts: 5

Rep: Reputation: 0

For the drivers, go to http://www.edimax.com, click on "downloads" and they're all listed. There is one driver package per card, Mine (the EW-7126, which is a PCI card and not a PC card) contains drivers for Redhat 7.1, 7.2, 7.3, 8.0 and 9.0, and Suse 8.2).

For each distribution there is a ready made driver, plus the source for the "open" part, and the closed-source object. Recompiling certainly helped me, even though there was a ready-made driver for my distribution. The makefile incorporates the closed source object into the newly compiled driver. This is a bit of a compromise, 'cos you are still dependent on the kernel used to compile the "secret" bit.

Yet another piece of software which makes it difficult to upgrade my kernel in the future. They really must open-source this stuff!

As far as my scripts are concerned, I used the ones supplied in the above-mention packages, and simply added a line to create a default routing entry. didn't need to do a thing with any additional iwpriv commands.

I do still have an issue which I discovered after my previous post. If you bring down the wlan link on the box, it won't come up again, and this seems to be because my AP still thinks the connection is active. Once the AP is rebooted, it works again. I'm looking for a command I can send the AP from the wlandown script to force it to drop the session, or maybe there is a timeout that can be set at the AP end. My AP is a US Robotics 2249. I'll post again when I've solved this issue.
 
Old 09-16-2003, 01:51 PM   #242
tonyg_2
LQ Newbie
 
Registered: Sep 2003
Posts: 2

Rep: Reputation: 0
Hey folks,

I have been reading this thread for two days now, and have tried everything. I have tried v1.2 drivers (uncommenting the typecast), and v1.3 drivers. I have downloaded them from realtek, edimax, and 152.104.124.40.

I am running kernel 2.4.20-gentoo-r5 on a 500 mhz PIII Dell-latitude labtop.

I have had no problems compiling or loading the drivers.
dmesg gives me this:

******** RTL8180 Wireless Lan Driver Version 1.1 <2003-05-22> loaded********
PCI: Setting latency timer of device 06:00.0 to 64
RTL8180: 06:00.0: region #0 IS a PIO resource!
RTL8180: request_region(0x00004800,0x00000100) !
RTL8180: STA is NOT acting as AP!
RTL8180: LITTLE_ENDIAN memory access
RTL8180: station mode eeprom info
RTL8180: EEpromAddressSize = 8!
RTL8180: eepromID = 0x8129
RTL8180: EEPROMVersion = 0x0102
RTL8180: Tx Power Level, channel 0 = 0xd0
RTL8180: Tx Power Level, channel 1 = 0xd0
RTL8180: Tx Power Level, channel 2 = 0xd0
RTL8180: Tx Power Level, channel 3 = 0xd0
RTL8180: Tx Power Level, channel 4 = 0xd0
RTL8180: Tx Power Level, channel 5 = 0xd0
RTL8180: Tx Power Level, channel 6 = 0xd0
RTL8180: Tx Power Level, channel 7 = 0xd0
RTL8180: Tx Power Level, channel 8 = 0xd0
RTL8180: Tx Power Level, channel 9 = 0xe0
RTL8180: Tx Power Level, channel 10 = 0xe0
RTL8180: Tx Power Level, channel 11 = 0xe0
RTL8180: Tx Power Level, channel 12 = 0xe0
RTL8180: Tx Power Level, channel 13 = 0xe0
RTL8180: ChannelPlan = 0x0002
RTL8180: RFChipID = 0x0003
RTL8180: EEPROMVersion > 0x0101
RTL8180: AntennaDiversity = TRUE
RTL8180: CSThreshold = 0x000b
RTL8180: DigitalPhy = FALSE
RTL8180: DefaultAntennaB = FALSE
RTL8180: CSMethod = RCR_EnCS1
RTL8180: wlan driver loaded. ioaddr=0x4800, irq=11, MAC_addr=0:c:5b:4c:d5:c9

however, when I try to run iwpriv, it tells me that wlan0 has no ioctls. I cannot figure out how to fix this. I am completely lost, and very very frustrated.

Anyone have any ideas?
thank you,
Tony G.
 
Old 09-16-2003, 10:38 PM   #243
darrellk
LQ Newbie
 
Registered: Sep 2003
Location: Sussex, UK
Posts: 5

Rep: Reputation: 0
it's getting complicated...

Since my last post I have discovered the following:

My suspicion about a problem being caused by the Access Point not "hanging up" when a connection is dropped by rebooting the client, for example, is a red herring.

Just to say, my AP is a US Robotics 2249, although I really don't think at the moment that this is important.

What is actually happening in my case is quite strange, and I still don't know why, but I have put together a really horrible hack which has got my connection working fairly consistently. I will describe my findings in some detail, so that hopefully someone with more Linux knowledge than me can gain some insight from them. (I know the IBM AS/400 inside out, but can only dabble with Linux at the moment!)

EDIMAX MODULE

insmod the module provided by Edimax.
iwpriv wlan0 wlan_para ssid2scan=USR2249
iwpriv wlan0 wlan_para networktype=infra
iwpriv wlan0 enable
ifconfig wlan0 172.16.1.99

the result of this in dmesg, messages, or whatever, includes a set of messages saying "RTL8180: Scan PHY channel number = ...", followed by "RTL8180: Neither joining a BSS or starting an IBSS"

No connection to the AP is established.

REALTEK MODULE

insmod the module provided by Realtek.
iwpriv wlan0 wlan_para ssid2scan=USR2249
iwpriv wlan0 wlan_para networktype=infra
iwpriv wlan0 enable
ifconfig wlan0 172.16.1.99

messages report "TX Power Level, channel 0 = 0xdd" etc, for each channel. Then there is an endless cycle of "connected, authentication failure, roaming reconnected", etc.

The card is connecting and reconnecting to the AP about every 4 or 5 seconds, resulting in an intermittent network connection, with packets being lost all over the place.


Right, my horrible hack involves making use of both the Edimax and Realtek modules!!!!!! - and there is further weirdness as reported below. The following works for me:

1. Start with a freshly hard-booted machine.

2. insmod the Realtek module

3. iwpriv wlan0 enable

4. iwpriv wlan0 disable

5. rmmod the Realtek module

6. insmod the Edimax module

7. iwpriv wlan0 wlan_para ssid2scan=USR2249 (ie my AP's SSID)

8. iwpriv wlan0 wlan_para networktype=infra

9. iwpriv wlan0 enable

10. ifconfig wlan0 172.16.1.99

11. route add default gw 172.16.1.1

--- at this point network connectivity is achieved over the wireless link. But I haven't finished yet. If I bring the link down and then bring it up again:

iwpriv wlan0 disable
iwpriv wlan0 enable

- I get an "authentication failed" message in the log. So I issue a second "iwpriv wlan0 enable" command, and it works again. Only every second call of "iwpriv wlan0 enable" works. And this sequence is remembered by the machine across hard reboots and it doesn't matter if I issue an "iwpriv wlan0 disable" inbetween, or not.

The final twist in the tale is that after a soft reboot, steps 2, 3, 4 and 5 - the Realtek driver stuff, is NOT required. This is only needed once per hard reboot of the machine. Remember, I am removing the realtek module almost as soon as i've loaded it anyway, so it seems that iwpriv with the realtek module loaded is kicking off some process or setting some variable which is maintained until a hard reboot.

Two other things:

The message "be in station mode in start_xmit" appears in the log whether the connection is working or not, whenever an action calling on the wireless connection (browser, ping, ntp, etc) is initiated.

And I see the message "RTL8180: Re-activating netif" on the console as more or less the last message before the system shuts down or reboots. Has this got anything to do with what's going on? Is this some really horrible low level socket stuff? This message also appears if the wlan0 interface is brought down when the RTL8180 PCI driver is still active.

I'm going to try some stuff like compiling the Edimax open source part with the Realtek closed object, and vice versa, but for now, my brain hurts, so bye-bye.

Darrell.
 
Old 09-17-2003, 04:58 PM   #244
quiescere
Member
 
Registered: Sep 2003
Distribution: Slackware64 13.1
Posts: 52

Rep: Reputation: 15
Netgear MA521 locks system

Okay, having read this thread (and the MA521 thread elsewhere) here's my experience with this card:

Downloaded the 1.3 (gcc 3x) driver from Realtek, compiled, installed, loaded. No problems. (can provide the dmesg and /proc/rtl8180/status info if anyone cares, but really.)

iwpriv wlan0 ssid2scan=aptest
iwpriv wlan0 networktype=infra
iwpriv wlan0 enable

dmesg says:
RTL8180: ------ Enable wlan driver ------
RTL8180: WLAN driver version 1.3
RTL8180: wireless LAN controller RTL8180 + philips RF.
RTL8180: PHILIPS_Config()
RTL8180: PHILIPS_Config() - Analog mode
RTL8180: ENABLE_RTL_DCST
RTL8180: Set dot11PrivacyInvoked = 0.
RTL8180: encryptmode = RTL_ENC_NONE
RTL8180: wepkeymode = WEP_MODE_OFF
RTL8180: Select a BSS and Join it at channel 1.
RTL8180: ----------------------------------------------------------
RTL8180: wlan0 Link status:
RTL8180: Channel number = 1
RTL8180: beacon period = 100
RTL8180: BSSID = 0x00:0x30:0xab:0x1f:0xf3:0xe4
RTL8180: SSID = aptest
RTL8180: Capability = 0x01
RTL8180: AID = 0x01
RTL8180: Operational rate = 0x0F <bit 0~3 = 1~11 Mbps>
RTL8180: ----------------------------------------------------------

So far, no problems. The system can stay up in this state indefinitely.

Now the fun begins:
dhcpcd -n wlan0
gets me nothing, and will lock the system fairly quickly.
ifconfig wlan0 192.168.0.102
seems to work, but doesn't. I can't even ping the interface IP, much less communicate externally.
ifconfig wlan down
will also lock the system. blinking caps and link lights, same as everyone else.

system: toshiba 2545xcdt, 333MHz K6, gcc 3.2, glibc 2.2.5, APM (no ACPI), kernel 2.4.22. Fairly heavily customised Slackware 8.1 laptop connecting to a Netgear MR314. WEP off for these tests.

Any suggestions, requests for more information, whatever? As soon as I see an ACPI patch for my version of the 2.4.22 kernel I'll try that, as some other Toshiba user mentioned that it helped them.

O, and if, after the enable step, you get a logging of attempts to connect in your syslog, double check that your card's MAC address is listed in your router's access filter. I lost two days to that stupid oversight.
 
Old 09-17-2003, 08:15 PM   #245
steelhoof
LQ Newbie
 
Registered: Aug 2003
Posts: 1

Rep: Reputation: 0
I just got this from Linksys, hope it helps clarify things.

The WPC11 version/chipset breakdown is as follows:

WPC11 ver 1 = Prism 2.0 chipset
WPC11 ver 2.5 = Prism 2.5 chipset
WPC11 ver 3.0= Prism 3.0 chipset
WPC11 ver 4.0 = Realtek RTL8180L chipset.

The Linux drivers on the Realtek website will work for WPC11 ver 4.0.

Linux kernel 2.4.X (gcc version 2.96) ftp://152.104.125.40/cn/wlan/rtl8180...0_linuxdrv_v13(gcc2.9x).zip

Linux kernel 2.4.x (gcc version 3.xx) ftp://152.104.125.40/cn/wlan/rtl8180...0_linuxdrv_v13(gcc3.xx).zip

Happy War Driving!
Bill
 
Old 09-18-2003, 01:41 AM   #246
syeh
LQ Newbie
 
Registered: Sep 2003
Posts: 2

Rep: Reputation: 0
I've been following this thread, but I'm confused: my WPC11 is
version 4, and "cardctl ident" tells me its "rtl8139", should I use
driver for 8180 or 8139? Thanks.
 
Old 09-18-2003, 04:37 AM   #247
finegan
Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
This is a cardbus card, so cardmgr doesn't need to read the ident off of the card to load the module, its IDs as a cardbus card and so cardmgr just loads cb_alloc and its part of the PCI devices from then on. That's why a normal pcmcia device doesn't appear under /sbin/lspci, but a cardbus card does.

With the device as a normal PCI device, hotplugging comes into it, and then hopefully loads the module. With most cards coming out as cardbus devices, now nearly everything pluggable: usb, scsi-emulated, firewire and pcmcia cards will all be controlled by the hotplugging daemon so you don't have to either A) insmod it by hand, B) rely on some nasty mess like Kudzu or Yast2, and C) have to have it be a seperate mess like pcmcia-cs.

Cheers,

Finegan
 
Old 09-18-2003, 10:09 AM   #248
syeh
LQ Newbie
 
Registered: Sep 2003
Posts: 2

Rep: Reputation: 0
Thanks. Well, but my question was which driver I should download from realtek? I'm running RH9 (2.4.20-8, gcc2.96) and not sure which one
driver from realtek should I installed?
linux24x-8139cp(160).zip (dated 2003/06/16)
or
rtl8180_linuxdrv_v13(gcc2.9x).zip (dated 2003/09/04)

I actually tried both drivers and both failed upon "/sbin/insmod -f" with
error said "init_module: No such device" and the usual warning and hints.
 
Old 09-18-2003, 11:08 AM   #249
Poprocks
Member
 
Registered: Sep 2003
Location: Toronto, Canada
Distribution: Slackware
Posts: 199

Rep: Reputation: 30
Angry

I have tried every version of this driver that is available on realtek's website -- I am running Arklinux, a Redhat-based distribution, that is running gcc 3.3.1 and kernel 2.4.23 -- when I try to compile it, I get the error:

In file included from /usr/src/linux-2.4/include/asm/semaphore.h:39,
from /usr/src/linux-2.4/include/linux/fs.h:204,
from /usr/src/linux-2.4/include/linux/capability.h:17,
from /usr/src/linux-2.4/include/linux/binfmts.h:5,
from /usr/src/linux-2.4/include/linux/sched.h:9,
from r8180_pci_init.c:26:
/usr/src/linux-2.4/include/asm/system.h: In function `__set_64bit_var':
/usr/src/linux-2.4/include/asm/system.h:187: warning: dereferencing type-punned pointer will break strict-aliasing rules
/usr/src/linux-2.4/include/asm/system.h:187: warning: dereferencing type-punned pointer will break strict-aliasing rules
In file included from r8180_pci_init.c:40:
r8180_type.h: At top level:
r8180_type.h:142: error: redefinition of `timer_t'
/usr/src/linux-2.4/include/linux/timer.h:41: error: `timer_t' previously declared here
make: *** [r8180_pci_init.o] Error 1

So, I opened r8180_type.h and commented out the line that defined timer_t -- It then compiled fine -- however, when I tried to insmod -f it, I got a segmentation fault -- when I lsmod, I can see rtl8180_24x in the list, but it's always stuck in the "initializing" stage.

I've tried to compile it with the 2.4.20 kernel source that I have, without uncommenting the timer_t stage -- it compiles OK, but when I insmod -f it I get a segmentation fault, with the same problem occurring. The same also occurs with all the binary rtl8180 modules I have tried to load....

Can anyone help me with this problem?
 
Old 09-18-2003, 04:20 PM   #250
malkis
LQ Newbie
 
Registered: Sep 2003
Location: Netherlands
Distribution: Fedora Core 9
Posts: 10

Rep: Reputation: 0
I know I already asked this, but I haven't found the answer as of yet. Maybe I shouldn't complain, because my connection in it self is fine now. It has been stable for a while!

However both in dmesg and in messages I get every few seconds this:

IBSSJoin(): Please check out the following ...
IBSSJoin(): BSSID = 0x02:0xe0:0xfc:0xbc:0xa8:0x5e
IBSSJoin(): SSID = server2
IBSSJoin(): dot11BeaconPeriod = 100
IBSSJoin(): dot11DtimPeriod = 0
IBSSJoin(): dot11OperationalRates = 0x0f
IBSSJoin(): mCap = 0x02

I think the problem has to do with the fact that I don't have an AP. The thing is that all I want is to silence it. I'm not sure where to go from here. Can someone help me / point me in the right direction? Please?

<edit> typo </edit>
 
Old 09-18-2003, 06:22 PM   #251
Poprocks
Member
 
Registered: Sep 2003
Location: Toronto, Canada
Distribution: Slackware
Posts: 199

Rep: Reputation: 30
w00, I got wireless to work!
I tried the binary SuSE module that I got from Edimax, and tried it WITH THE 2.4.21 KERNEL that I have -- it did NOT work with my 2.4.23, nor did any of the ones I compiled/tried to compile -- I don't really want to have to use my 2.4.21 kernel again, but if wireless works that's good enough for me -- all I had to do was enter some very basic values (ie: linksys for ssid2scan) and after that run
/sbin/dhconfig wlan0 to get it to enable DHCP
Thanks everyone, this is a great thread!
 
Old 09-20-2003, 11:55 AM   #252
davidfrahm
LQ Newbie
 
Registered: Sep 2003
Location: United States
Distribution: Red Hat 9
Posts: 4

Rep: Reputation: 0
Overruns OK?

Does anyone know if some overruns are any big deal?

Other than that (which may be nothing to worry about) my v4 WPC11 works great on my Dell CPi after following this thread. It is very fast, just like my other Dell D500 running WinXP.

Here's my ifconfig with the 6 overruns after running for about 10 minutes (surfing and one 9MB download)...

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:185302 errors:0 dropped:0 overruns:0 frame:0
TX packets:185302 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:12667922 (12.0 Mb) TX bytes:12667922 (12.0 Mb)

wlan0 Link encap:Ethernet HWaddr 00:0C:41:4A:CD:D9
inet addr:192.168.1.102 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:6234 errors:0 dropped:0 overruns:0 frame:0
TX packets:2888 errors:0 dropped:0 overruns:6 carrier:0
collisions:0 txqueuelen:100
RX bytes:6739435 (6.4 Mb) TX bytes:0 (0.0 b)
Interrupt:11 Base address:0x4000
 
Old 09-20-2003, 12:13 PM   #253
capedc
LQ Newbie
 
Registered: Aug 2003
Posts: 17

Rep: Reputation: 0
RH9/WPC11
Almost everything works, the card is powered, the module is inserted, the wlanO reports correctly, cardctl works properly, but it is not connecting to my access point why how can I make it connect or what am I doing wrong...

This is the last step and I would like to start using Evolution instead of virus infested Lookout, please help...all I need is that elusive connection...
 
Old 09-20-2003, 12:35 PM   #254
davidfrahm
LQ Newbie
 
Registered: Sep 2003
Location: United States
Distribution: Red Hat 9
Posts: 4

Rep: Reputation: 0
I am 100% newbie, but when I was at your point all I needed was DHCP.

I'm on Red Hat 9, so I gave it /sbin/dhclient wlan0
Other distros use different command, listed elsewhere in this thread

Of course if you want static IP then...

# Setup manual IP settings:
# /sbin/ifconfig wlan0 192.168.1.180
# Can also do netmask on same line:
# /sbin/ifconfig wlan0 192.168.1.180 netmask 255.255.255.0
# Now can ping router (internally)
# /sbin/route add default gw 192.168.1.1
# Now can ping router (externally)
 
Old 09-20-2003, 05:21 PM   #255
capedc
LQ Newbie
 
Registered: Aug 2003
Posts: 17

Rep: Reputation: 0
Thanks. I tried it did not work. It kept getting no reply from the access point. Do I have to adjust my dhclient.conf configuration or what. Man this is so close that I taste it.

Again thanks for your help
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Linksys WPC11 version 4 aover25 Linux - Wireless Networking 5 02-12-2006 11:01 PM
WPC11 version 3 chiatello Linux - Networking 0 10-28-2003 09:32 PM
Linksys WPC11 version 4 kronixx Linux - Networking 1 06-07-2003 10:25 PM
WPC11 Version 4 StarCat Linux - Networking 1 05-03-2003 12:13 PM
Linksys WPC11 Version 3 haqtiq Linux - Networking 3 01-15-2003 11:33 PM


All times are GMT -5. The time now is 10:02 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration