LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 07-28-2005, 02:25 AM   #1
scorpio1883
LQ Newbie
 
Registered: Jul 2005
Location: PA.USA
Distribution: Fedora
Posts: 1

Rep: Reputation: 0
Wpa_supplicant Problems Plz Help!


Hi
I have a WRT54G router and a WPCI810G "Motorola" & WMP54G "Linksys" PCI cards they both use broadcom drivers. I successfully installed them via ndiswrapper had the internet working with encryption off and WEP ON. As you know or might not know WEP is like using toliet paper door in a storm. It wont protect you for long. So i tried to use WPA_Supplicant...

I made the .config file with:
CONFIG_DRIVER_NDISWRAPPER=y
CONFIG_CTRL_IFACE=y

I have my wpa_supplicant.config as so:

ctrl_interface=/var/run/wpa_supplicant
network={
ssid="myssid"
psk="mysecret"
key_mgmt=WPA-PSK
proto=WPA
}

I did:

ifconfig wlan0 up
wpa_supplicant -Dndiswrapper -iwlan0 -c/etc/wpa_supplicant.conf -dd

it either says:
No Keys have been configured - skip key clearing

or

Something to the affect of... Fail AP retrieval

or

Cancelling auth. timeout

or if I go to Network in System settings and try to activate wlan0
it says ...

" Failed to read configuration file '/etc/wpa_supplicant.conf' "

I just wanna use WPA-PSK TKIP with my cards

btw i use FEDORA CORE 4

help is much appreciated...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wpa_supplicant and ipw2100 problems in SUSE 9.2 overheadcam Linux - Wireless Networking 1 04-19-2005 12:08 PM
wpa_supplicant and ipw2100 problems in SUSE 9.2 overheadcam Linux - Networking 1 04-14-2005 11:17 AM
wpa_supplicant problems maddoggames Linux - Wireless Networking 2 01-22-2005 03:36 PM
Problems using Wpa_supplicant and linuxant Oostertoaster Linux - Wireless Networking 0 08-03-2004 07:01 AM
redhat problems plz plz help sap666 Linux - Newbie 5 07-30-2003 10:57 AM


All times are GMT -5. The time now is 01:29 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration