LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 07-13-2006, 07:56 AM   #1
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 10.04/12.04, Scientific Linux 6.3, Android-x86, Maemo
Posts: 1,658

Rep: Reputation: 138Reputation: 138
WPA_Supplicant problem on Debian Etch


I've got a problem with wpa_supplicant on Debian Etch.

The good news is that this is the first time that I've ever gotten WPA to work in Linux,... any encryption to work, actually (couldn't get WEP to work either on SuSE). The bad news is that it is working sporatically... and I don't know why...

I managed to get an Atheros AR5212 working with the win drivers loaded through ndiswrapper. I then followed a very nice set of instructions on a blog to manually configure wpa_supplicant to connect to my linksys router (and my girlfriend's as well). It worked the first time... but not the second... not the third,... worked the 4th,... not the 5th though,.... then worked the 6th... and so on...

My goal is to write a script called by su-to-root that will engage the wireless card through wpa_supplicant. The problem is that every now and them wpa_supplicant will kill some other process and spontaneously start working. I would like to figure out exactly what is happening so I can make it happen on purpose. Crap-shoot wifi is not good wifi.

I've tried using the command line tools to bring the ethernet port down... but won't work. Can anyone point me in the right direction?
 
Old 07-14-2006, 05:03 AM   #2
unSpawn
Moderator
 
Registered: May 2001
Posts: 26,543
Blog Entries: 51

Rep: Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606
The bad news is that it is working sporatically... and I don't know why.
I found that scanning for AP's (using the Madwifi Atheros driver) can result in intermittent connection behaviour. If you "wpa_cli scan_results" shows multiple AP's in the neighbourhood then if you list all AP's you don't use in the conf as "disabled=1" could help. If it's not that then you could run wpa_supplicant in the foreground to get an indication why it fails.
 
Old 07-14-2006, 07:59 AM   #3
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 10.04/12.04, Scientific Linux 6.3, Android-x86, Maemo
Posts: 1,658

Original Poster
Rep: Reputation: 138Reputation: 138
I think the problem may be the application network-administation, or something similar to that. It is a GUI app that allows you to configure the network, take network devices off line, re-activate them etc.

RANT: [The biggest problem with this or any application of its kind is that they are not built around wpa_supplicant... they only support WEP weak encryption... With a lot of teenagers living in my neighborhood, and at least 5 wireless routers on my block, I'm not keen on using WEP. If my freakin' Palm LifeDrive can use WPA, so should my Linux laptop...]

Enough rant...

I noticed last night that when I re-configured this application to only use a default setup, one that had the wlan0 activated and all other interfaces de-activated, then launched wpa_supplicant as root at the command line, it seemed to work,... how it will work when I try it today, I don't know.

What commands should I issue to observe what wpa_supplicant is doing, i.e. give a verbose log of it failing to connect or running into interference...???

PS - wpa_supplicant rarely reports an error. Often it is showing itself properly connected to the router... only no internet... It there a possibility that the internet services are not being correctly initialized (maybe due to being assigned to one of the other network devices, like eth0, eth1, or the modem)??? If so, how do I re-initialize the internet service to wlan0 without having to jump through too many fire-hoops???
 
Old 07-14-2006, 08:26 AM   #4
unSpawn
Moderator
 
Registered: May 2001
Posts: 26,543
Blog Entries: 51

Rep: Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606Reputation: 2606
I noticed last night that when I re-configured this application to only use a default setup, one that had the wlan0 activated and all other interfaces de-activated, then launched wpa_supplicant as root at the command line, it seemed to work,... how it will work when I try it today, I don't know.
Definately a prob with the app I'd say since you give wpa_supp the -i to only work with a certain device.


What commands should I issue to observe what wpa_supplicant is doing, i.e. give a verbose log of it failing to connect or running into interference...???
Ain't that in the docs? Hmm. If you take away "-B" and add "-dd" it'll spit out lots of info.


PS - wpa_supplicant rarely reports an error. Often it is showing itself properly connected to the router... only no internet... It there a possibility that the internet services are not being correctly initialized (maybe due to being assigned to one of the other network devices, like eth0, eth1, or the modem)???
Check if any other devices are up, if "wpa_cli status verbose" shows "connected" or other mode, if your route -n are still OK, ping and tcptraceroute to world to name a few.
 
Old 07-14-2006, 08:30 AM   #5
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 10.04/12.04, Scientific Linux 6.3, Android-x86, Maemo
Posts: 1,658

Original Poster
Rep: Reputation: 138Reputation: 138
Thanks,...

I'll try your suggestions when I get a chance...
 
Old 07-16-2006, 01:52 AM   #6
short101
Member
 
Registered: May 2004
Location: Aust.
Distribution: Debian
Posts: 424

Rep: Reputation: 30
May i ask why you arent using the madwifi drivers for your card? check out the docs at madwifi.org. There is even source modules in the non-free section of the debian repo's. install madwifi-source, kernel-headers and module assistant, then just do a m-a a-i madwifi-source.
Also to check your route, just type 'route', it will show which interface is currently being used for your internet.
 
Old 07-17-2006, 08:34 AM   #7
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 10.04/12.04, Scientific Linux 6.3, Android-x86, Maemo
Posts: 1,658

Original Poster
Rep: Reputation: 138Reputation: 138
As far as why no MadWiFi,... I've had problems, and heard that I wasn't the only one,... using the madwifi drivers for the Atheros chipsets and WPA encryption,... most recently on SuSE 10.1... So I figured I'd save myself the pain...

I now have the thing working. The problem is that eth0 (and I guess eth1, when my docking station is attached) is/are enabled by default. I have to bring them down (I use the Network Administration gui applet),... launch wpa_supplicant in a terminal window as root,... and then I've been using wpa_gui to force the connection to the router. My ultimate goal was to do it with a simple script... but the current configuration lets me moniter when device go up and down and the internet is available...

To avoid the problem with my girlfriend's router not connecting, I purchased a new one for her, similar to mine, and configured it exactly as mine was... So no new settings.

It now works,... Getting a new IP address for Internet access is painfully slow,... but it works.

Now, If I could only get OpenGL and XGL working, and ALSA sound working consistantly in Gnome (taken to using KDE, which I prefer anyway), I'd be all set.

Last edited by JaseP; 07-17-2006 at 08:37 AM.
 
Old 07-25-2006, 01:44 AM   #8
JaseP
Senior Member
 
Registered: Jun 2002
Location: Eastern PA, USA
Distribution: K/Ubuntu 10.04/12.04, Scientific Linux 6.3, Android-x86, Maemo
Posts: 1,658

Original Poster
Rep: Reputation: 138Reputation: 138
Well, did a kernel upgrade and lost my ndis setup... switched to the madwifi drivers... much better...

Thanks for the advice Short101...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Canon iP4200 and Debian Etch Problem KRiSX.cjb.net Linux - Hardware 8 01-01-2007 03:01 PM
initrd problem (Debian etch on Toshiba Satellite) kaz2100 Linux - Laptop and Netbook 2 07-10-2006 08:26 PM
Debian etch GUI problem AaronKupen Linux - Software 3 06-16-2006 02:18 PM
Debian Etch Half Network Problem KRiSX.cjb.net Debian 4 06-06-2006 05:26 PM
xfce4/xfwm on debian etch (compositor problem) cyberfishee Linux - Software 0 12-06-2005 09:49 PM


All times are GMT -5. The time now is 07:50 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration