LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 03-26-2013, 10:15 AM   #1
laugher5
LQ Newbie
 
Registered: Mar 2013
Posts: 3

Rep: Reputation: Disabled
wpa_supplicant hangs with mwifiex driver and custom hardware


So I have embedded linux running mwifiex driver v1.0 (14.57.5.p.41). The driver downloads and initializes then I want to connect to a router using wpa_supplicant and wpa encryption. I have already connected to an open network.
I run
wpa_supplicant -ddd -mlan0 -c/etc/wpa_supplicant.conf
-Dnl80211
the result is:
wpa_supplicant v1.0
random: Trying to read entropy from /dev/random
Initializing interface 'mlan0' conf '/etc/wpa_supplicant.conf' driver 'nl80211' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant.conf' -> '/etc/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant.conf'
ap_scan=1
Line: 5 - start of a new network block
ssid - hexdump_ascii(len=6):
4f 53 54 2d 30 33 OST-03
BSSID - hexdump(len=6): 00 14 6c 93 bc f4
proto: 0x3
key_mgmt: 0x2
pairwise: 0x18
group: 0x8
PSK - hexdump(len=32): [REMOVED]
Priority group 0
id=0 ssid='OST-03'
iface is mlan0

and that is it it just stops - following the code trail it dies in wpa_supplicant/wpa_supplicant.c in
wpa_supplicant_set_driver() - basically an unsupported driver. Any thoughts?
 
Old 04-01-2013, 04:18 PM   #2
elucches
Member
 
Registered: Jan 2011
Posts: 91

Rep: Reputation: 8
Running wpa_supplicant with no arguments will show you the supported drivers. If the one you want to use doesn't appear in the list, I guess you'll have to recompile wpa_supplicant.
 
Old 04-09-2013, 07:01 AM   #3
laugher5
LQ Newbie
 
Registered: Mar 2013
Posts: 3

Original Poster
Rep: Reputation: Disabled
Not that obvious

When I run wpa_supplicant with nothing else it shows the nl80211 driver is not loaded. I recompiled with the makefile change to
CONFIG_DRIVER_NL80211=y, unfortunately then I got tons of compile errors. So I have to go back and look at my build. Thanks for your help.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Necessity of driver when communicating with custom hardware on parallel port Summer_Penguin Linux - Hardware 3 04-02-2012 12:39 AM
Install hardware driver under custom-built kernel worker Linux - Server 4 03-16-2012 04:25 AM
wpa_supplicant can t associate with ndiswrapper driver pomard Linux - Wireless Networking 4 01-12-2010 09:12 PM
wpa_supplicant driver support genmaicha Linux - Wireless Networking 1 07-03-2009 03:20 AM
net driver causes system hangs (keyboard hangs) yjchen Linux - Networking 0 10-21-2004 10:12 PM


All times are GMT -5. The time now is 04:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration