LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 01-08-2007, 09:22 PM   #1
semtex
LQ Newbie
 
Registered: Jan 2007
Location: Germany
Distribution: Gentoo 2006.1
Posts: 16

Rep: Reputation: 0
Unhappy WPA with Dell Wireless 1500 (Broadcom 4328)


Hi! First of all my name is Dimi.
I'm a kind of noob to linux and I thought installing Gentoo Linux by myself will give me some deeper insight into Linux OS. So I grabbed my brand new Dell Inspiron 640 notebook with a Dell Wireless 1500 WiFi Controller and now I'm trying to get this damn network card to work for almost 5 days.

I'm now so far that I can establish a wireless connetion to an unencrypted network. For now I'm using the ndiswrapper driver 1.33 and wpa_supplicant 0.5.4.

The problem I have is that I wasn't yet successful connecting to my WPA1 encrypted network. As I said connecting to a plain network works fine. I have already googled for every possible combination of keywords but it seems that there aren't many people with this problem, so I thought that maybe you guys can help me out.

I'm not sure which info I should provide, so that you can give me a proper advice, so I will just wait for someone to tell me .

The config for my WPA network looks like this (/etc/wpa_supplicant/wpa_supplicant.conf snippet):
network={ ssid "foo"
#proto=WPA
key_mgmt=WPA-PSK
#pairwise=TKIP
#group=TKIP
psk=........
}
The commented switches are one I've already tested, that means that I tried to connect with and without them. I'm sure that my psk key is correct, I tried the ASCII key and the one generated with wpa_passphrase.
To test my connection I'm using the following command:
wpa_supplicant -Dndiswrapper -iwlan0 -c/etc/wpa_supplicant/wpa_supplicant.conf -d
I also tried to use the -Dwext switch instead of the -Dndiswrapper (i haven't found a description for the wext driver, I have no idea what it is) as it was suggested in one of the articles I found, but I still had no luck. Also I'm sure that my wlan card at least sees the network because it is displayed by using: iwlist wlan0 scan command.

I hope that someone can help me out because I don't have a clue how to get it to work. Thanks!
 
Old 01-09-2007, 03:25 PM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
For comparison, here is a WPA entry I know works:

Code:
network={
ssid="WPA_NETOWRK_SSID"
scan_ssid=1
key_mgmt=WPA-PSK
pairwise=TKIP
group=TKIP
psk="WPA_Passphrase"
priority=1
}
It looks as if you have at least one syntax error in your entry (the ssid doesn't have a = sign) and I think the # may be causing trouble.

The command you're using to start wpa_supplicant looks good. Does anything show up in either your logs or in dmesg when you start it? Also, once you've started wpa_supplicant, what does your iwconfig look like?


Quote:
i haven't found a description for the wext driver, I have no idea what it is
My understanding is that wext is a generic driver that works through iwconfig. In theory, any card that can be configured through iwconfig should be able to run wpa_supplicant with the wext driver. That saves the wpa_supplicant people a whole lot of coding.
 
Old 01-13-2007, 03:37 PM   #3
semtex
LQ Newbie
 
Registered: Jan 2007
Location: Germany
Distribution: Gentoo 2006.1
Posts: 16

Original Poster
Rep: Reputation: 0
wpa_supplicant output

So, I finally found some time to post a reply. Sorry that it took so long, I was very busy this week. Here is what wpa_supplicant says:

Code:
Initializing interface 'wlan0' conf '/etc/wpa_supplicant/wpa_supplicant.conf' driver 'ndiswrapper' ctrl_interface 'N/A' bridge 'N/A'
Configuration file '/etc/wpa_supplicant/wpa_supplicant.conf' -> '/etc/wpa_supplicant/wpa_supplicant.conf'
Reading configuration file '/etc/wpa_supplicant/wpa_supplicant.conf'
update_config=1
ctrl_interface='/var/run/wpa_supplicant'
ctrl_interface_group='wheel' (DEPRECATED)
eapol_version=1
ap_scan=1
fast_reauth=1
Priority group 2
   id=0 ssid='Fuck Off'
Initializing interface (2) 'wlan0'
EAPOL: SUPP_PAE entering state DISCONNECTED
EAPOL: KEY_RX entering state NO_KEY_RECEIVE
EAPOL: SUPP_BE entering state INITIALIZE
EAP: EAP entering state DISABLED
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
SIOCGIWRANGE: WE(compiled)=20 WE(source)=18 enc_capa=0xf
  capabilities: key_mgmt 0xf enc 0xf
WEXT: Operstate: linkmode=1, operstate=5
Own MAC address: 00:16:cf:b3:7a:6d
Driver does not support WPA.
wpa_driver_wext_set_key: alg=0 key_idx=0 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=1 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=2 set_tx=0 seq_len=0 key_len=0
wpa_driver_wext_set_key: alg=0 key_idx=3 set_tx=0 seq_len=0 key_len=0
Setting scan request: 0 sec 100000 usec
ctrl_interface_group=10 (from group name 'wheel')
Added interface wlan0
RTM_NEWLINK: operstate=0 ifi_flags=0x1002 ()
Wireless event: cmd=0x8b06 len=12
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
RTM_NEWLINK: operstate=0 ifi_flags=0x1003 ([UP])
RTM_NEWLINK, IFLA_IFNAME: Interface 'wlan0' added
State: DISCONNECTED -> SCANNING
Starting AP scan (broadcast SSID)
Trying to get current scan results first without requesting a new scan to speed up initial association
Received 893 bytes of scan results (3 BSSes)
Scan results: 3
Selecting BSS from priority group 2
0: 00:15:0c:94:7d:b4 ssid='Fuck Off' wpa_ie_len=26 rsn_ie_len=0 caps=0x11
   selected based on WPA IE
Trying to associate with 00:15:0c:94:7d:b4 (SSID='Fuck Off' freq=2447 MHz)
Cancelling scan request
WPA: clearing own WPA/RSN IE
Automatic auth_alg selection: 0x1
WPA: using IEEE 802.11i/D3.0
WPA: Selected cipher suites: group 8 pairwise 8 key_mgmt 2 proto 1
WPA: set AP WPA IE - hexdump(len=26): dd 18 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02 00 00
WPA: clearing AP RSN IE
WPA: using GTK TKIP
WPA: using PTK TKIP
WPA: using KEY_MGMT WPA-PSK
WPA: Set own WPA IE default - hexdump(len=24): dd 16 00 50 f2 01 01 00 00 50 f2 02 01 00 00 50 f2 02 01 00 00 50 f2 02
No keys have been configured - skip key clearing
State: SCANNING -> ASSOCIATING
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
Association request to the driver failed
Setting authentication timeout: 5 sec 0 usec
EAPOL: External notification - EAP success=0
EAPOL: External notification - EAP fail=0
EAPOL: External notification - portControl=Auto
Authentication with 00:00:00:00:00:00 timed out.
Added BSSID 00:15:0c:94:7d:b4 into blacklist
State: ASSOCIATING -> DISCONNECTED
wpa_driver_wext_set_operstate: operstate 0->0 (DORMANT)
WEXT: Operstate: linkmode=-1, operstate=5
No keys have been configured - skip key clearing
EAPOL: External notification - portEnabled=0
EAPOL: External notification - portValid=0
Setting scan request: 0 sec 0 usec
As I went though the log I saw that there is a line
Code:
Driver does not support WPA.
which I think says that I have no chance to connect to my WPA protected network. I think that I have to wait until the ndiswrapper guys modify their driver to support wpa on my card model or until the bcm43xx project supports my card.
 
Old 01-13-2007, 03:59 PM   #4
semtex
LQ Newbie
 
Registered: Jan 2007
Location: Germany
Distribution: Gentoo 2006.1
Posts: 16

Original Poster
Rep: Reputation: 0
Some more messages

Here are some more program outputs:

ifconfig (with started wpa_supplicant)
Code:
wlan0     Protokoll:Ethernet  Hardware Adresse 00:16:CF:B3:7A:6D  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          Kollisionen:0 Sendewarteschlangenlänge:1000 
          RX bytes:0 (0.0 b)  TX bytes:320 (320.0 b)
          Interrupt:177 Speicher:efdfc000-efe00000
iwconfig (with started wpa_supplicant)
Code:
wlan0     IEEE 802.11g  ESSID:off/any  
          Mode:Managed  Frequency:2.462 GHz  Access Point: Not-Associated   
          Bit Rate=130 Mb/s   Tx-Power:24 dBm   
          RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0
iwlist wlan0 scan (with started wpa_supplicant)
Code:
wlan0     Scan completed :
          Cell 01 - Address: 00:15:0C:94:7D:B4
                    ESSID:"Fuck Off"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.447 GHz (Channel 8)
                    Quality:68/100  Signal level:-52 dBm  Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 22 Mb/s
                              6 Mb/s; 9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s
                              36 Mb/s; 48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
                    IE: WPA Version 1
                        Group Cipher : TKIP 
                        Pairwise Ciphers (1) : TKIP 
                        Authentication Suites (1) : PSK  
          Cell 02 - Address: 00:11:50:41:FA:30
                    ESSID:"belkin54g"
                    Protocol:IEEE 802.11g
                    Mode:Managed
                    Frequency:2.462 GHz (Channel 11)
                    Quality:10/100  Signal level:-89 dBm  Noise level:-96 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
                              24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
                              12 Mb/s; 48 Mb/s
                    Extra:bcn_int=100
                    Extra:atim=0
 
Old 01-14-2007, 07:31 AM   #5
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
Driver does not support WPA.
I don't think you're interpreting that error message quite right. I'm going to guess that when wpa_supplicant was compiled, something important was left out. I know from my own experience that both the ndiswrapper and wext drivers do support WPA encryption. Have a look on my help site (link in sig) where I've got an example config file for wpa_supplicant that works with both ndiswrapper and bcm43xx.
 
Old 01-14-2007, 11:35 AM   #6
semtex
LQ Newbie
 
Registered: Jan 2007
Location: Germany
Distribution: Gentoo 2006.1
Posts: 16

Original Poster
Rep: Reputation: 0
Compiling with Gentoo

Hi. As I've already mentioned, I'm a newbie to linux. I'm using the gentoo 2006.1 distribution and as gentoo has a very cool package management and compiling interface (portage) I thought that it would automatically configure the wpa_supplicant build file so that it will work. Should I really recompile wpa_supplicant by hand or is it unnecessary? (USE flags I used to compile: dbus readline ssl; deactivated USE flags: -gsm -madwifi -qt3 -qt4)
 
Old 01-15-2007, 06:49 AM   #7
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I do understand how Gentoo does things, and that was one of the reasons I asked about wpa_supplicant. If you download the source code and read the installation instructions, one of the things that you have to do is write your own configuration file for the compilation. They give you a couple of examples, but they really aren't very easy to understand which leads to lots of confusion. It is one of the reasons why I keep a config file posted on my site. Anyway, knowing what Gentoo used for its config file might be a way to find out why you're getting that error.

Quote:
Should I really recompile wpa_supplicant by hand or is it unnecessary? (USE flags I used to compile: dbus readline ssl; deactivated USE flags: -gsm -madwifi -qt3 -qt4)
If you can find the config file Gentoo used, then it probably isn't necessary. However, if you can't, I would suggest compiling it from source outside of the portage system. By the way, those flags you've got are rather odd (and probably don't really apply to wpa_supplicant).

The other thing to try (and maybe do this first) is make sure you've got the latest drivers from Dell. WPA has been around a long time, and if your hunch is right and the error is referring to the Windows driver rather than wpa_supplicant, that might do it.
 
Old 01-15-2007, 11:28 AM   #8
semtex
LQ Newbie
 
Registered: Jan 2007
Location: Germany
Distribution: Gentoo 2006.1
Posts: 16

Original Poster
Rep: Reputation: 0
OK, thanks, I'll look for the build config file. I'm sure I've got the latest Windows drivers (the newest I could find on Dell site) and I have at least the newest wpa_supplicant and ndiswrapper available on portage (I also unmasked both packages, so I have the testing tree). The flags I wrote down are the ones wpa_supplicant package has, there aren't any more, less or others available for this package. The qt* flags are switched off, because I don't use KDE, the rest is set by default. Anyway, I'll look, what options in the build file portage used to compile this package.
 
Old 01-23-2007, 01:46 PM   #9
semtex
LQ Newbie
 
Registered: Jan 2007
Location: Germany
Distribution: Gentoo 2006.1
Posts: 16

Original Poster
Rep: Reputation: 0
Hi. I tried to find the makefile that portage generates to compile the wpa_supplicant package but it seems that portage deletes the file after compile. As I'm not very familiar to Linux I don't know how to compile the package by hand . If someone could give me advice, I would appreciate it. Thanks.
 
Old 01-23-2007, 02:47 PM   #10
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
For wpa_supplicant it is pretty easy:

- unpack the tarball
- cd into the directory
- Using a text editor, create a .config file (you can probably use the one I've got on my site)
- in the console, run make
- in the console, as root, cp wpa_supplicant wpa_cli /usr/local/bin
- create your /etc/wpa_supplicant.conf file with a text editor.

There are detailed instructions in the README file that comes with the tarball, so I would read those as well.
 
Old 02-12-2007, 03:05 PM   #11
semtex
LQ Newbie
 
Registered: Jan 2007
Location: Germany
Distribution: Gentoo 2006.1
Posts: 16

Original Poster
Rep: Reputation: 0
Hi. I have finally finished with my exams and found some time to compile wpa_supplicant by hand. I made all the steps described in the README file and I also read the notes on Hangdog42's site. The result of my work is that wpa_supplicant still brings about the same messages I wrote about before. I'm now in a state of depression . Nothing seems to work for me.
I even found out, that on the unencrypted network used at university, where I have to log in via OpenVPN I'm not able to log in. Why? I don't have a clue. As I tried to log in using the wired connection and OpenVPN everything worked fine but using the WLAN connection it worked exactly twice and never since. (OpenVPN says it cannot find route to host, I think it is a driver problem, since the wired connection works. iwconfig says it is connected with the right network, an IP address is assigned, the routes are set but OpenVPN cant find the route ).
I am very disappointed with the whole situation, although I know that the only one I have to blame is BROADCOM.
I am curious: do I have a chance to get this card to work with BCM43xx native driver? All the FAQ's say no, but maybe someone had experience with this card?
I am grateful for any help I can get to finally solve the problem. Thanks!

Last edited by semtex; 02-12-2007 at 03:10 PM.
 
Old 02-12-2007, 04:40 PM   #12
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
I am curious: do I have a chance to get this card to work with BCM43xx native driver? All the FAQ's say no, but maybe someone had experience with this card?
It pretty much depends on the chipset, which unless I've missed it, you haven't posted. Have a look at the output of lspci and see if it lists it. If it is a 4306, you're probably good. If it is a 4318, it might be trouble. Even if it is a 4318, you might give bcm43xx a go. It certainly can't make it any worse.
 
Old 02-12-2007, 05:06 PM   #13
semtex
LQ Newbie
 
Registered: Jan 2007
Location: Germany
Distribution: Gentoo 2006.1
Posts: 16

Original Poster
Rep: Reputation: 0
Sorry, I should have forgotten to write it down (the thread name says it all ). Its the Broadcom 4328 chipset (at least thats what lspci says), the card is Dell TrueMobile 1500.
I also already mentioned, that I read almost every spec from the BCM43xx project and it seems that this chipset isn't supported yet and won't be in the near future.

Last edited by semtex; 02-12-2007 at 05:08 PM.
 
Old 02-13-2007, 07:06 AM   #14
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,790
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Quote:
Originally Posted by semtex
Sorry, I should have forgotten to write it down (the thread name says it all ). Its the Broadcom 4328 chipset (at least thats what lspci says), the card is Dell TrueMobile 1500.
I also already mentioned, that I read almost every spec from the BCM43xx project and it seems that this chipset isn't supported yet and won't be in the near future.

Sheesh. One of these days I'll learn to read, and then I'll be dangerous......


The only suggestion I have is to try as many different Windows drivers as you can with ndiswrapper. You shouldn't have to recompile wpa_supplicant for each, but I would try starting wpa_supplicant with both the ndiswrapper and wext options and see if one works better than the others. If you haven't already, check the ndiswrapper wiki and see if anyone there has success with this chipset. Otherwise try any driver you can find for this on either the Dell or the Broadcom websites.

Of course a better alternative might be to find a new wireless card that actually has Linux support. However, only you can determine if your wallet can handle the load.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ndiswrapper - openSUSE - Dell Wireless 1500 (802.11draft-n/a/g) WLAN MiniCard cudmore Linux - Wireless Networking 5 06-20-2007 01:04 AM
WPA with Dell Wireless 1500 (Broadcom 4328) semtex Linux - Wireless Networking 2 01-09-2007 03:24 PM
[FC-6 x86_64] Broadcom Corporation Dell Wireless 1390 woes homer420 Linux - Laptop and Netbook 2 11-02-2006 01:54 PM
Broadcom 4328 Dell Draft N Card needyouradvice Linux - Wireless Networking 1 07-31-2006 12:58 PM
Broadcom 1400 Wireless G NIC in Dell 8500 jgrover Linux - Wireless Networking 3 03-01-2004 01:29 PM


All times are GMT -5. The time now is 05:30 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration