LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 04-11-2004, 10:00 PM   #1
kovermours
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Rep: Reputation: 0
wlan0 appears as eth1 and can't get an ip


Using SuSE 9, my Linksys WPC11 (that works, and I had running under SuSE 8.1 a few months ago) appears as eth1 instead of wlan0, and won't grab an ip from my router. It does in winXP. eth0 is my onboard nic and it works.

I'm using orinoco_cs, external pcmcia.

If you need any other data, please ask!

Thanks
 
Old 04-11-2004, 10:03 PM   #2
kovermours
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Original Poster
Rep: Reputation: 0
it appears as wlan0 during boot, it's set to hotplug.

only in kwifimanager and iwpriv / iwconfig does it appear as eth1.
 
Old 04-12-2004, 07:30 AM   #3
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Moved: This thread is more suitable in Wireless Networking and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 09-13-2004, 01:39 PM   #4
joninsb
LQ Newbie
 
Registered: Sep 2004
Posts: 3

Rep: Reputation: 0
have you figured it out yet

I have the same problem. I am not sure what I did, but after adding an interface through yast and a couple of reboots I now get eth1 to work as my wireless interface. This does not seem correct though.
 
Old 09-13-2004, 02:07 PM   #5
rhettmaxwell
LQ Newbie
 
Registered: Apr 2004
Posts: 20

Rep: Reputation: 0
iwconfig

you can use iwconfig from the command line to view the adapter. if it shows a mac address like 4444:4444:4444:4444 then its not finding your AP.

you can also use iwconfig to set the ssid, and other wireless configs

iwconfig eth1 essid abcssid key s:abckey

'man iwconfig' for more details.

i think you can change the name of the device from eth1 to wlan0 by renaming /etc/sysconfig/network-scripts/ifcfg-eth1 to ifcfg-wlan0, but i don't use suse, so i don't know for sure.
 
Old 09-13-2004, 03:32 PM   #6
joninsb
LQ Newbie
 
Registered: Sep 2004
Posts: 3

Rep: Reputation: 0
Well, I got something working. In /etc/sysconfig/network I have a file named ifcfg-wlan-bus-pcmcia. Weird thing is that my wireless interface always comes up as eth1 but it used this configuration file. I tried renaming it to ifcfg-wlan0 to no avail. I just get an error that says "no configuration information for eth1. It turns out the eth1 basically works but it does not get the default gateway (which I set through yast) so I had to create a file called /etc/sysconfig/network/ifroute-wlan-bus-pcmcia (which somehow gets mapped to eth1) with the following contents.

default 192.168.2.1

This works. I still wish I knew how to change eth1 to wlan0 though.
 
Old 09-13-2004, 03:53 PM   #7
rhettmaxwell
LQ Newbie
 
Registered: Apr 2004
Posts: 20

Rep: Reputation: 0
ok, i think i figured it out

add the following line to your ifcfg- file

DEVICE=wlan0
 
Old 09-13-2004, 04:55 PM   #8
joninsb
LQ Newbie
 
Registered: Sep 2004
Posts: 3

Rep: Reputation: 0
Thanks for your help. Even though my network is now functional I tried what you said just to see if I could change the name of the interface to wlan0. When I ran '/etc/init.d/network restart' I got:

Shutting down service network . . . . . . . . . . . . . done.
Hint: you may set mandatory devices in /etc/sysconfig/network/config
Setting up network interfaces:
lo
lo IP address: 127.0.0.1/8 done
eth0 device: Intel Corp. 82801BD PRO/100 VE (MOB) Ethernet Controller (rev 83)
eth0 configuration: eth-id-00:08:0d:23:4b:33
eth0 (DHCP) . . . . . no IP address yet... backgrounding. waiting
eth1 device: "TOSHIBA", "Wireless LAN Card", "Version 01.01", ""
eth1 configuration: wlan-bus-pcmcia
eth1 warning: using NO encryption
interface wlan0 is not available failed
Setting up service network . . . . . . . . . . . . . . done.


I should have mentioned that I already have an ifcfg-wlan0 (which I have no clue what it is for - maybe attached to the pcmcia slot somehow), but I removed this and still got the same error. I don't undertand how hotplug devices work, but I think both wlan-bus-pcmcia and wlan0 are hotplug devices. Don't know if that is related somehow.

Jon
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
change ipw220 interface name from eth1 to wlan0 zen0n Linux - Laptop and Netbook 3 08-23-2005 01:55 PM
wireless eth1 to wlan0? ferreter Fedora 0 09-11-2004 02:19 PM
Activating eth1/wlan0 for intel 2100 wireless Atmchicago Linux - Wireless Networking 4 09-01-2004 02:50 AM
ethernet bridge (wlan0 eth1) - canīt ping magicien Linux - Wireless Networking 0 07-05-2004 03:59 AM
how do i rename wlan0 to eth1 laclac01 Linux - Networking 2 06-10-2004 05:31 PM


All times are GMT -5. The time now is 02:52 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration