LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Wireless won't work after reboot w/ Mepis& integrated Dell Wireless 1370 WLAN MiniPCI (http://www.linuxquestions.org/questions/linux-wireless-networking-41/wireless-wont-work-after-reboot-w-mepis-and-integrated-dell-wireless-1370-wlan-minipci-420739/)

longboarder543 03-01-2006 05:47 PM

Wireless won't work after reboot w/ Mepis& integrated Dell Wireless 1370 WLAN MiniPCI
 
After several hours of trial and error, I have managed to successfully get my integrated wireless card working on my Dell Inspiron 2200 notebook, on my WEP encrypted network. The problem is, no matter what I do, I can not get the settings to remain after I reboot. I can see ndiswrapper service starting during boot, and I have written a shell script that I can run once the computer boots to configure the network, and voila. I would like it all work at boot time, however.

My card uses the bcmwl5 driver, which is included with Mepis, and I have verified with 'ndiswrapper -l' and I get 'bcmwl5 driver present, hardware present'.

I did the following to "install" the driver:
ndiswrapper -m
sudo /sbin/depmod -a
sudo /sbin/modprobe ndiswrapper

And I did the following to configure the network:
iwconfig wlan0 essid 'SSIDHERE'
iwconfig wlan0 mode Managed
iwconfig wlan0 key open WEPKEYHERE
iwconfig wlan0 essid 'SSIDHERE'
dhclient wlan0

And the network comes alive.

Having already issued 'ndiswrapper -m' earlier, I added 'ndiswrapper' to '/etc/modules', to supposedly make these settings load at boot, but every time I reboot, I have to run the network configuration portion of the commands above to get the network going. Like I said, I made a bash script, but I still want it to load by itself, I want it all.

Thanks in advance for the help -- longboarder543

oh, and by the way, if you have an Inspiron 2200, don't bother installing Ubuntu, unless you have an external monitor, and alot of patience, it doesn't play nice with X after an install.

jschiwal 03-01-2006 07:14 PM

One possibility is that both the regular nic interface and the wlan0 interface are active. Try stopping the NIC interface (eth0) and restarting the network for the wlan interface.
On my system I can restart the wlan0 interface with the command: sudo /sbin/network restart wlan0. This will also restart the DHCP client and give wlan0 an IP address. Your system may have a similar method such as
sudo /sbin/service network restart wlan0. Or you may need to start wlan0 with ifup-wlan0 and also restart the dhcp daemon.

You could try either changing the configuration for the ethernet NIC device (eth0) so that it only starts if a cable is plugged in, or even disable it if you don't need it.


All times are GMT -5. The time now is 08:48 PM.