LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 09-04-2009, 03:15 PM   #1
qianian
LQ Newbie
 
Registered: Nov 2007
Posts: 14

Rep: Reputation: 0
wireless won't connect to password-protected networks


I want to connect to a password-secured wireless network. I can connect to unsecured networks no problem.

I'm running Ubuntu Hardy 8.10 on a lenovo Thinkpad R91i.

In the notification area, it detects many wireless networks and shows that it has connected to the one I want (80-100% signal). I get no more prompts for the password after I enter it the first time. I've tried unchecking Wired under Network and both enable Roaming and specified the network I want to use under Wireless.

When I ping, though, I get no connection. I've pasted some details below. Fir iwconfig, I tried the s: prefix, which returned the command line but still didn't get me connected. The man page reads "Passphrase is currently not supported" so does that mean iwconfig is no help?

Please understand I'm relatively new and need some English thrown in to explain the commands. Thank you all!

root@Stonau:/home/qian# iwlist eth1 scanning
eth1 Scan completed :
Cell 01 - Address: 00:19:E3:32:79:09
ESSID:"Beautiful"
Mode:Master
Channel:1
Frequency:2.412 GHz (Channel 1)
Quality=49/100 Signal level=-79 dBm Noise level=-95 dBm
Encryption keyn
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (1) : TKIP
Authentication Suites (1) : PSK
IE: IEEE 802.11i/WPA2 Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 6 Mb/s; 9 Mb/s
11 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:tsf=000000144e5b2d65
root@Stonau:/home/qian# iwconfig eth1 essid "Beautiful" key "fakepasscode"
Error for wireless request "Set Encode" (8B2A) :
invalid argument "fakepasscode".
qian@Stonau:~$ sudo lshw -C network
*-network
description: Wireless interface
product: PRO/Wireless 3945ABG Network Connection
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wmaster0
version: 02
serial: 00:1b:77:b0:cd:f8
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list logical ethernet physical wireless
configuration: broadcast=yes driver=iwl3945 ip=10.0.1.4 latency=0 module=iwl3945 multicast=yes wireless=IEEE 802.11g
*-network
description: Ethernet interface
product: NetLink BCM5787M Gigabit Ethernet PCI Express
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:04:00.0
logical name: eth0
version: 02
serial: 00:15:58:c8:c6:03
capacity: 1GB/s
width: 64 bits
clock: 33MHz
capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.86 ip=10.0.1.3 latency=0 link=no module=tg3 multicast=yes port=twisted pair
qian@Stonau:~$ sudo lshw -C network
*-network
description: Wireless interface
product: PRO/Wireless 3945ABG Network Connection
vendor: Intel Corporation
physical id: 0
bus info: pci@0000:03:00.0
logical name: wmaster0
version: 02
serial: 00:1b:77:b0:cd:f8
width: 32 bits
clock: 33MHz
capabilities: pm msi pciexpress bus_master cap_list logical ethernet physical wireless
configuration: broadcast=yes driver=iwl3945 ip=10.0.1.4 latency=0 module=iwl3945 multicast=yes wireless=IEEE 802.11g
*-network
description: Ethernet interface
product: NetLink BCM5787M Gigabit Ethernet PCI Express
vendor: Broadcom Corporation
physical id: 0
bus info: pci@0000:04:00.0
logical name: eth0
version: 02
serial: 00:15:58:c8:c6:03
capacity: 1GB/s
width: 64 bits
clock: 33MHz
capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.86 ip=10.0.1.3 latency=0 link=no module=tg3 multicast=yes port=twisted pair
qian@Stonau:~$ iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

eth1 IEEE 802.11g ESSID:"Beautiful" Nickname:""
Mode:Managed Frequency:2.412 GHz Access Point: 00:19:E3:32:79:09
Bit Rate=54 Mb/s Tx-Power=27 dBm
Retry min limit:7 RTS thrff Fragment thr=2346 B
Power Managementff
Link Quality=63/100 Signal level=-69 dBm Noise level=-91 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

qian@Stonau:~$ sudo dhclient eth1
There is already a pid file /var/run/dhclient.pid with pid 8077
killed old client process, removed PID file
Internet Systems Consortium DHCP Client V3.0.6
Copyright 2004-2007 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/

wmaster0: unknown hardware address type 801
wmaster0: unknown hardware address type 801
Listening on LPF/eth1/00:1b:77:b0:cd:f8
Sending on LPF/eth1/00:1b:77:b0:cd:f8
Sending on Socket/fallback
DHCPREQUEST of 10.0.1.4 on eth1 to 255.255.255.255 port 67
DHCPACK of 10.0.1.4 from 10.0.1.1
bound to 10.0.1.4 -- renewal in 6859 seconds.
qian@Stonau:~$ ping google.com
ping: unknown host google.com
qian@Stonau:~$ ping 82.211.81.158
PING 82.211.81.158 (82.211.81.158) 56(84) bytes of data.
From 10.0.1.3 icmp_seq=1184 Destination Host Unreachable
From 10.0.1.3 icmp_seq=1185 Destination Host Unreachable
From 10.0.1.3 icmp_seq=1186 Destination Host Unreachable
From 10.0.1.3 icmp_seq=1187 Destination Host Unreachable
From 10.0.1.3 icmp_seq=1189 Destination Host Unreachable
From 10.0.1.3 icmp_seq=1190 Destination Host Unreachable
From 10.0.1.3 icmp_seq=1191 Destination Host Unreachable
From 10.0.1.3 icmp_seq=1192 Destination Host Unreachable
From 10.0.1.3 icmp_seq=1193 Destination Host Unreachable
From 10.0.1.3 icmp_seq=1194 Destination Host Unreachable

root@Stonau:/home/qian# lspci -v
03:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)
Subsystem: Intel Corporation Unknown device 1010
Flags: bus master, fast devsel, latency 0, IRQ 217
Memory at df6ff000 (32-bit, non-prefetchable) [size=4K]
Capabilities: [c8] Power Management version 2
Capabilities: [d0] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable+
Capabilities: [e0] Express Legacy Endpoint IRQ 0
 
Old 09-05-2009, 07:54 AM   #2
estabroo
Senior Member
 
Registered: Jun 2008
Distribution: debian, ubuntu, sidux
Posts: 1,094
Blog Entries: 2

Rep: Reputation: 111Reputation: 111
for an ascii password you need to put an s: in front of it

Quote:
root@Stonau:/home/qian# iwconfig eth1 essid "Beautiful" key "fakepasscode"
iwconfig eth1 essid "Beautiful" key "s:fakepasscode"
 
Old 09-05-2009, 08:24 AM   #3
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,856

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
It looks like you are using WPA encryption which iwconfig can only handle WEP keys. WPA requires wpa_supplicant.
What desktop are you running? Do you have network manager installed? It is a GUI wireless configuration tool.

Last edited by michaelk; 09-05-2009 at 08:25 AM.
 
Old 09-10-2009, 09:50 PM   #4
qianian
LQ Newbie
 
Registered: Nov 2007
Posts: 14

Original Poster
Rep: Reputation: 0
I'm using the Network Administration Tool on Hardy.

I believe Gnome is the default, but how do I find out?
 
Old 09-10-2009, 09:51 PM   #5
qianian
LQ Newbie
 
Registered: Nov 2007
Posts: 14

Original Poster
Rep: Reputation: 0
estabroo, I tried that and no beans. I'm sure it's a passcode I'm dealing with. Thanks anyway.
 
Old 09-23-2009, 05:43 PM   #6
qianian
LQ Newbie
 
Registered: Nov 2007
Posts: 14

Original Poster
Rep: Reputation: 0
To follow up on this problem, I upgraded to Jaunty and have no problem connecting with WEP.
 
Old 09-23-2009, 06:26 PM   #7
michaelk
Moderator
 
Registered: Aug 2002
Posts: 11,856

Rep: Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738Reputation: 738
Thanks for the update. Be sure to make this thread as solved.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 12.2 will not connect to Wireless Networks picketfence Linux - Laptop and Netbook 9 03-28-2009 10:00 AM
how i connect in wireless networks ? hatebreeder666 Linux - Newbie 2 01-03-2009 03:11 PM
Can't Connect to any Encrypted Wireless Networks markackerman8@gmail. Linux - Newbie 3 07-13-2008 12:52 PM
NetworkManager can't connect to wireless networks debeus Linux - Laptop and Netbook 3 12-26-2007 07:39 PM
I cannot connect to WEP-protected wireless network niklasfischer Linux - Wireless Networking 1 12-11-2006 04:16 AM


All times are GMT -5. The time now is 05:53 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration