LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 11-21-2007, 10:07 AM   #1
apock627
LQ Newbie
 
Registered: Sep 2007
Location: Sydney
Posts: 4

Rep: Reputation: 0
Wireless visible but can't connect


Hi. Hoping someone can tell me what I'm missing with my wireless setup.

Running slack12, 2.6.23.1 on a toshiba laptop with an ipw3945 card. Dual boot with winXP.
Previously had wireless working with Vector 5.8. Recently installed slack12 and have not been able to get wireless working.
Recently wireless stopped working under windows with similar symptoms (could see wireless network and network settings all seemed OK) and this was fixed by uninstalling and reinstalling driver. I'd put this down to normal windows behaviour.

I've built the driver module under this kernel (from source, not the slackware extras package) and it gets loaded in /etc/rc.d/rc.modules
The ipw3945d daemon gets started in rc.local
So far I think it's all OK because e.g.
# iwlist scanning
produces a normal output including my own wireless network.

iwconfig output looks ok to my newbie eye
# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 unassociated ESSID:"Palantir" Nickname:"orthanc"
Mode:Managed Frequency=2.437 GHz Access Point: 00:60:64:07:A2:4C
Bit Rate:0 kb/s Tx-Power:16 dBm
Retry limit:15 RTS thr:off Fragment thr:off
Encryption key:XXXX_XXXX_XXXX_XXXX_XXXX_XXXX_XX Security mode:restricted
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:27093 Missed beacon:0


The wireless device was always eth1 (192.168.1.3). The wired NIC is eth0 which is working fine (192.168.1.2).
The changes I've made are:
/etc/modprobe.d/wireless:alias eth1 ipw3945
Settings for eth1 in /etc/rc.d/rc.inet1.conf
Filled in section in /etc/rc.d/rcwireless.conf

#ifconfig gives
(snip)

eth1 Link encap:Ethernet HWaddr 00:13:02:D6:F4:1B
inet addr:192.168.1.3 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:17449 overruns:0 frame:0
TX packets:2 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:150 (150.0 b)
Interrupt:17 Base address:0x8000 Memory:ff9ff000-ff9fffff
(snip)
# route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth1

With all of this can't ping my wireless router except with a wired connection (Destination host unreachable) or connect anywhere else

Didn't want to make this too much bulkier. If someone is able to help please just let me know which other outputs I should include. And I'm sure my problem has been dealt with before but I jst can't find a thread which quite matches my problem.

Many thanks
 
Old 11-21-2007, 06:23 PM   #2
PDock
Member
 
Registered: Aug 2004
Distribution: Slack10 & curr. tried numerous
Posts: 189

Rep: Reputation: 36
What happen if you take down eth0 ie
Code:
 /etc/rc.d/rc.inet1 eth0 down
suspect you don't want both wired and wireless up at the same time.
 
Old 11-21-2007, 06:47 PM   #3
apock627
LQ Newbie
 
Registered: Sep 2007
Location: Sydney
Posts: 4

Original Poster
Rep: Reputation: 0
Thanks for reply. I never bothered about it before, both were always up without a problem. I have got wireless working in my Vector linux installation and for some reason now it did only work after
# ifconfig eth0 down
but this has not fixed the problem in slack12.
I thought it could be because eth0 was listed at the end of the default route line, so I did
# route del default
# route add default gw 192.168.1.1 eth1
but still no dice
At least I know it's not a hardware problem.
Thanks for the suggestion - keep 'em coming!
 
Old 11-22-2007, 02:47 AM   #4
apock627
LQ Newbie
 
Registered: Sep 2007
Location: Sydney
Posts: 4

Original Poster
Rep: Reputation: 0
Decided to start with a clean slate. Went right through /etc/rc.d commenting out every mention of eth0 or eth1, all wireless settings (except for loading the driver and the daemon) and rebooted. After
# ifconfig eth1 192.168.1.3 netmask 255.255.255.0
# route add default gw 192.168.1.1
# iwconfig eth1 essid "MyNetwork"
# iwconfig eth1 key XXXXXXXXXXXXXXXX

everything works. Only problem is everything I commented out looked like it belonged there,so I'm a bit confused about the boot scripts.

I'll just make this a script for the moment but if anyone wants to tell me how all these things should really be started I'd be very grateful.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
connect to internet trough wireless others connect to me with lan Amir Menesy Linux - Wireless Networking 1 11-13-2007 08:28 PM
Wire network is ok but unable to connect to wireless and wireless card is not detect vitalstrike82 Suse/Novell 4 11-01-2007 06:56 AM
Ubuntu 7.04 Wireless Router Visible but No IP Address bobby_hawk Ubuntu 4 06-20-2007 12:01 AM
SUSE 10.1+Airforce One 54g=AP visible but cant connect rh-penguin Linux - Wireless Networking 1 09-11-2006 03:47 PM


All times are GMT -5. The time now is 08:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration