LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Wireless Slows down computer to a halt (http://www.linuxquestions.org/questions/linux-wireless-networking-41/wireless-slows-down-computer-to-a-halt-529893/)

ShadowHywind 02-17-2007 08:30 AM

Wireless Slows down computer to a halt
 
Hi all, I had my wireless (bcm4311) working flawlessly last month. But i ended up having to reinstall a fresh copy of kubuntu couple of weeks ago (my ext2 partition got accidently deleted). But now i am trying to get my wireless to work again. And everytime i connect with the wireless. My computer will start slowing to the point of it basically just freezeing. And i have no idea where to being. running tp in the console doesn't show anything out of the ordinary, no memory hogs. I have tried the wireless assistant manager, and just running wpa_supplicant and both slows my computer down. So any ideas?

camorri 02-17-2007 10:10 AM

The first thing I would do is kill IPv6 and try again. It causes long waits timing out.

jbuckley2004 02-17-2007 12:04 PM

This is just a SWAG, but I had a similar problem (with Mandriva) after replacing/upgrading my motherboard - Everything involved with my wireless was very slow. If you're using ndiswrapper as a driver, and especially if you moved your wireless pci card around (sorry, I can't tell from the information you provided if either is the case), this may be your problem.

I had introduced an IRQ conflict; ndiswrapper in particular does not play well with some other devices, like the monitor, when they share the same IRQ, and the problem doesn't show up as either a memory problem or as a process hogging cpu. It was solved (almost painlessly) by moving my pci card for the wireless to a different slot.

brunoparga 07-07-2007 08:06 PM

Same problem
 
Hi there, I think I'm having much the same problem as the original poster. I run Ubuntu (feisty, fairly up-to-date) and Windows XP on a Celeron. Under Win it runs OK, but under Linux the computer gets horribly slow when I plug the wireless adapter in and it halts when I plug it out. This is a link to a page here which describes the USB adapter I'm using:

http://www.linuxquestions.org/hcl/sh...t=3778&cat=all

I couldn't even try to kill the IPv6 process as the first reply suggested, since the computer was effectively down. The second reply, as far as I understand it, suggests that the problem might be this: both the USB and the monitor are connected through the same way into the motherboard, which causes a conflict, so I'd have to separate that. Well, judging from the way I can plug things on the back of the box, both the video and the USB controllers are inbuilt on the motherboard, so I don't know if I'd be able to do the job. I'd like ideas on that, please.

English isn't my mother language and I quite lack technical terms, so if anyone who'd answer could kindly use simple language and describe the objects and parts, instead of just naming them, that'd be very appreciated.

Thanks a lot,
Bruno

PS: since I'd rely on that adapter to use Internet on that machine, it'd be a little complicated for me to post outputs from lspci or stuff like that here. If it's absolutely necessary, then I'd do it.

Simon Bridge 07-08-2007 01:36 AM

Quote:

I couldn't even try to kill the IPv6 process as the first reply suggested, since the computer was effectively down.
You can kill ipv6 before you plug it in.
http://ubuntuforums.org/archive/index.php/t-87798.html
Quote:

both the USB and the monitor are connected through the same way into the motherboard, which causes a conflict, so I'd have to separate that.
I've never heard of a usb monitor... if you mean that the dongle (that wireless thing) and the monitor both plug into the same panel on the back of your box, then this is not the same.

If you suspect an irq conflict... I would suggest adding "acpi=noirq" on the kernel line in menu.lst

<off your blank look> OK, I'll show you:

sudo cp /boot/grub/menu.lst /boot/grub/menu.lst.original

(You will be editing a system file.. so we back it up.)

sudo gedit /boot/grub/menu.lst

(This file handles boot settings for each OS you have installed. It has a lot of comments in it which describe what each bit does.

Look through this file for your normal Ubuntu boot. It will be something like this:
Code:

title          Ubuntu, kernel 2.6.20-16-generic
root            (hd0,0)
kernel          /boot/vmlinuz-2.6.20-16-generic root=UUID=2a6975b6-eb02-4b6a-b215-593f0ce276ca ro quiet splash
initrd          /boot/initrd.img-2.6.20-16-generic
quiet
savedefault

... the line that starts with "kernel" is the one you want. Right at the end of it, add in acpi=noirq so it reads

kernel /boot/vmlinuz-2.6.20-16-generic root=UUID=2a6975b6-eb02-4b6a-b215-593f0ce276ca ro quiet splash acpi=noirq

(yeah, that's all one line!)


All times are GMT -5. The time now is 11:18 PM.