LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 07-18-2004, 10:08 PM   #1
burnt_toast
Member
 
Registered: Aug 2003
Distribution: RedHat (What else?)
Posts: 36

Rep: Reputation: 15
Angry Wireless on Dell D600


Hi. I hope someone can help me here. I've been reading up on Wireless capabilities under linux, and I'm very less than encouraged from what I've found. I have a Dell Inspiron D600 with a 1450 Dual-Band WLAN miniPCI Card. The only option that I've tried so far is the ndiswrapper, using the windows driver downloaded from Dell's website.

Here is the order of events (which I got from the ndiswrapper documentation) that I've taken:

1. I did a <make install> on ndiswrapper.
2. I ran ndiswrapper -i /root/wlan-driver/bcmw15a.inf
3. I ran ndiswrapper -l and got the following output:

Quote:
bcmw15a present
4. I ran modprobe ndiswrapper (with no error)
5. The relevant output of lsmod returns the following:

Quote:
ndiswrapper 62868 1
6. dmesg returns the following relevant output:

Quote:
ndiswrapper version 0.8 loaded
ndiswrapper adding bcmwl5.sys
PCI: Found IRQ 11 for device 02:03.0
PCI: Sharing IRQ 11 with 00:1f.5
PCI: Sharing IRQ 11 with 00:1f.6
divert: allocating divert_blk for wlan0
wlan0: ndiswrapper ethernet device 00:90:96:aa:25:68 using driver bcmwl5.sys
7. I ran the following series of commands:

iwconfig wlan0 mode Managed
iwconfig wlan0 key restricted <keyname>
iwconfig wlan0 essid <essidname>

8. After running the command iwconfig wlan0, the following output was returned.

Quote:
wlan0 IEEE 802.11g ESSID:""
Mode:Managed Frequency:2.462GHz Access Point: FF:FF:FF:FF:FF:FF
Bit Rate:54Mb/s
RTS thr:2347 B Fragment thr:2346 B
Encryption key:<keyname> Security mode:restricted
Power Management:off
Link Quality:100/100 Signal level:-10 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:599 Missed beacon:0
9. I added a file named ifconfig-wlan0 to the /etc/sysconfig/network-scripts folder with the following contents:

Quote:
DEVICE=wlan0
USERCTL=yes
ONBOOT=yes
BOOTPROTO=dhcp
HWADDR=<mac address>
10. I ran ifup wlan0 with the following output

Cannot get driver information: No such device

Determining IP information for wlan0...failed

---------------------------------------------------------------

A couple of things to note:
When I ran the command "iwconfig wlan0" (step 8) it didn't have the essid listed, even after specifically setting it using the command "iwconfig wlan0 essid <ssid name>" Also, note that the "ifup wlan0" command returns "No Such Device" even though DMESG reports that it loaded the sys file.

I know that this is a pretty long post, but I'm at my wits end as far as this goes. I'd like to get this working. I'm by no means a newbie (I've been using RH since version 4) and I can honestly say that I 've never had this much trouble setting up a piece of hardware.

If it matters, I'm running Fedore Core 1, and my wireless router is a Netgear WGR614 v4.

Thanks in advance
 
Old 07-19-2004, 01:36 PM   #2
tomap
Member
 
Registered: Jul 2004
Location: Southern NJ
Posts: 44

Rep: Reputation: 15
Hi burnt_toast,

ftr: I’m a noob to linux (hoping to change that) and fairly good with M$ (MCSE back in 97 or 98).

I have a m600 with the same wireless card (1450). With both Knoppix (3.4) and Mandrake 9.1, the wireless wasn’t detected during the install. Tired using “driverloader” but that too failed. It installed OK but I couldn’t access it through the browser nor could I run, “dldrconf”. The file couldn’t be found.

The wire (NIC) works well but would still like to (some way) get the wireless in Linux working too! I’m dual booting with XP Pro. Should you find a cure, please post and / or advise.

Regards,
TomaP
 
Old 07-19-2004, 04:27 PM   #3
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,785
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
For some reason with some Broadcom cards, you need to set the mode to Auto before you can set the ESSID. The other thing I noticed is that you didn't run ndiswrapper -m, which edits your /etc/modprobe.conf file with the line alias wlan0 ndiswrapper. That may have something to do with the "No such device" error message.

Since you are running Fedora, you might want to read this article and see if there is anything useful there. The author is describing the set-up of a pcmcia card, but does go into some of the Fedora slants to ndiswrapper.

By the way, the reason this card isn't detected on install is that there isn't a native linux driver for it, or any other Broadcom wireless card. Please feel free to express your displeasure to Broadcom since they won't wirte a linux driver and won't release enough information for anyone else to write one.

Last edited by Hangdog42; 07-19-2004 at 04:30 PM.
 
Old 07-19-2004, 04:32 PM   #4
burnt_toast
Member
 
Registered: Aug 2003
Distribution: RedHat (What else?)
Posts: 36

Original Poster
Rep: Reputation: 15
AP MAC

Thanks. I'll try resetting the mode to auto. I originally ran ndiswrapper -m, but since the ndiswrapper documentation said that this was for automation purposes, I didn't want to re-run the command until after I got everything working right.

Also, I've noticed the MAC address for the AP. Why in the world is it FF:FF:FF:FF:FF:FF? Is that like a "broadcast" address (if there is one for MAC addresses)?
 
Old 07-19-2004, 04:40 PM   #5
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,785
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I think the FF MAC address is some sort of screw-up/error that gets displayed when the card can't connect to an access point. I see that sometimes when I can't connect to my AP.
 
Old 07-19-2004, 09:33 PM   #6
burnt_toast
Member
 
Registered: Aug 2003
Distribution: RedHat (What else?)
Posts: 36

Original Poster
Rep: Reputation: 15
Unhappy no luck

Alright...I've reset everything and tried from scratch, but it simply won't keep the ssid, and refuses to load when I do the ifup.

I'm about to give up and try to load fedora 2 to see if that will help.

Why in the world don't wireless manufacturers make native linux drivers for their hardware?
 
Old 07-20-2004, 10:12 AM   #7
Glooba
Member
 
Registered: Aug 2003
Distribution: Slackware 10
Posts: 35

Rep: Reputation: 15
I dunno if this applies, but if I use "iwconfig wlan0 key open <key>" v. "iwconfig wlan0 key restricted <key>" it holds an essid. This is on an inspiron 8600 with an Intel 2100 Wlan card.
 
Old 07-20-2004, 10:23 AM   #8
burnt_toast
Member
 
Registered: Aug 2003
Distribution: RedHat (What else?)
Posts: 36

Original Poster
Rep: Reputation: 15
I'll give that a shot tonight when I'm in front of my laptop
 
Old 07-20-2004, 06:02 PM   #9
burnt_toast
Member
 
Registered: Aug 2003
Distribution: RedHat (What else?)
Posts: 36

Original Poster
Rep: Reputation: 15
Alrighty then...that got me one step further. I issued 'iwconfig wlan0 open <keyname>' and that kept my essid, and it also retrieved my AP MAC address. However, when I issue the ifup wlan0 command it still issues:

Code:
Cannot get driver information: No such device
 
Determining IP information for wlan0... failed.
Here's a question...does ndiswrapper require the actual driver files (the sys file that the inf refers to) to be in a particular directory when you load the inf using 'ndiswrapper -i /path/to/inf''? The ndiswrapper documentation wasn't too clear on that point.
 
Old 07-20-2004, 06:08 PM   #10
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,785
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
You may be tripping up on the alias......If you haven't run ndiswrapper -m, then your /etc/modprobe.conf hasn't been modified with the line:

alias wlan0 ndiswrapper

(you can also edit this by hand)


I think without this, there is no connection between wlan0 and ndiswrapper.
 
Old 07-20-2004, 06:36 PM   #11
burnt_toast
Member
 
Registered: Aug 2003
Distribution: RedHat (What else?)
Posts: 36

Original Poster
Rep: Reputation: 15
Talking

Hot Diggity Damn!

I had actually run the ndiswrapper -m command, but when I checked /etc/modprobe.conf the alias wasn't in there. I created a manual entry for it, and reset everything using redhat-config-network. After that, I did an ifup wlan0, and although it gave me the same message, it obtained the dhcp and this is the first wireless post I've made to the forum.

Do you know of anything I need to do in order for it to keep this config on reboot?

Thanks for all your help! I really appreciate it.
 
Old 07-21-2004, 07:17 AM   #12
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,785
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
Well, the change to modprobe.conf should be permanent as is so the only thing you need to do is make sure a dhcp request is sent at boot time. You can probably include your ifup command in your /etc/rc.d/rc.local file since I think every linux distro has one (although it may not be in /etc/rc.d/) and rc.local is the last file run at boot time.
 
Old 07-21-2004, 07:34 PM   #13
jayazusa
LQ Newbie
 
Registered: Jul 2004
Location: Prescott Valley, AZ
Posts: 5

Rep: Reputation: 0
Wireless on Dell D600

What wireless card are you configuring? I am following along trying to setup a Dell D600 with a True Mobile 1400 card it seems to work but I am not able to connect to the wireless network. Could you post the step by step that actuall made your device work? I am new to Linux and the <make install> did noty do anything do I have to launch files form a directory after I do the"make" or move them somewhere. Please help.

Thanks
 
Old 07-21-2004, 09:00 PM   #14
burnt_toast
Member
 
Registered: Aug 2003
Distribution: RedHat (What else?)
Posts: 36

Original Poster
Rep: Reputation: 15
step by step instructions

I'd be happy to post exactly what I did.

I used ndiswrapper to install the windows drivers under linux. Since there are no native linux drivers for most wireless cards, ndiswrapper was developed to use the windows drivers with linux. So, first you have to find a way to get the windows drivers. I went to dell's support site, put in my service tag and downloaded them. The only problem was that the drivers were only available as a self-extracting windows executable (which can't be run under linux). Since my laptop is a dual boot of Fedora/WinXP this wasn't a problem for me. You'll have to find a way to get the extracted files onto your linux filesystem.

After getting the driver, download the ndiswrapper source code. Here is a download link . If that link doesn't work, try going to http://ndiswrapper.sourceforge.net and scouring around for the source file.

Download it to your home folder, fire up a terminal, and run the following command:
Code:
tar -xzvf ndiswrapper-0.8.tar.gz
That command will untar/unzip the archive into a directory. Type
Code:
cd ndiswrapper-0.8
to get into the new directory.

Next, read through the INSTALL file in the ndiswrapper-0.8 directory. This file will explain how to compile ndiswrapper and configure the driver files you extracted, using ndiswrapper. Do everything in this INSTALL file down to (but not including) step 4. Step two walks you though installing the driver file, but I can't tell you which driver to use, because I'm using the 1450 Dual Band card, and not the 1400 TruMobile. Just keep going through step 2 until there is a "present" beside one of the driver files.

Step 4 actually configures the interface. But it's really specific to your wireless setup. After a lot of trial and error, I issued the following commands:

Code:
iwconfig mode Auto
iwconfig wlan0 key open <wep key>
iwconfig wlan0 essid <my-essid>
If you have WEP enabled on your AP, then the second command should work for you. If not, you may not even need to enter the second command. However, in my setup, the third command didn't work until I issued the second one.

Issue 'iwconfig wlan0' and you should see something similar to the following:

Code:
wlan0     IEEE 802.11g  ESSID:"<your essid>"  Nickname:"<your computer name>"
          Mode:Auto  Frequency:2.442GHz  Access Point: <your AP mac address>
          Bit Rate=54Mb/s
          RTS thr=2347 B   Fragment thr=2346 B
          Encryption key:<your encryption key>   Security mode:restricted
          Power Management:off
          Link Quality:100/100  Signal level:-74 dBm  Noise level:-256 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:80  Invalid misc:412   Missed beacon:0
If all looks ok here, then issue:
Code:
ndiswrapper -m
Open up the file /etc/modprobe.conf and make sure the following line is in there:
Code:
alias wlan0 ndiswrapper
If it's not, then add it to the end of the file.

There's one last thing you have to do in order to up the interface. Configure the IP options by manually creating a file in the /etc/sysconfig/network-scripts folder. Name the file ifcfg-wlan0. If you're using the DHCP capabilities of your wireless router, then you'll want to put the following in this file:

Code:
USERCTL=no
PEERDNS=yes
TYPE=Wireless
DEVICE=wlan0
BOOTPROTO=dhcp
If all is well, then at this point, you should be able to issue
Code:
ifup wlan0
It might tell you that it can't find the device, but if it gets the IP information, it should dump you back to a prompt in a matter of about 5 seconds.

The only problem I'm still having is getting this thing to come up on reboot. I've tried editing my startup scripts, but for some reason, they just won't work. Every time I boot up, I have to fire up a terminal and issue the 3 iwconfig commands, and the ifup command.

Anyway, I hope this helped. I know I could have used this kinda support when I first started with linux. Have fun with linux, and don't let this kinda crap discourage you. It makes it all worth it when you can throw your arms in the air and scream "IT WORKED!!!!"
 
Old 07-22-2004, 10:24 PM   #15
jayazusa
LQ Newbie
 
Registered: Jul 2004
Location: Prescott Valley, AZ
Posts: 5

Rep: Reputation: 0
Ok Burnt Toast,

I have a couple of problems
Problem 1
I cannot get the "MAKE INSTALL" work because it says I need my source files where should my source be?

Looks like I'll try the ndiswrapper, however, being a newbie I'm falling over at the first step. Looking at the Install notes :

Prerequisites
-------------
* You need a recent kernel (at least 2.6.0 or 2.4.20) with source.
* Make sure there is a link to the source from the modules directory:
'/lib/modules/<VERSION>/build' should be a link to the kernel
source, where <VERSION> is the version of the kernel you are running.

How do I know there is link to the source?

________
Problem 2
Also I have the same network Card as you in my D600 but I was wondering what inf you referanced? In the driver file from Dell there are two directorys "AR" and "IR" Which one did you use? they both have the "bcmwl5a.inf" in the directory

I have found an RPM of the .71 NDIS Wrapper but it dosn't seem to work Could be wrong driver
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
driver WIRELESS on dell latitude D600 lark Linux - Laptop and Netbook 6 08-25-2007 11:37 PM
Dell D600 - Wireless - Newb question djbeenie Fedora 6 10-12-2005 02:09 PM
Configuring wireless on Dell D600 SuSE 9.2 JWHolloway Linux - Laptop and Netbook 12 07-08-2005 02:00 PM
wireless not working on fc3 on dell d600 totenengel Linux - Laptop and Netbook 8 02-12-2005 04:46 AM
Dell Latitud D600 Richard Craneum Linux - Laptop and Netbook 5 10-13-2004 05:12 AM


All times are GMT -5. The time now is 01:34 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration