LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 10-11-2008, 05:51 PM   #1
ngjunkie0011
Member
 
Registered: Jun 2005
Location: New York
Distribution: Ubuntu Studio
Posts: 105

Rep: Reputation: 15
Wireless not working with encryption turned on


Wireless networking works PERFECTLY using winXP. I have Linksys Router BEFW11S4 Firmware Version: 1.52.02. I tested the wireless card with my ubuntu box with no encryption and I was able to connect and get an IP. However, when I enable WEP encryption at 64 bits 10 hex digits Wireless Encryption Level, I am unable to connect using my ubuntu distro. It works fine with Windows XP???? Do I have to manually configure WEP or is there an issue with WEP in Linux???

Can someone help me troubleshoot the wireless connectivity with encryption enabled???
 
Old 10-11-2008, 06:01 PM   #2
ngjunkie0011
Member
 
Registered: Jun 2005
Location: New York
Distribution: Ubuntu Studio
Posts: 105

Original Poster
Rep: Reputation: 15
Here is the output of iwconfig when the router is configured with encryption enabled. The weird thing is that my router sees my laptop connected but it doesn't receive an IP. Again, I am able to connect with encryption disabled. I am typing this post from my lappie.


eth1

IEEE 802.11-DS ESSID:"wnet"
Mode:Managed Frequency:2.412 GHz Access Point:
Bit Rate:11 Mb/s Tx-Power=20 dBm Sensitivity=0/65535
Retry limit:16 RTS thr: off Fragment thr: off
Power Management: off
Link Quality=100/100 Signal level=-38 dBm Noise level=-90 dBm
Rx invalid nwid:10851 Rx invalid crypt:1 Rx invalid frag:0
Tx excessive retries:45 Invalid misc:175984 Missed beacon:0

wifi0

IEEE 802.11-DS ESSID:"wnet"
Mode:Managed Frequency:2.412 GHz Access Point:
Bit Rate:11 Mb/s Tx-Power=20 dBm Sensitivity=0/65535
Retry limit:16 RTS thr: off Fragment thr: off
Power Management: off
Link Quality=100/100 Signal level=-38 dBm Noise level=-90 dBm
Rx invalid nwid:10851 Rx invalid crypt:1 Rx invalid frag:0
Tx excessive retries:45 Invalid misc:175984 Missed beacon:0

Last edited by ngjunkie0011; 10-15-2008 at 12:46 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless doesn't work if encryption turned on pchw Linux - Wireless Networking 9 03-28-2006 11:02 AM
Wireless Network not working with Encryption enabled goel_ar Linux - Wireless Networking 3 07-26-2005 08:53 AM
Belkin F5D6020 isn't working in Fedora when WEP is turned on? laltopi Linux - Wireless Networking 2 03-08-2004 12:24 PM
Wireless DHCP and encryption not working on RedHat 9.0 asadhussain Linux - Wireless Networking 0 10-13-2003 10:54 AM
Mandrake 9.0 Wireless Works without encryption.. does not with encryption topcat Linux - Wireless Networking 3 05-04-2003 08:47 PM


All times are GMT -5. The time now is 02:59 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration