LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Wireless not working on Slackware 12 (http://www.linuxquestions.org/questions/linux-wireless-networking-41/wireless-not-working-on-slackware-12-a-623349/)

grandbazaar 02-23-2008 02:33 PM

Wireless not working on Slackware 12
 
Hi,

I recently installed Slackware 12 on my PC which has two network cards (one which is wireless). Out of the box only one eth is added (eth0) it seems to be assigned to my non-wireless nic.

Searching through the web I found that my wireless card DLINK WDA-2320(Atheros based) should work out of the box. I am not familiar with adding eth devices so help would be appreciated. I would also like to deactivate my non-wirless if possible.

Notes: lspci gives me the correct details of both network cards. My /etc/rc.d/rc.wireless.conf file has been edited with my wireless info.

grandbazaar 02-23-2008 04:05 PM

O.K I've done some more working on this issue. Here's what I've done.

1. installed mad-wifi package for Atheros support.
2. added to my /etc/rc.modules file the line to start module "/sbin/modprobe ath-pci"
3. edited /etc/rc.d/rc.wireless.conf file with router info including hex key.
4. restarted services
5. brought down my eth0 card

Results:

ath0 and wifi0 now appear when I execute ifconfig. iwconfig command lists my ath0 interface with correct ESSID. kwifimanager lists my ath0 connection correctly giving the signal an "ultimate" rating but no IP address is assigned. Internet doesn't work and pinging address's obviously doesn't respond.

I have the feeling not much is missing to make it work.
any help would be greatly appreciated.

Thanks in advance.

grandbazaar 02-23-2008 04:58 PM

Ok for some reason I can connect to my router's management program with WI-FI
but internet doesn't work.

Here goes more Info that may help troubleshoot me:

ifconfig --
Quote:

ath0 Link encap:Ethernet HWaddr 00:19:5B:D1:7C:EE
inet addr:192.168.1.102 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::219:5bff:fed1:7cee/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:722 errors:0 dropped:0 overruns:0 frame:0
TX packets:718 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:731907 (714.7 KiB) TX bytes:68387 (66.7 KiB)

eth0 Link encap:Ethernet HWaddr 00:0C:6E:88:C6:59
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:22

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:364 errors:0 dropped:0 overruns:0 frame:0
TX packets:364 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:31196 (30.4 KiB) TX bytes:31196 (30.4 KiB)

wifi0 Link encap:UNSPEC HWaddr 00-19-5B-D1-7C-EE-61-74-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:12279 errors:0 dropped:0 overruns:0 frame:3633
TX packets:957 errors:2 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:199
RX bytes:1825891 (1.7 MiB) TX bytes:101395 (99.0 KiB)
Interrupt:18


iwconfig --
Quote:

ath0 IEEE 802.11g ESSID:"ChopSquad" Nickname:"fox"
Mode:Managed Frequency:2.462 GHz Access Point: 00:18:F8:35:EE:8B
Bit Rate:54 Mb/s Tx-Power:18 dBm Sensitivity=1/1
Retry:off RTS thr:off Fragment thr:off
Encryption key:{KEY} Security mode:restricted
Power Management:off
Link Quality=37/70 Signal level=-53 dBm Noise level=-90 dBm
Rx invalid nwid:1160 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

lo,eth,wifi0 : no wireless extensions

dhclient --
Quote:

wifi0: unknown hardware address type 801
wifi0: unknown hardware address type 801
Listening on LPF/wifi0/
Sending on LPF/wifi0/
Listening on LPF/eth0/00:0c:6e:88:c6:59
Sending on LPF/eth0/00:0c:6e:88:c6:59
Listening on LPF/ath0/00:19:5b:d1:7c:ee
Sending on LPF/ath0/00:19:5b:d1:7c:ee
Sending on Socket/fallback
DHCPDISCOVER on eth0 to 255.255.255.255 port 67 interval 8
DHCPREQUEST on ath0 to 255.255.255.255 port 67
DHCPDISCOVER on wifi0 to 255.255.255.255 port 67 interval 5
DHCPREQUEST on ath0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.1
bound to 192.168.1.102 -- renewal in 40490 seconds.
Kwifimanager ScreenShot :
http://i18.photobucket.com/albums/b1...ifimanager.png

Hangdog42 02-24-2008 07:21 AM

That's really weird. From what you've posted, you've got everything that you need to be up and running. You should check the output from route -n and make sure your router's IP address is the same for the gateway. Also check your /etc/resolv.conf and see if there are legitimate DNS servers listed.

Oh, and just in case it might make a difference, I always use dhcpcd instead of dhclient. I've always found dhclient to be flaky. Since both are installed in Slackware, give dhcpcd a try and see if it works better.

grandbazaar 02-24-2008 12:53 PM

Hi,

checked resolv.conf, and it's empty. Not familiar with Linux system files so not sure what that's suppose to contain.

dhcpd does not seem to work it keeps on prompting me to
add a subnet configuration to dhcpd.conf which I did but seems
to work only if Ath0 has a subnet attached to it which defeats the purpose
of me wanting to use it.

as for route -n command here is the output. My wifi card (ath0) seems to have no Gateway assigned, is that normal? if not, how do I go about to fix it ?
Quote:

Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 ath0
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 ath0

Thanks for the help.

Hangdog42 02-25-2008 07:28 AM

Quote:

checked resolv.conf, and it's empty. Not familiar with Linux system files so not sure what that's suppose to contain.
It is supposed to contain the IP addresses of the nameservers you ISP has you using. If it is empty, that is not good. For example, if you can get to LQ by entering http://75.126.162.205 but not with http://www.linuxquestions.org , then you've got a DNS issue. It is easy to fix, but dhclient should have populated resolv.conf with at least one DNS server.

Quote:

dhcpd does not seem to work
That is because that isn't the command I suggested you use. The one you ran (dhcpd) is the DHCP server that comes with Slackware, and no, you don't need to run it. The one I suggested (dhdpcd) is the DHCP client. Note that c between the p and d, it is VERY important.
Quote:

As for route -n command here is the output. My wifi card (ath0) seems to have no Gateway assigned, is that normal? if not, how do I go about to fix it ?
Actually, if you look closer, that info is OK. The last line has an IP address under the Gateway column. As long as 192.168.1.1 is your router's IP, this part should be good to go.

Personally, I'm betting on a DNS issue, so try the test on getting to LQ by IP address and name. Also give dhcpcd a run.

grandbazaar 02-25-2008 01:50 PM

I guess you were right, dhclient is flakey because running dhcpcd worked, thanks to you!
It populated my resolv.conf file with many dns address's.

Now my next question is how do I automate the running of dhcpcd at boot time so that
my network is all up and running correctly without me having to lift a finger ?

Hangdog42 02-25-2008 03:41 PM

There are a couple of ways of doing it. Probably the most official way is to edit your /etc/rc.d/rc.inet1.conf file and modify an entry to suit your needs. An alternative would be to run the needed commands to configure and get an IP address in /etc/rc.d/rc.local. Since I pretty routinely bounce between three different wireless networks, I've always found the standard way too restricting, so I've written a collection of scripts that I run from a console as needed.

grandbazaar 02-25-2008 07:56 PM

Thanks for you're help and expertise!
I can finally move on to setting up the rest of Slackware, which is much easier to do with the help of internet :P


All times are GMT -5. The time now is 09:08 AM.