LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 10-26-2012, 03:58 AM   #16
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,371

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557

Here's how a connected wifi looks
Quote:
bash-4.2$ iwconfig wlan0
wlan0 IEEE 802.11bg ESSID:"My_Essid"
Mode:Managed Frequency:2.462 GHz Access Point: 00:11:22:33:44:55
Bit Rate=48 Mb/s Tx-Power=20 dBm
Retry long limit:7 RTS thrff Fragment thrff
Power Managementff
Link Quality=67/70 Signal level=-43 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:758 Missed beacon:0
The access point says you're associated. Right there on line 2 it says "not associated" if you're not associated. Check the Quality also. Things can get dodgy below 40/70.

Sorry about errors. The wireless tools (iwconfig, iwlist) both always need wlan0 as the first argument.
To see how it's going, just run 'ifconfig wlan0' after the 'dhcpcd wlan0' line - see if wlan0 has an IP. 169.254.x.x is not a working IP, but the default when it fails to get one.

you should see this sort of stuff from the dhcpcd command, btw

Quote:
Oct 5 15:24:53 harriet dhcpcd[1249]: version 5.5.6 starting
Oct 5 15:24:53 harriet dhcpcd[1249]: wlan0: sending IPv6 Router Solicitation
Oct 5 15:24:53 harriet dhcpcd[1249]: wlan0: broadcasting for a lease
Oct 5 15:24:53 harriet dhcpcd[1249]: wlan0: offered 192.168.0.100 from 192.168.0.1
Oct 5 15:24:53 harriet dhcpcd[1249]: wlan0: acknowledged 192.168.0.100 from 192.168.0.1
Oct 5 15:24:53 harriet dhcpcd[1249]: wlan0: checking for 192.168.0.100
Oct 5 15:24:57 harriet dhcpcd[1249]: wlan0: sending IPv6 Router Solicitation
Oct 5 15:24:58 harriet dhcpcd[1249]: wlan0: leased 192.168.0.100 for 604800 seconds
Oct 5 15:24:58 harriet dhcpcd[1249]: forked to background, child pid 1254
Ethernet Fast Switching is in the BIOS. Don't worry about kernels.
 
Old 10-27-2012, 10:01 AM   #17
Ace Blackwell
Member
 
Registered: Mar 2004
Location: Kentucky, USA
Distribution: SlamD 12.1 / Slack 12.0 ~ 14.0_64
Posts: 284

Original Poster
Rep: Reputation: 30
Well BK, I am now speaking to you from Slackware 14.0 64 with Broadcom 4312. It was a long process. I appreciate all your help and patience.

Here is what finally got me over the hump. I ran your previous suggestions
ifconfig wlan0 up
iwlist wlan0 scan|less (I think I have my MAC address memorized at this point)
iwconfig wlan0 essid "Ace" ap 00:00:00:00:00:00

At this point I ran iwconfig wlan0 and seen that I wasn't associated

I ran wpa_supplicant -c/etc/wpa_supplicant.conf -Dwext -iwlan0 && iwconfig essid "Ace" ap 00:00:00:00:00:00

as usual it just dropped to the next line and hung up. Then I went and pulled up the wpa_supplicant.conf file and noticed it didn't have any information in it. Including my passphase. So I surfed around and learn what needed to be in the file. I updated the file by hand and reran all the previous commands. The wpa_supplicant command associated and connected. It still hung up (I may have had something entered wrong still. I'll clean it up later) then I ran iwconfig wlan0 and seen I was associated. Lastly I ran dhcpcd wlan0 and here I am.

For the moment I'm going to start populating my computer with all my files and programs. In time I'll clean up a few quirky items and then I'll dive in to what is exactly happening with the wpa_supplicant.conf file and fully understanding the process so I'll be able to duplicate next time on my own.

Again, Thanks for all your help. Scottie has nothing on you (nod to Ireland)

Ace
 
Old 10-27-2012, 01:38 PM   #18
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,371

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
Great that you're going. Here's my /etc/wpa_supplicant.conf
Quote:
bash-4.2$ sudo cat /etc/wpa_supplicant.conf
# See /usr/doc/wpa_supplicant-0.5.10/wpa_supplicant.conf.sample
# for many more options that you can use in this file.

# This line enables the use of wpa_cli which is used by rc.wireless
# if possible (to check for successful association)
ctrl_interface=/var/run/wpa_supplicant
# By default, only root (group 0) may use wpa_cli
# ctrl_interface_group=0
eapol_version=1
ap_scan=1
fast_reauth=1

# WPA protected network, supply your own ESSID and WPAPSK here:
network={
# scan_ssid=0
ssid="Moriarty"
proto=WPA
key_mgmt=WPA-PSK
#psk="My_passphrase"
psk=stuff that wpa_passphrase spits out
}
#
# Plaintext connection (no WPA, no IEEE 802.1X),
# nice for hotel/airport types of WiFi network.
network={
key_mgmt=NONE
priority=0
}
Now I don't know if they still do it, but some Slackware config file had sections with the leading digits of the mac address of your computer, but I hacked all that out as most of it was a pure waste. Manufacturers have a code to start their mac addresses with, so you can identify the manufacturer from the mac if the mac address is original (Big If).

You should be able to configure rc.wireless.conf and maybe touch up section [4] in rc.inet1.conf which will override any settings in wireless.conf.
 
Old 10-27-2012, 08:54 PM   #19
Ace Blackwell
Member
 
Registered: Mar 2004
Location: Kentucky, USA
Distribution: SlamD 12.1 / Slack 12.0 ~ 14.0_64
Posts: 284

Original Poster
Rep: Reputation: 30
I am only having one issue. I lose connection pretty quickly and I have to log off and restart. My signal shows being 62/70. However when I do the wpa_supplicant command, it associates and connects but hangs after CONTROL EVENT blah blah blah. I have to Ctrl-Z to get to move on. It does t stop me from getting on but could be contributing to the dropping out. Meanwhile is there a way to add all the set up commands to a boot up script. So I don't have to type every time . Also what happens if I take the laptop some where else? Do I have to type the Essid for those networks too? Just asking.
Thanks
Ace
 
Old 10-28-2012, 03:57 AM   #20
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,371

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
That wpa_supplicant.conf works on my place, and unprotecrted networks. The section between the { & } is the output of 'man wpa_passphrase. IIRC, B43 doesn't do WEP, but does all forms of wpa.

To go live at boot: The config files I offered were here
https://skydrive.live.com/#cid=99361...4096FF2C07!208
The rc.wireless.conf & rc.inet1.conf work in my place, the local College, and a few hotels at least. There is often an issue with resolv.conf if they use their own dns (and disallow yours) but you can sort that on a place by place basis. If the dns doesn't come up right, find out what it should be, set
DHCP_KEEPRESOLV="yes"
and try again.

On the dropouts, I've no idea. 62/70 is fine. What issues the CONTROL_EVENT?

Last edited by business_kid; 10-28-2012 at 04:00 AM.
 
Old 11-04-2012, 02:39 PM   #21
Ace Blackwell
Member
 
Registered: Mar 2004
Location: Kentucky, USA
Distribution: SlamD 12.1 / Slack 12.0 ~ 14.0_64
Posts: 284

Original Poster
Rep: Reputation: 30
Business Kid,

Well I finally got everything to work correctly. Your help was greatly appreciated. At the point I was at previously, I couldn't stay on line but for 2-3 mins before I was dropped and had to do everything over to get it back up and running. So I tried uninstalling the fwcutter and b43 and installed broadcom_sta. Still no luck. At that point I decided I was going back to 13.37_64. This ended up being a good thing. To bore you with a long story, I installed 13.37_64. I down loaded fwcutter and b43 firmware. Didn;t have any luck so I looked around and found some slack builds with older version levels for 13.37_64. I then installed Wicd 1.6.X.X I think, from my previous installation. It let me stay on line and it logged on to a local unsecured network. However when I went to enter my pass key, it wouldn't leave the set up screen. It acted like it was waiting on me to hit Ok. To cut to the chase, I realized my mistake. I had Wicd for 32 bit. I guess it worked previously before I started installing 14.0_64, because I had the multilibs installed for 32bit. Sure enough, once I got 1.7.2.1 _64 I was on strong.

Energized with new determination, I reinstalled 14.0_64. Installed fwcutter 014 and b43-firmware-5.10.56.27.3. I installed Wicd 1.7.2.4_64 (Slack Build) and I've been running strong ever since. Also as a side note, I noticed 13.37 wpa_supplicant.conf had my ESSID and passkey and also a generic "ALL" type set up as well. Upon installing 14.0_64 the wpa_supplicant.conf only had two lines, like last time. Don't remember specifically but was something about controlXXXXXXX.
So I replaced it with the one from my 13.37_64 installation. Not sure if it amounted to anything given I copied it first before installing wicd. But just as an FYI.

I hope my adventure and conclusion helped someone running 14.0_64. Now that the wireless thing is over, I really am liking the upgrade to 14.0. Again, thanks for all you help.

Ace
 
Old 11-05-2012, 04:18 AM   #22
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 6,371

Rep: Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557Reputation: 557
Thanks, Ace. I spent a Month here in the beginning installing distros & trying to get online, and another few days when I went encrypted. But once you master it, you're made up. And it's so much more intellectually satisfying than something like gnome's NetworkManager.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless won't connect to password-protected networks qianian Linux - Wireless Networking 6 09-23-2009 06:26 PM
Slackware 12.2 will not connect to Wireless Networks picketfence Linux - Laptop and Netbook 9 03-28-2009 10:00 AM
how i connect in wireless networks ? hatebreeder666 Linux - Newbie 2 01-03-2009 03:11 PM
Can't Connect to any Encrypted Wireless Networks markackerman8@gmail. Linux - Newbie 3 07-13-2008 12:52 PM
NetworkManager can't connect to wireless networks debeus Linux - Laptop and Netbook 3 12-26-2007 07:39 PM


All times are GMT -5. The time now is 11:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration