LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 06-21-2005, 01:06 PM   #1
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Rep: Reputation: 30
Wireless internet on a Toshiba Satelite a70 w/atheros card.


I recently installed Fedora Core 4 on my Toshiba Satellite a70-ML1 laptop. In order to install wireless network support, I was told to do this (note that these are instructions for gentoo, not fedora 4)

Quote:
Wireless Setup
After I finished the install I added net-wireless/madwifi-driver ~x86 to /etc/portage/package.keywords so that I could install the masked madwifi drivers for my atheros wifi adapter built in to the laptop. To setup the wireless nic do the following.
emerge madwifi-driver
emerge wireless-tools
cp /etc/init.d/net.eth0 /etc/init.d/net.ath0
modprobe ath_hal
modprobe ath_pci
modprobe wlan
echo "ath_hal" >> /etc/modules.autoload.d/kernel-2.6
echo "ath_pci" >> /etc/modules.autoload.d/kernel-2.6
echo "wlan" >> /etc/modules.autoload.d/kernel-2.6


To use the wireless adapter do
iwconfig ath0 essid any
iwconfig ath0 key off
iwconfig ath0 channel 6
/etc/init.d/net.ath0 start


substitute your appropriate settings as needed.

now add the net.ath0 init script to your startup
rc-update add net.ath0 default
also you will need to modify /etc/conf.d/net and add lines for ath0 like you edited for etho during the installation.
If you plan to use the wireless nic exclusively then you might want to remove eth0 from your startup.
rc-update del net.etho default

Next be sure to emerge hotplug and coldplug they will load needed modules automatically.
Can someone make sense of this? I was lost by the first line. I need to know what I need to download, and how to run it. I have set up wireless internet on a computer before, but I used ndiswrapper, this seems nothing like it.
 
Old 06-21-2005, 05:59 PM   #2
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,430

Rep: Reputation: 83
#1. You need madwifi package. I am not sure if you have installed it. If not, you can find it http://madwifi.sourceforge.net

#2. You need to install wireless-tools package. Again, I am not sure if you have installed it.

#3. Then, depending on your directory configuration, you want or do not want to follow
Code:
cp /etc/init.d/net.eth0 /etc/init.d/net.ath0
(I do not know anything about Gentoo and FC.)

I am using atheros on my Toshiba laptop.

Check #1 and #2 and come back here.
 
Old 06-21-2005, 11:23 PM   #3
flystar06
LQ Newbie
 
Registered: Apr 2004
Location: Tennessee
Distribution: SimplyMEPIS3.3.1
Posts: 20

Rep: Reputation: 0
go here ... i had the same questions not too long ago ... and they were answered ... i hope that thread helps ... reply if it doesn't
 
Old 06-22-2005, 05:54 AM   #4
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Original Poster
Rep: Reputation: 30
Quote:
Most people can just type:

trouble% make

at the top level to build all the modules for the system where you
are building.
1. trouble% make does nothing.

2. where is the top level?
 
Old 06-22-2005, 02:38 PM   #5
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Original Poster
Rep: Reputation: 30
Sorry, didn't notice the message there. I installed the rpm packages for fc4, and everything went great, but according to Fedora, I have wireless-tools installed, yet ifconfig, iwconfig, iwlist don't do anything. I created the file that I was told to on the other post linked in the post earlier, but nothing happened, and when I restarted, fedora didnt detect any new hardware. I don't think I got the right wireless channel in my file either, could someone give me an example of what should be there?
 
Old 06-22-2005, 08:32 PM   #6
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Original Poster
Rep: Reputation: 30
OK, another update, and another question.

I got madwifi installed from source, and fedora can pick up my card now. I also figured out that I need to use the fedora network manager, which is a graphical version of wireless tools, I think. So, I set up ath0, and when I try to connect, I get the following error:

Quote:
Error for wireless request "Set Bit Rate" (8B20) :
SET failed on device ath0 ; Invalid argument.
Error for wireless request "Set Encode" (8B2A) :
SET failed on device ath0 ; Invalid argument.

Determining IP information for ath0...ping: icmp open socket: Permission denied
failed.
So, what's wrong?
 
Old 06-22-2005, 08:49 PM   #7
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,430

Rep: Reputation: 83
You successfully installed packages.

What happens when you
Code:
ifconfig
?

This is the starting point.

EDIT
This is not GUI. command line.

Last edited by kaz2100; 06-22-2005 at 08:58 PM.
 
Old 06-22-2005, 09:07 PM   #8
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Original Poster
Rep: Reputation: 30
[simon@simons ~]$ ifconfig
bash: ifconfig: command not found
[simon@simons ~]$

I think fedora is trying to erase command line use, or my install screwed up, but everything else works, so I doubt it.
 
Old 06-22-2005, 09:21 PM   #9
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,430

Rep: Reputation: 83
Auch, /sbin/ifconfig or log in as root.

This part, you are using FC, I have Slackware and Debian. All I know stis on command line.

Last edited by kaz2100; 06-22-2005 at 09:24 PM.
 
Old 06-22-2005, 09:28 PM   #10
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Original Poster
Rep: Reputation: 30
Thanks, I'll add a link or something to those in ~/.bin or ~/bin or something so it's easier next time. Anyway,

eth0 Link encap:Ethernet HWaddr 00:0F:B0:5B:FE:AD
inet addr:192.168.1.205 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::20f:b0ff:fe5b:fead/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:672 errors:0 dropped:0 overruns:0 frame:0
TX packets:668 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:410045 (400.4 KiB) TX bytes:90232 (88.1 KiB)
Interrupt:201 Base address:0xa000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1631 errors:0 dropped:0 overruns:0 frame:0
TX packets:1631 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1522214 (1.4 MiB) TX bytes:1522214 (1.4 MiB)

is the outcome of ifconfig.
 
Old 06-22-2005, 09:36 PM   #11
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,430

Rep: Reputation: 83
Code:
ifconfig ath0 up
and see what happens. If ifconfig complains that ath0 is non-existant. Please refer
http://www.linuxquestions.org/questi...hreadid=336177

(This thread is still going.) Then post whatever informative thing.

If ifconfig goes well,
Code:
iwconfig ath0 essid any
iwlist ath0 scanning
Once these look good, you will set up either static IP or dhcp. This part is distro dependant. (I cannot help much)

If wrong, post informative things here.
 
Old 06-22-2005, 09:41 PM   #12
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,430

Rep: Reputation: 83
I appreciate if you follow the link
http://www.linuxquestions.org/questi...hreadid=336177
and give any suggestion opinion whatever as a member of Penguin community.
You use Mandaravia also.
 
Old 06-22-2005, 09:59 PM   #13
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Original Poster
Rep: Reputation: 30
Thanks very much, kaz2100, after playing with iwconfig and ifconfig for a while, I pulled the ethernet plug from the back of my computer, and I don't think it worked, but a few minutes later, I thought I'd check up on my post, and forgot to plug my network back in, and it worked (I didn't notice at the time). So I followed some of the instructions on the other page, I went to unplug ethernet, and it wasn't plugged in. I set it to start up automatically when I boot up my system, and I'm hoping it won't screw up when I do. So, that's my story, and I don't remember how I did it.
 
Old 06-22-2005, 10:08 PM   #14
kaz2100
Senior Member
 
Registered: Apr 2005
Location: Penguin land, with apple, no gates
Distribution: Debian testing woody(32) sarge etch lenny squeeze(+64) wheezy jessie
Posts: 1,430

Rep: Reputation: 83




Basically,
1. turn on interface, (ifconfig ath0 up, or ifup........)
2. configure wireless (id, passwd.....)
3. DHCP or static IP.

you can find somewhere in /etc/init.d or /etrc/rc.d, depending your configure, you modify as necessary.

Have fun

Last edited by kaz2100; 06-22-2005 at 10:13 PM.
 
Old 06-22-2005, 10:11 PM   #15
simeandrews
Member
 
Registered: May 2004
Distribution: Debian
Posts: 341
Blog Entries: 1

Original Poster
Rep: Reputation: 30
I just figured out how I did it, I ran /sbin/dhclient. Is there a way to turn that on when the computer starts?

I know we've had an IM type thing going on, but its 1:00, so I'm going to bed.

Last edited by simeandrews; 06-22-2005 at 10:13 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wireless Atheros ar5004g card on Toshiba A60 satellite laptop cannot get dhcp lease crazynoodle7 Linux - Newbie 6 06-30-2006 09:27 AM
intel wireless pro 2200 detected as atheros wireless card? whf Suse/Novell 5 08-29-2005 06:04 PM
wireless Atheros ar5004g card on Toshiba A70 satellite laptop j0ck Linux - Wireless Networking 3 04-27-2005 05:38 AM
Wireless internet - Toshiba - Atheros rksprst Linux - Hardware 6 12-31-2004 07:09 AM
Wireless on Toshiba A35-S209 w/ Atheros AR5001x+ TrojanMan Linux - Wireless Networking 3 05-20-2004 11:21 AM


All times are GMT -5. The time now is 10:27 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration