LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 07-20-2004, 12:10 PM   #1
CypherXero
LQ Newbie
 
Registered: Jul 2004
Posts: 9

Rep: Reputation: 0
Wireless in Linux: Guide


I've written a guide to getting wireless cards to work in Linux, specifically integrated BroadCom and SuSE 9.1 Professional. Please comment on this, and spread this guide around with credit to me (CypherXero). Thanks! Enjoy!

***

Wireless in Linux: Part One
So, you've decided to install one of the many distros of Linux and you've come across a really bad situation: your wireless LAN card will not work. Actually, most, if not all, wireless cards will work under Linux, but you have to be smart about it and apply a few “tricks” to get it to work.

In this guide, my test environment consists of the following:

* SuSE 9.1 Professional
* Integrated BroadCom 802.11g Wireless NIC
* Kernel 2.6.4

So, let's get started.

1. First, you'll need to download NDISWrapper.

2. Extract the tar.gz file and you'll get a folder called “ndiswrapper-0.8”.

3. Download your wireless drivers for Windows XP. BroadCom users like me can get the correct drivers here.

4. Extract the BroadCom (or other) drivers. Creating a folder called broadcom or something else appropriate to put the files in makes things easier.

5. Make sure that you have GCC, make, and the kernel source code on your system. If you're running SuSE, you can open up YaST2, and then select “Install and remove software”. Search for GCC, make, and kernel, and check to see if they're installed. If not, you will need to install them.

6. Open up bash (Konsole, Xterm, etc.).

7. Type in “su root” and enter the password for root when prompted.

8. Type in “cd ./ndiswrapper-0.8” (or the location in which the NDISWrapper folder is located).

9. Once you're in the directory of NDISWrapper, run “make”.

10. Once “make” is finished, execute “make install”.

11. Type in “ndiswrapper -i [/path/to/inffile.inf]” (the .inf file will be found in the folder where you extracted the Windows XP drivers).

12. After installing, you can run “ndiswrapper -l” to see the status of your installed drivers.

13. Type “modprobe ndiswrapper”.

14. Type in “iwconfig wlan0 essid [SSID]”, and enter in the SSID of your wireless network.

15. If you use encryption (WEP), set the key using “iwconfig wlan0 key restricted XXXXXXXX”.

16. Finally, type in “ndiswrapper -m” and restart your computer. Once you return you Linux, you should have a working wireless card in Linux!!!

Wireless in Linux: Part Two

Nothing is ever guaranteed. Soon after getting my wireless to work, it wouldn't work anymore. Something was wrong. I even went so far as to reinstall SuSE TWICE, and I was still having problems.

I got so far as to be able to connect to my router (and makes changes, etc..), but I couldn't ping my DSL modem, and I couldn't get online. So, after many hours and hours of searching, and trying to figure out what to do (I was at the shell until 2AM last night trying to get my wireless to work again) So, this morning, I started doing a lot of Google searching (as if I hadn't done that already), and I found...a solution. And so I'm going to share it with you guys, because you might run into this problem.

The problem was quite simple...the default route is confused between eth0 and wlan0 (my wired NIC and my wireless NIC). I've had to use eth0 to get online to search for answer. So, I found a way to resolve this.

Fixing The Problem
1. Once you have everything up and running (wlan0 and eth0 are both active), unplug the ethernet cable from your computer.
2. Open up bash (Konsole, Xterm, etc..), and type in "su root" and then the root password.
3. Now type in "ifdown eth0"
4. Next, type in "ifdown wlan0"
5. Now, type in "ifup wlan0"
6. Then, type in "ifconfig -a"
7. Finally, type in "route" to check your routing.

This should work! As soon as I followed those steps, I opened up my browser, crossed my fingers, and fired up Google...and it WORKED. I hope this has saved someone hours and hours of frustration.
 
Old 07-20-2004, 12:42 PM   #2
Rob Roye
Member
 
Registered: Mar 2004
Location: Mishawaka, IN
Distribution: SuSE 9.0, 9.1, 9.2
Posts: 38

Rep: Reputation: 15
Ok, it's official. I now love you.

Oh, stop laughing.

I use SuSE 9.0 with a Broadcom integrated 802.11g card. Hmmm, see any similarities? I really appreciate this effort, you saved me much time in trying to get my wireless working in Linux. Thank you.
 
Old 07-20-2004, 11:35 PM   #3
CypherXero
LQ Newbie
 
Registered: Jul 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Quote:
Originally posted by Rob Roye
Ok, it's official. I now love you.

Oh, stop laughing.

I use SuSE 9.0 with a Broadcom integrated 802.11g card. Hmmm, see any similarities? I really appreciate this effort, you saved me much time in trying to get my wireless working in Linux. Thank you.
Hehe, glad I could help out
 
Old 07-21-2004, 07:06 PM   #4
oudent
Member
 
Registered: Jul 2001
Distribution: Ubuntu
Posts: 195

Rep: Reputation: 30
Looks good...I just think it is important to mention that if there is a driver for your device in linux, open sourced or official, then this guide is not the best way for you to go. NDISWrapper is a quick and dirty fix (no offense intended) though it works well, and is indeed a super tool when nothing else is available. The important point that has been made time and time again by others is that this is an extra interpreter, and therefore can never give the full performance of an actual driver, and introduces non-opensourced code into your system.

But again, it is an amazing tool for those of you who have no other choice, or cannot get anything else to work. Just remember that it should only be used in desperate situations.
 
Old 07-21-2004, 08:30 PM   #5
efanning
Member
 
Registered: Jul 2004
Distribution: Right now - Ubuntu 7.04
Posts: 81

Rep: Reputation: 15
I've followed these same instructions to install ndiswrapper that were in the INSTALL file. I just still have one problem, when I reboot, it does not remember my encryption. The only way that I can get it to connect it to remove the encryption on my wireless router, reboot, connect to my router, reinstate my WEP encryption, set it up on wlan0 and everything's fine until I reboot again. Can anyone help me?

My system:

HP Pavilion ze4805us
Currently running Mandrake 10
Broadcom wireless
ndiswrapper

Linksys 2.4Ghz Wireless B router

Any suggestions would be greatly appreciated!!

Thanks

Signed

 
Old 07-22-2004, 04:37 PM   #6
ScotsDave
LQ Newbie
 
Registered: Jul 2004
Location: Omaha, NE
Posts: 1

Rep: Reputation: 0
Many Thanks

CypherXero, Many thanks. I am not exactly a newbie to Linux and Networking but this had been driving me crazy. You saved me spending $20 on Linuxant

Setup:

Suse 9.1 Pro
Motorola PCI 802.11g Broadcom based card.
Kernal 2.6.4
 
Old 07-22-2004, 05:42 PM   #7
Ghost_runner
Member
 
Registered: Jun 2004
Location: Kansas City, MO
Distribution: openSUSE 10.2/64bit
Posts: 276

Rep: Reputation: 30
add to the wiki?
 
Old 07-22-2004, 05:44 PM   #8
CypherXero
LQ Newbie
 
Registered: Jul 2004
Posts: 9

Original Poster
Rep: Reputation: 0
Today, I've been using Linux for about, I'd say 10 or 11 days now. When I wrote this guide to Wireless in Linux, I had been using Linux for 4 days!

Yeah, I wanna add this to the wiki, too, what's the link?
 
Old 07-22-2004, 05:54 PM   #9
Ghost_runner
Member
 
Registered: Jun 2004
Location: Kansas City, MO
Distribution: openSUSE 10.2/64bit
Posts: 276

Rep: Reputation: 30
look to the top/right of this page, under main menu, linux wiki
 
Old 07-25-2004, 11:33 AM   #10
Nonsensical
LQ Newbie
 
Registered: Jul 2004
Posts: 2

Rep: Reputation: 0
Wow, thanks so much. Everyone had been recommending ndiswrapper but I had no idea how to get it to work until I read this guide. This was terrific! Thanks again!
 
Old 07-26-2004, 05:06 AM   #11
apple
LQ Newbie
 
Registered: Jul 2004
Posts: 1

Rep: Reputation: 0
WLAN using NDISWRAPPER

I am really new to Linux, having got pissed of with the constant virus, spyware problem of Windows.

Yesterday I installed Suse Linux 9.1, went fine, exept the WLAN.

I followed CypherXeros instructions for my Belkin / Broadcom based 54g card. Everything seems ok I get a response from ndiswrapper -l that the driver is installed.

But I can't get the card to see the network, is there something that has to be done in YaST?

Everyone seems to find this simple, so perhaps I'm missing something or maybe I just stupid, please help, anyone.
 
Old 07-26-2004, 04:24 PM   #12
ciaran.mooney
LQ Newbie
 
Registered: Mar 2004
Distribution: Slackware 9.1
Posts: 18

Rep: Reputation: 0
I am also having trouble with ndiswrapper. I am using a Belkin 6001.Ver3 (uk) PCI card, based on the Realtek8180 driver.

Ndiswrapper installs fine, so does the driver (nb I have to use the win98 driver, as winXP driver does not show "present" when using the "ndiswrapper -l" command). But as soon as I start trying to set up the WLAN settings (ESSID etc) it says that wlan0 doesn't exist.
 
Old 07-29-2004, 10:03 PM   #13
Ross316
LQ Newbie
 
Registered: Mar 2002
Distribution: RedHat 7.2
Posts: 1

Rep: Reputation: 0
better way?

I have the same problem of my wired nic getting in the way of my wireless one with the default gateway.

Followed this:
Quote:
Fixing The Problem
1. Once you have everything up and running (wlan0 and eth0 are both active), unplug the ethernet cable from your computer.
2. Open up bash (Konsole, Xterm, etc..), and type in "su root" and then the root password.
3. Now type in "ifdown eth0"
4. Next, type in "ifdown wlan0"
5. Now, type in "ifup wlan0"
6. Then, type in "ifconfig -a"
7. Finally, type in "route" to check your routing.
and it works now!!!!

Now, is there a better way to switch between wireless and wired card than this?
 
Old 08-02-2004, 11:08 PM   #14
jeffChuck
Member
 
Registered: Feb 2004
Posts: 89

Rep: Reputation: 15
It worked for me until the 'iwconfig' step. I got an error that wlan0 does not exist. What can I do about this?

I have hotplug installed, and the card says that it has power.
 
Old 08-03-2004, 07:05 PM   #15
Ghost_runner
Member
 
Registered: Jun 2004
Location: Kansas City, MO
Distribution: openSUSE 10.2/64bit
Posts: 276

Rep: Reputation: 30
try dmesg | grep "eth0" or dmesg | grep "wi0" see if your card has a different name, or maybe the more generic dmesg | grep "network" might tell you what your card is named?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DISCUSSION: Belkin F5D7000 USA Wireless Card in Linux: Complete Guide michaeljsmalley LinuxAnswers Discussion 4 05-13-2008 03:06 PM
Belkin F5D7000 Wireless Card in Linux: Complete Guide michaeljsmalley Linux - Wireless Networking 5 06-02-2006 01:50 PM
Guide: Increasing Wireless WRT54G Levels johnp Linux - Wireless Networking 2 07-28-2005 12:44 AM
Ultranoob Guide - Mandrake + Wireless willko Linux - Wireless Networking 1 04-24-2005 01:55 AM
Linux Lappy & Wireless PCMCIA - Definitive Guide Request geokker Linux - Laptop and Netbook 3 11-11-2004 02:11 PM


All times are GMT -5. The time now is 06:35 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration