LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 05-13-2012, 07:39 AM   #1
sportyaccordy
LQ Newbie
 
Registered: Dec 2011
Posts: 9

Rep: Reputation: Disabled
Wireless driver installed but no wireless device/name active (BCM4311)


lspci shows this

Code:
0c:00.0 Network controller: Broadcom Corporation BCM4311 802.11a/b/g (rev 01)
but iwconfig shows this

Code:
lo        no wireless extensions.

eth0      no wireless extensions.
How do I get a wireless device name (like wlan0 or eth1) associated with the wireless card? I've un + re installed the device like 10 times, and when I ran a demo Ubuntu install initially my wireless worked, so I know its possible. Any suggestions????

Last edited by sportyaccordy; 05-13-2012 at 07:41 AM.
 
Old 05-13-2012, 08:10 AM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046
Do you have the needed firmware installed?
 
Old 05-13-2012, 08:18 AM   #3
sportyaccordy
LQ Newbie
 
Registered: Dec 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
What other firmware would I need besides the device driver?
 
Old 05-13-2012, 08:21 AM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Main: Gentoo Others: What fits the task
Posts: 15,592
Blog Entries: 2

Rep: Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046Reputation: 4046
The driver is not a firmware, but it needs the firmware to function.
Install the package firmware-b43-installer.
 
Old 05-13-2012, 08:59 AM   #5
sportyaccordy
LQ Newbie
 
Registered: Dec 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
I installed + restarted. Still have no new network devices.
 
Old 07-17-2012, 06:51 PM   #6
sportyaccordy
LQ Newbie
 
Registered: Dec 2011
Posts: 9

Original Poster
Rep: Reputation: Disabled
I gave up and bought an Asus USB-N13. Plugged it in and it started up instantly
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
BCM4311 wireless not working on Xubuntu lppatmore Linux - Newbie 5 03-16-2012 02:30 PM
[SOLVED] Slackware wireless networking setup w/Broadcom Wireless BCM4311 NIC on HP DV9000 astanton Slackware 14 12-30-2010 07:37 PM
Wireless not working, b43 driver (BCM4311) ducksong Arch 3 11-27-2010 02:40 PM
Wireless device driver not being installed freenhigh Linux - Networking 1 04-20-2010 07:26 AM
bcm4311 wireless driver install for CentOS 5.3 ferrell Linux - Newbie 8 09-21-2009 06:47 PM


All times are GMT -5. The time now is 08:52 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration