LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 11-13-2008, 06:09 AM   #1
daganesh
LQ Newbie
 
Registered: Nov 2008
Posts: 4

Rep: Reputation: 0
Wireless device crash when wireless network is lost (ubuntu/gutsy on ThinkPad)


Dear linux people,
I am quite new here, so please be patient
I was using the wireless connection successfully for a while,
then had to move to a different location, while laptop is still on (but cover closed).
Of course the previous wireless network was lost, but also I could not reestablish a new connection (wireless device was not working at all).

I tried to set up a new manual connection and failed.
Then I could not restore the default settings (could not find a way).
even after restart it doesn't work

I am using a ThinkPad T61 with ubuntu/Gutsy:
Linux my-laptop 2.6.22-14-generic #1 SMP Sun Oct 14 23:05:12 GMT 2007 i686 GNU/Linux

thanks in advance for any clue.
Dagan


attached a few relevant outputs:
let me know what other info is needed.

> lspci
00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 0c)
00:01.0 PCI bridge: Intel Corporation Mobile PM965/GM965/GL960 PCI Express Root Port (rev 0c)
00:19.0 Ethernet controller: Intel Corporation 82566MM Gigabit Network Connection (rev 03)
00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Contoller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03)
00:1c.3 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 4 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation 82801HBM (ICH8M-E) LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation Quadro NVS 140M (rev a1)
03:00.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
15:00.0 CardBus bridge: Ricoh Co Ltd RL5c476 II (rev ba)
15:00.1 FireWire (IEEE 1394): Ricoh Co Ltd R5C832 IEEE 1394 Controller (rev 04)

> sudo iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wifi0 no wireless extensions.

ath0 IEEE 802.11a ESSID:"myhovercraftisfullofeels" Nickname:""
Mode:Managed Frequency:5.54 GHz Access Point: Not-Associated
Bit Rate:0 kb/s Tx-Power:8 dBm Sensitivity=1/1
Retryff RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality=0/70 Signal level=-98 dBm Noise level=-98 dBm
Rx invalid nwid:41958 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
 
Old 11-13-2008, 12:17 PM   #2
irishbitte
Senior Member
 
Registered: Oct 2007
Location: Brighton, UK
Distribution: Ubuntu Hardy, Ubuntu Jaunty, Eeebuntu, Debian, SME-Server
Posts: 1,213
Blog Entries: 1

Rep: Reputation: 82
Basically, my experience on this is that you will have to reboot the machine completely. Putting it into standby is not a great idea when trying to operate in a wireless environment.
 
Old 11-16-2008, 04:53 AM   #3
daganesh
LQ Newbie
 
Registered: Nov 2008
Posts: 4

Original Poster
Rep: Reputation: 0
irishbitte - thanks for the reply.
I have done that (complete reboot), a few times, but it won't resolve the problem.

What I meant is that at my first attempt I didn't want to restart the computer, just because I needed to restart the wireless device.
I am sure you could do that without rebooting.

Anyway now I cannot have wireless running at all...
 
Old 11-17-2008, 02:35 PM   #4
irishbitte
Senior Member
 
Registered: Oct 2007
Location: Brighton, UK
Distribution: Ubuntu Hardy, Ubuntu Jaunty, Eeebuntu, Debian, SME-Server
Posts: 1,213
Blog Entries: 1

Rep: Reputation: 82
hmmm. try looking in

System -> Administration -> Network -> Unlock

Now click on Wireless Connection -> Properties

Check that the box for "Enable roaming mode" is ticked. If not, tick it.

Now close out of all that, and reboot your machine.

Let us know how you get on!
 
Old 11-23-2008, 03:18 AM   #5
daganesh
LQ Newbie
 
Registered: Nov 2008
Posts: 4

Original Poster
Rep: Reputation: 0
irishbitte,
I could not follow your instructions, since my system menus are different, and I could not find the "enable roaming" option in the wireless configuration menus.

Trying to view/set any configuration manually results in (for example):
Error for wireless request "Set ESSID" (8B1B) :
GET failed on device eth0 ; Operation not supported

BTW - I am using Ubuntu 7.10 with KDE 3.5.8

thanks...
 
Old 11-23-2008, 10:34 AM   #6
irishbitte
Senior Member
 
Registered: Oct 2007
Location: Brighton, UK
Distribution: Ubuntu Hardy, Ubuntu Jaunty, Eeebuntu, Debian, SME-Server
Posts: 1,213
Blog Entries: 1

Rep: Reputation: 82
Hmm. I don't use kubuntu or KDE. But you can find your network settings under 'knetwork manager' somewhere in the menus. Anyway, I had a quick hunt around, take a look at this:

http://www.computing.net/answers/lin...fig/29824.html particularly response number 4.

Also, this may help: http://www.linuxforums.org/forum/ubu...tu-7-10-a.html

This one had good pointers: http://ubuntuforums.org/showthread.php?t=749215
 
Old 11-24-2008, 05:06 AM   #7
daganesh
LQ Newbie
 
Registered: Nov 2008
Posts: 4

Original Poster
Rep: Reputation: 0
thanks again,
I have seen around the ndiswrapper solution, BUT since my wireless connections used to work, I would first try to re-enable the existing driver and interfaces, rather than replacing them.
If all that fails, I will try to follow that solution.

thanks for the pointers, actually I thought I've posted at the ubuntu forums, but apparently m post was not there :P
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless not working Ubuntu Gutsy (7.10) JMC8501 Linux - Laptop and Netbook 38 10-30-2008 05:23 AM
Ubuntu 8.04 wireless problems on t60 thinkpad using atheros wireless adapter AR5212 NuxIT Linux - Wireless Networking 0 08-21-2008 05:54 AM
Broadcom Wireless Ubuntu Gutsy pccdrussell Linux - Wireless Networking 11 02-20-2008 01:08 AM
LXer: 3 Wireless Setups for Ubuntu Gutsy Gibbon LXer Syndicated Linux News 0 11-26-2007 08:50 AM
LXer: Ubuntu Gutsy Wireless Help LXer Syndicated Linux News 0 10-19-2007 08:10 AM


All times are GMT -5. The time now is 07:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration