LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Wireless connection must be reconfigured at each reboot (http://www.linuxquestions.org/questions/linux-wireless-networking-41/wireless-connection-must-be-reconfigured-at-each-reboot-336094/)

broggyr 06-22-2005 11:30 AM

Wireless connection must be reconfigured at each reboot
 
Installed Mandriva LE2005 on a gateway 333MHz laptop. Network card is a NetworkEverywhere NWP11B (ACX100 chipset).

Works fine with ndiswrapper & windowsXP driver. However, when I reboot, the connection does not start. When I hover over the connection status icon, says it hasn't been configured.

When I reconfigure the connection, the driver is still there and will work again after I run through the configuration.

I even have the "Start at boot" checked.

I don't know what file to edit, what edits need to be made, or even which one to look at...

Let me know what info I can post...

eroica 06-23-2005 11:40 AM

try this site:
http://www.houseofcraig.net/belkin_howto.php
i have mdk 9.1 but it probably still pertains. notice the "Automating the config" section. Once i filled in the text file @ /etc/sysconfig/network-scripts/ifcfg-eth0, where eth0 is the device name on your system & my /etc/sysconfig/network file was configured properly, i never had to use iwconfig again.

alan

broggyr 06-23-2005 12:14 PM

Thanks for the reply, I'll try it when I get home tonite :)

broggyr 06-24-2005 01:44 AM

Well, I did that but it had no effect. The only way I can start this connection is to go into the Control Panel and create a new connection with the existing driver or by running the config tool in HardDrake. I know of no other way.

/etc/sysconfig/network:
HOSTNAME=9.24.19.72
NETWORKING=yes
GATEWAY=9.24.19.72

/etc/sysconfig/network-scripts/ifcfg-wlan0:
DEVICE=wlan0
BOOTPROTO=dhcp
ONBOOT=yes
HWADDR=00:06:25:13:e9:9d
METRIC=10
MII_NOT_SUPPORTED=yes
USERCTL=yes
WIRELESS_MODE=Managed
WIRELESS_ESSID=broggnet
WIRELESS_ENC_KEY=XXXXXXXXXXXXXXXXXXXX
DHCP_CLIENT=dhclient
NEEDHOSTNAME=yes
PEERDNS=yes
PEERYP=no
PEERNTPD=no

eroica 06-24-2005 09:52 PM

one thing i know i had problem w/was the file name.it must be the same as the device name. did you issue @ the command prompt "ifconfig -a". does it list your wireless card as wlan0 or perhaps another name. like mine is recognized as atml0. i then had to create a file called ifcfg-atml0...

alan

broggyr 06-25-2005 12:04 AM

Interesting. However, as soon as I run the configuration, it shows as and connects as wlan0.

# ifconfig -a also shows the wireless as wlan0

eroica 06-25-2005 04:24 PM

what i'm also thinking is u metioned that u installed w/ndis wrapper. perhaps u need the wireless tools and extentions for autoconfig to work. can u issue an "iwconfig" command and get back the wlan0 adapter w/its options listed? if not check out this site : http://www.hpl.hp.com/personal/Jean_...TRIBUTIONS.txt note at the bottom he mentions mandrake autoconfig and the appropriate rpm u need. also can look at this site:http://www.hpl.hp.com/personal/Jean_...nux/Tools.html this is the home page for the wireless extentions tools...

alan

broggyr 06-26-2005 02:38 PM

Thanks for that, but the wireless tools are installed by default. Like I mentioned earlier, as soon as I run the Mandriva Control Center and add a New Connection it works fine until the next reboot.

eroica 06-27-2005 07:44 PM

I found this site: http://www.brunolinux.com/08+-WiFi/Ndiswrapper.html
it says to issue command "ndiswrapper -m" to have ndiswrapper load automatically @ boot. have u tried this? i think the problem is your using ndiswrapper and the conventional ways to load config info @ boot dont apply...

alan

broggyr 06-28-2005 07:37 AM

Amazing. I did the following:
Code:

# ndiswrapper -m
Adding alias wlan0 to /etc/modprobe.conf

I followed that link and edited my /etc/rc.d/rc.local file to include those lines. Now when I reboot, seems all I have to do is
Code:

# iwconfig
and the wlan0 connects (at least it did this morning!)

Thanks, I'll play around with it in more detail tonite, and see if I can get the 'iwconfig' command into the rc.local file, or find another way to init it - the ultimate goal of course is to be able to launch firefox without having to manually connect first.

Thanks again!!

eroica 06-28-2005 08:26 PM

glad to see youre making progress. i dont see why just iwconfig @ prompt is doing anything? that is just a list command? i am curious, issuing ifconfig -a right after bootup does it show wlan0 as "UP" like mine:
[root@Thinkpad xxxx]# ifconfig -a
atml0 Link encap:Ethernet HWaddr xx:xx:xx:xx:xx:xx
inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4099 errors:0 dropped:0 overruns:0 frame:0
TX packets:2463 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:256176 (250.1 Kb)
Interrupt:3 Base address:0xa00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.255.255.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:199 errors:0 dropped:0 overruns:0 frame:0
TX packets:199 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:12240 (11.9 Kb) TX bytes:12240 (11.9 Kb)
am not familiar w/ndiswrapper. does it load like a module? if so maybe u could do a modinfo ndiswrapper and see what parameters it takes and stick a line in modules.conf if what youre trying doesnt work. but according to above website i would say that once u issued ndiswrapper -m that all was taken care of....

alan


All times are GMT -5. The time now is 05:10 PM.