LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 03-03-2010, 11:55 AM   #1
andreqls
LQ Newbie
 
Registered: Apr 2007
Posts: 14

Rep: Reputation: 2
Wireless connection is poor in Linux but great on Windows


Greetings, good people.

I have a VAIO laptop (recently acquired, reference VPCCW21FX) with an Atheros AR9285 Wireless card adapter that dual-boots a pre-installed Windows 7 64-bit OS with the (by-far-preferred) Slackware 13 64-bit OS.

My problem is that the only way I can get access-point association (and thus an actual connection) in Slackware is if I'm very close to my router, which is of course not convenient at all; comparatively, Windows is able to get great reception from a fairly decent distance.

To be more precise, I am still able to scan and identify my domestic wireless network by using "iwlist wlan0 scan", and I can see that the quality is around 40/100, which for Windows means it's quite stable (I'm posting at such a spot right now).

The problematic behavior occurs when attempting to actually associate the access-point so I can get an IP address through DHCP from a greater-than-very-very-close distance; my usual procedure consists of: "iwconfig wlan0 essid [etc]" and subsequently checking the association with "iwconfig wlan0". It works perfectly if I'm right next to my router, and I get regular Internet access; however, if I distance myself a little (signal quality around 80/100) I loose the connection, and if I try to connect from such a position the status of the access-point (from "iwconfig") remains "Not-Associated".

My main point is that the Wireless card itself is fine since Windows acts normally despite all this. Also note that wicd has the exact same behaviour as my own commands: it works when very close, but dies if a little far from the router. On another note, my previous HP laptop with Slackware 13 didn't have any of these problems - leading me to wonder if it has something to do with linux driver support for the wireless card, but my searches lead to nothing (neither have I seen any account of problems similar to mine).

I think I've made the issue pretty clear... If anybody thinks they'd benefit from more information (such as the actual outputs from the commands, which I believe I explained well, but maybe not) I'll promptly try to provide it. Thanks in advance.

Last edited by andreqls; 04-29-2010 at 12:55 PM. Reason: solvedness
 
Old 03-03-2010, 08:21 PM   #2
MS3FGX
Guru
 
Registered: Jan 2004
Location: NJ, USA
Distribution: Slackware, Debian
Posts: 5,852

Rep: Reputation: 351Reputation: 351Reputation: 351Reputation: 351
To start with, take a look at what the power level is set as with iwconfig. Then see if you can find the documentation for your WiFi hardware, which should list the maximum output power in the specifications. For whatever reason, I have found that Linux WiFi drivers often don't start the hardware at maximum power, and need to be manually turned up.

Last edited by MS3FGX; 03-03-2010 at 10:38 PM.
 
Old 03-03-2010, 10:05 PM   #3
andreqls
LQ Newbie
 
Registered: Apr 2007
Posts: 14

Original Poster
Rep: Reputation: 2
Thank you for your response, MS3FGX. I've just read through iwconfig's man page again but I'm still not sure what you mean by "lower level" output power in the context of this command's configurable options... Nevertheless, here is the output for "iwconfig wlan0" (after setting the essid and key):

Quote:
wlan0 IEEE 802.11bgn ESSID:"joseqls"
Mode:Managed Frequency:2.437 GHz Access Point: Not-Associated
Tx-Power=27 dBm
Retry min limit:7 RTS thrff Fragment thr=2352 B
Encryption key:A9BE-7178-31 Security modepen
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
And, for completeness, this is what "iwlist wlan0 scan" has to say:
Quote:
Cell 03 - Address: 00:18:F8:6E:9E:9A
ESSID:"joseqls"
Mode:Master
Channel:6
Frequency:2.437 GHz (Channel 6)
Quality=62/100 Signal level:-67 dBm
Encryption keyn
IE: Unknown: 00076A6F7365716C73
IE: Unknown: 010882848B962430486C
IE: Unknown: 030106
IE: Unknown: 050400010000
IE: Unknown: 2A0104
IE: Unknown: 2F0104
IE: Unknown: 32040C121860
IE: Unknown: DD060010180201F4
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:tsf=0000003a4ca88184
Extra: Last beacon: 288ms ago
If you're referring to Tx-Power, then it does seem possible to configure it to another value... Yet, I believe I have found the complete specifications for the wireless card and they unfortunately seem to make no mention of it:

http://www.atheros.com/pt/AR9285.htm

So for now I'm at a loss as to how to proceed... I will do some more researching on this matter and if something comes up I'll test it and post my results.
 
Old 03-04-2010, 10:30 AM   #4
andreqls
LQ Newbie
 
Registered: Apr 2007
Posts: 14

Original Poster
Rep: Reputation: 2
Incidentally, I've just come across a dBm value reference table (http://en.wikipedia.org/wiki/DBm) stating that 15dBm (=32mW) is the "typical WiFi transmission power in laptops". If that's true, then my value of 27dBm (=500mW) must be a reasonable one, for it's over 15 times the "typical" value (even if that information is outdated, I still don't think I should be having this kind of problem with that high of a power setting).

Of course, I can't actually rule out the possibility that the power setting is actually below acceptable, but I believe that the current TxPower value of 27dBm is probably close to the maximum... As a matter of fact I have just attempted increasing TxPower to 30dBm and it had no effect.

So basically I'm back to zero leads (unless someone refutes my last two paragraphs)... AND I still haven't found a single account by someone experiencing a similar problem. Hopefully the answer will reveal itself somehow... At which point I'll yell "Zvarri!"

Last edited by andreqls; 03-04-2010 at 11:11 AM. Reason: minor correction-update
 
Old 03-04-2010, 09:39 PM   #5
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
What kind encryption do you use?
If WPA, can you please, post here content of the wpa_supplicant.conf WITHOUT any passwords.
Also, please connect to your wireless router, then move out your laptop until it drops the connection, and then please type in console: "dmesg | tail -n 30". Post it here as well.

Thanks
 
Old 03-04-2010, 09:56 PM   #6
damgar
Senior Member
 
Registered: Sep 2009
Location: dallas, tx
Distribution: Slackware - current multilib/gsb Arch
Posts: 1,949
Blog Entries: 8

Rep: Reputation: 201Reputation: 201Reputation: 201
This is a common problem from what I gathered when I installed linux on my laptop. While I didn't check to see whether or not it would work at all at the same distances, I found that what was a non-issue distance for the preinstalled Vi$ta was TERRIBLY slow in Mandriva or Ubuntu (I never installed slack on the laptop). I too have an atheros card. There are two things I did to fix my problem, with one working considerably better than the other:

The best solution is what I did in Mandriva: NDISwrapper. It was a breeze to setup in Mandriva and it gave me the same performance in Mandriva as I had In 'doze.

The other solution which worked for my problem, but not as well, is what I did in Ubuntu where NDISwrapper was above my user experience at the time: I manually set the rate with iwconfg to 12 Mb/s which is fine for what I use my wireless for. I found that if I set it too high it simply failed to work at all at a "non-issue-windows-distance" and if I let it decide for itself what the rate should be, it would go down to 1 Mb/s even though setting it manually to 12 works just fine in the same spot.
 
Old 03-05-2010, 01:15 AM   #7
andreqls
LQ Newbie
 
Registered: Apr 2007
Posts: 14

Original Poster
Rep: Reputation: 2
@damgar: Alright, looks promising! I'll go with the NDISwrapper but since it sounds like a little more time-demanding I'll do some research on how to set it up for Slackware and get back to you with the results. Whatever the outcome is, thanks in advance xD

@nimnull22: WEP encryption. Once again, I find it hard for the issue to be related to that kind of thing since when close to the router everything works flawlessly; it even auto-connects when I log on at close range, before I enter any commands (I'm assuming from wicd, which is also active - and exhibits the same behaviour). To clarify, I log on to runlevel 3 (console, not graphic). About the commands, I'll run them, save the output and follow-up with a post containing them because the only access I have at the moment is said laptop xP I'll post what you requested first then wait while I look into damgar's suggestion. Thanks for the help and interest as well!
 
Old 03-05-2010, 01:47 AM   #8
andreqls
LQ Newbie
 
Registered: Apr 2007
Posts: 14

Original Poster
Rep: Reputation: 2
More @nimnull22: Just to be safe, what I did was run your command and monitor the connection when logging close, then I monitored the connection while moving by ping'ing google.com until it became unresponsive (yes, it did not say it failed to transmit packets but simply became unresponsive - even after killing it and trying again, ping simply was no more), then when I had no connection I ran the command again. These two times (1 when connected and 1 after loosing connection) resulted in the very same output:

Quote:
hda_intel: azx_get_response timeout, switching to polling mode: last cmd=0x01ef000c
Adding 4000144k swap on /dev/sda6. Priority:-1 extents:1 across:4000144k
fuse init (API version 7.11)
EXT4 FS on sda7, internal journal on sda7:8
ppdev: user-space parallel port driver
lp: driver loaded but no devices found
sky2 eth0: enabling interface
NET: Registered protocol family 10
lo: Disabled Privacy Extensions
ADDRCONF(NETDEV_UP): eth0: link is not ready
ADDRCONF(NETDEV_UP): wlan0: link is not ready
sky2 eth0: disabling interface
sky2 eth0: enabling interface
ADDRCONF(NETDEV_UP): eth0: link is not ready
ADDRCONF(NETDEV_UP): wlan0: link is not ready
wlan0: authenticate with AP 00:18:f8:6e:9e:9a
wlan0: authenticate with AP 00:18:f8:6e:9e:9a
wlan0: authenticated
wlan0: associate with AP 00:18:f8:6e:9e:9a
wlan0: RX AssocResp from 00:18:f8:6e:9e:9a (capab=0x411 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present
wlan0: direct probe to AP 00:18:f8:6e:9e:9a try 1
wlan0 direct probe responded
wlan0: authenticate with AP 00:18:f8:6e:9e:9a
wlan0: authenticated
wlan0: associate with AP 00:18:f8:6e:9e:9a
wlan0: RX ReassocResp from 00:18:f8:6e:9e:9a (capab=0x411 status=0 aid=1)
wlan0: associated
One thing I noted was that the access point got associated to wlan0 when close to the router and remained associated after loosing the connection... Not that it's any good sign as far as I understand. After that, I rebooted the computer and ran your command after trying to connect from afar, and here's the output:

Quote:
wlan0: direct probe to AP 00:18:f8:6e:9e:9a try 2
wlan0: direct probe to AP 00:18:f8:6e:9e:9a try 3
wlan0: direct probe to AP 00:18:f8:6e:9e:9a timed out
wlan0: direct probe to AP 00:18:f8:6e:9e:9a try 1
wlan0: direct probe to AP 00:18:f8:6e:9e:9a try 1
wlan0: direct probe to AP 00:18:f8:6e:9e:9a try 2
wlan0: direct probe to AP 00:18:f8:6e:9e:9a try 3
wlan0: direct probe to AP 00:18:f8:6e:9e:9a timed out
wlan0: authenticate with AP 00:18:f8:6e:9e:9a
wlan0: authenticate with AP 00:18:f8:6e:9e:9a
wlan0: authenticated
wlan0: associate with AP 00:18:f8:6e:9e:9a
wlan0: associate with AP 00:18:f8:6e:9e:9a
wlan0: associate with AP 00:18:f8:6e:9e:9a
wlan0: association with AP 00:18:f8:6e:9e:9a timed out
wlan0: direct probe to AP 00:18:f8:6e:9e:9a try 1
wlan0: direct probe to AP 00:18:f8:6e:9e:9a try 1
wlan0: direct probe to AP 00:18:f8:6e:9e:9a try 2
wlan0: direct probe to AP 00:18:f8:6e:9e:9a try 3
wlan0: direct probe to AP 00:18:f8:6e:9e:9a timed out
wlan0: authenticate with AP 00:18:f8:6e:9e:9a
wlan0: authenticate with AP 00:18:f8:6e:9e:9a
wlan0: authenticate with AP 00:18:f8:6e:9e:9a
wlan0: authenticate with AP 00:18:f8:6e:9e:9a
wlan0: authenticated
wlan0: associate with AP 00:18:f8:6e:9e:9a
wlan0: RX AssocResp from 00:18:f8:6e:9e:9a (capab=0x411 status=0 aid=1)
wlan0: associated
ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
wlan0: no IPv6 routers present
And when trying to log from afar, ping just replied "unknown host", but managed to terminate accordingly without becoming unresponsive.

For now that's all the information I think I can provide... I'll start looking into that NDISwrapper right away. Cheers.

Last edited by andreqls; 03-16-2010 at 05:43 PM.
 
Old 03-05-2010, 12:27 PM   #9
andreqls
LQ Newbie
 
Registered: Apr 2007
Posts: 14

Original Poster
Rep: Reputation: 2
Yeah... NDISwrapper did nothing for me... I located some XP drivers for the AR9285 but they did not improve anything. In fact, I tried two different versions (64 and 32-bit): the first one made no difference and the second one caused my device to stop being recognized. In the end I had to reinstall Slackware from scratch. Not that troublesome, but I'm now back to having no idea what to try.

More information (that I forgot to mention before): If I try to run "dhcpcd wlan0" it says that dhcpcd is already running on some mysterious pid number that I can't see with ps or kill. That's all for now.
 
Old 04-15-2010, 12:11 AM   #10
rsisto
LQ Newbie
 
Registered: Apr 2010
Posts: 3

Rep: Reputation: 0
Dear andreqls, I was having the same issue with my new laptop. I just tried this http://ubuntuforums.org/showthread.php?p=9096752 and it seems to be working better...

Let me know if it works for you. Greetings!
 
1 members found this post helpful.
Old 04-16-2010, 02:37 AM   #11
andreqls
LQ Newbie
 
Registered: Apr 2007
Posts: 14

Original Poster
Rep: Reputation: 2
@rsisto: It works! Thank you very much. This is just what I wanted. I'd already given up, but now I'm excited: this was the one last thing keeping me from using my beloved Slackware for real. Indeed, I was planning on waiting until the next release of some things (e.g. NVIDIA driver support for GeForce310M) to get a kernel upgrade (because I need it to replace the sadly-not-still-quite-usable "noveau" driver)... I was gonna miss out on using Slack until then if it hadn't been for you. I am truly grateful.

Also thanks to all the other remarkable individuals who put altruistic effort into helping me. May we be able to help many more men and women of worth.
 
Old 04-19-2010, 03:46 PM   #12
rsisto
LQ Newbie
 
Registered: Apr 2010
Posts: 3

Rep: Reputation: 0
@andreqls: How is the driver working for you? I actually tried it and thought it was working better, but actually my downloads are always intermittent... Did you try downloading big files to see how the connection works?
The signal of my connection is always great, but the downloads don't work as well as if I were using LAN cable...

Greetings and thanks in advance!
 
Old 04-21-2010, 01:50 AM   #13
andreqls
LQ Newbie
 
Registered: Apr 2007
Posts: 14

Original Poster
Rep: Reputation: 2
@rsisto: Actually I haven't downloaded anything particularly large yet, but so far it seems to be working (at least for the slackbuilds I've tried). In fact, if I have a complaint it would be about the actual browsing: it seems that with some frequency pages stop loading spontaneously and I have to refresh them, and then they work just fine.
Perhaps I'll try to download OpenOffice or some other big files to verify what you've reported. You may wait for a reply some time soon. Until then, best of fortunes.
 
Old 04-29-2010, 12:53 PM   #14
andreqls
LQ Newbie
 
Registered: Apr 2007
Posts: 14

Original Poster
Rep: Reputation: 2
Ahmm... it seems the situation has changed quite a bit.
I swear I could download everything when I installed the updated drivers, and the only problem was during browsing sometimes.
Now... If I try to download anything above 1MB, the download speed apparently starts "right" (around 60kB/s, at least that's what Chrome says) then quickly drops to less than 1kB/s -_- for a 2.8MB file I have ETA = 11 minutes and climbing =(
On the other hand, browsing seems mighty fine now... go figure. I guess this isn't the definitive solution.
Best regards to all.
 
Old 05-28-2010, 02:52 PM   #15
andreqls
LQ Newbie
 
Registered: Apr 2007
Posts: 14

Original Poster
Rep: Reputation: 2
Well, I have some good news.
I had been resisting a kernel upgrade due to some recent unpleasant experiences with the matter, but Slackware 13.1 just came out, sporting the 2.6.33.4 Linux kernel. So I began using it.
Without any extra effort, my wireless connection is now much, much better: web pages load properly and download speed is stable. But it's still not optimal: the "maximum" stable download speed is about one third of what the speed I get using Windows.
Still, I consider this to be a remarkable improvement. ^^
Alright, just wanted to share... Best of fortunes, everyone.
 
  


Reply

Tags
ar9285, atheros, signal, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] DSL connection slow on Linux wired connection but fast on Windows wireless Pandarsson Linux - Wireless Networking 9 12-17-2010 06:55 PM
Linux is great, Windows is great but can you live without a computer? Mr-Bisquit General 49 03-08-2010 07:26 PM
Linux Connect to internet via Windows XP wireless connection khskinsfan Linux - General 6 09-02-2009 10:45 PM
Why can't I get a wireless connection after installing Linux on my Windows XP laptop HillaAraujo Linux - Newbie 6 08-29-2008 09:37 AM
Linux through a Wireless Windows Connection C-bro Linux - Wireless Networking 11 08-04-2006 07:51 AM


All times are GMT -5. The time now is 09:45 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration