LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   wireless configuration fedora 3 intel pro 2200 (http://www.linuxquestions.org/questions/linux-wireless-networking-41/wireless-configuration-fedora-3-intel-pro-2200-a-259298/)

vkerry 11-25-2004 05:41 PM

wireless configuration fedora 3 intel pro 2200
 
i am total noob here so please bear with me .. i have dell inspiron 700m laptop with Intel Pro 2200 B/G card in it and I just installed FEDORA Core 3. I went thru the source forge and installed the driver as well as the firmware .. i have a Dlink G router at home and my ISP is comcast. I am not able obtain an IP address either able to ping . i did the following.
and when i do a ifup eth1 or ipw2200 i get the following error ...

# modprobe eth1
# ifup eth1

Determining IP information for eth1... failed; no link present. Check cable?

I went thru almost all the questions here in the forum .. they didn;t help me much .. please let me know if somebody out there needs more info to help me out. Thank you.

my ifcf-eth1 looks like this

DEVICE=eth1
ONBOOT=yes
BOOTPROTO=dhcp
TYPE=wireless
DHCP_Hostname=SETI

# iwconfig

lo no wireless extensions.

eth0 no wireless extensions.

eth1 unassociated ESSID:"SETI"
Mode:Managed Channel=0 Access Point: 00:00:00:00:00:00
Bit Rate=0kb/s Tx-Power=20 dBm
RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:221 Missed beacon:0

sit0 no wireless extensions.

# ifconfig -a
eth0 Link encap:Ethernet HWaddr
inet addr:192.168.0.100 Bcast:192.168.0.255 Mask:255.255.255.0
inet6 addr: Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:7042 errors:0 dropped:0 overruns:0 frame:0
TX packets:3556 errors:0 dropped:0 overruns:0 carrier:5
collisions:0 txqueuelen:1000
RX bytes:5933959 (5.6 MiB) TX bytes:450898 (440.3 KiB)
Interrupt:10

eth1 Link encap:Ethernet HWaddr
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:2 errors:0 dropped:221 overruns:0 frame:0
TX packets:8 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:140 (140.0 b) TX bytes:568 (568.0 b)
Interrupt:10 Base address:0xc000 Memory:e0206000-e0206fff

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:1894 errors:0 dropped:0 overruns:0 frame:0
TX packets:1894 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3141918 (2.9 MiB) TX bytes:3141918 (2.9 MiB)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

snecklifter 11-25-2004 06:18 PM

You must first associate your 2200 with your AP so set the ssid first with:
Code:

iwconfig eth1 essid <your ssid here>
and this will associate it. If you have WEP enabled you must also set the key.
Now you can try
Code:

ifconfig eth1 up
or the variation of that instruction you have been using. An IP address can be obtained using
Code:

dhclient eth1
as well.
Hope this helps
Chris

vkerry 11-26-2004 09:09 AM

Thanks Chris, I tried doing what you said ... and it worked when i had the wired network port (eth0) also connected to my router at the same time to the router. After I removed it and restarted everything .. and repeated the steps .. i got the following messages .. If u see my previous post, both eth1 and eth0 share the same interrupt, is this okie ? If i need to change the interrupts how do i do that .. thanks ..

# modprobe ipw2200
# iwconfig eth1 essid "SETI"
# ifconfig eth1 up
# dhclient eth1
Internet Systems Consortium DHCP Client V3.0.1
Copyright 2004 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/products/DHCP

sit0: unknown hardware address type 776
sit0: unknown hardware address type 776
Listening on LPF/eth1/00:0e:35:73:7b:83
Sending on LPF/eth1/00:0e:35:73:7b:83
Sending on Socket/fallback
DHCPREQUEST on eth1 to 255.255.255.255 port 67
DHCPREQUEST on eth1 to 255.255.255.255 port 67
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 4
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 8
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 15
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 20
No DHCPOFFERS received.
Trying recorded lease 192.168.0.102
PING 192.168.0.1 (192.168.0.1) 56(84) bytes of data.

--- 192.168.0.1 ping statistics ---
4 packets transmitted, 0 received, +3 errors, 100% packet loss, time 2998ms
, pipe 4
No working leases in persistent database - sleeping.
# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 unassociated ESSID:"SETI"
Mode:Managed Channel=0 Access Point: 00:00:00:00:00:00
Bit Rate=0kb/s Tx-Power=20 dBm
RTS thr:off Fragment thr:off
Encryption key:off
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:141 Missed beacon:0

sit0 no wireless extensions.

snecklifter 11-26-2004 10:59 AM

I didnt realise you had a wired connection as well. Unless you need this I would disable it in the BIOS to simplify things. Otherwise they should be fine sharing the same interrupt.
I think what you have wrong here is the ssid. Are the quotes actually there when you typed it? If so try it again but without the quotes and make sure its in the correct case. Also, check your router to make sure its not hiding or encrypting anything. Keep it simple to begin with and then introduce security measures afterwards.
Basically the problem is that it isnt associating with your router/AP. It cant find it. Work along this route and you should come up trumps very soon.
Regards
Chris

vkerry 11-26-2004 11:57 AM

Thanks again Chris, well .. i don't have any encryption set for my router the only filter i have is the MAC filter and that works with Windows XP. I will check with the quotes in my ssid when i go home, if u please see my first post my dhcp_hostname parameter is set to my ssid SETI without the quotes and when i do the iwconfig without doing anything it shows up as "SETI" , and then later on it goes and connects to my neighbor's router .. and stays hooked up to it.

I will go ahead and try it out and will update with the results. Thanks

I did what you said .. seems like it is working now .. thanks for all the help.


All times are GMT -5. The time now is 06:10 AM.