LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 08-31-2004, 08:21 PM   #1
fizgigtiznalkie
LQ Newbie
 
Registered: Aug 2004
Posts: 20

Rep: Reputation: 0
Wireless card working, but can't access internet


I have my wireless card up and running, and I can get to the router's web interface with the other wired nic unplugged and I can ping it, and the router assigns it an IP, but i cannot get out to the internet

the errors are mostly DNS errors, cannot find host, and the DHCP gives it an IP but no nameserver info, I added those manually by IP, but still have the problem, here is my ifconfig, the wireless card is eth1, wep is disabled for now until i can get this up and working and then i'll try to set that up again

linux:/home/ryan # ifconfig
eth0 Link encap:Ethernet HWaddr 00:04:76:49:B4:66
inet addr:192.168.1.104 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::204:76ff:fe49:b466/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:114603 errors:0 dropped:0 overruns:0 frame:0
TX packets:91949 errors:0 dropped:0 overruns:0 carrier:62
collisions:0 txqueuelen:1000
RX bytes:164970012 (157.3 Mb) TX bytes:6689228 (6.3 Mb)
Interrupt:10 Base address:0xe800

eth1 Link encap:Ethernet HWaddr 00:06:25:51:B36
inet addr:192.168.1.102 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::206:25ff:fe51:b3d6/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:2613 errors:0 dropped:0 overruns:0 frame:0
TX packets:532 errors:14 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1010046 (986.3 Kb) TX bytes:87239 (85.1 Kb)
Interrupt:3 Base address:0x100

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:169 errors:0 dropped:0 overruns:0 frame:0
TX packets:169 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:12177 (11.8 Kb) TX bytes:12177 (11.8 Kb)

linux:/home/ryan # lspci -n
0000:00:00.0 Class 0600: 8086:1130 (rev 04)
0000:00:01.0 Class 0604: 8086:1131 (rev 04)
0000:00:1e.0 Class 0604: 8086:2448 (rev 03)
0000:00:1f.0 Class 0601: 8086:244c (rev 03)
0000:00:1f.1 Class 0101: 8086:244a (rev 03)
0000:00:1f.2 Class 0c03: 8086:2442 (rev 03)
0000:01:00.0 Class 0300: 10de:0112 (rev b2)
0000:02:03.0 Class 0401: 125d:1998 (rev 10)
0000:02:06.0 Class 0200: 10b7:6055 (rev 10)
0000:02:06.1 Class 0780: 10b7:1007 (rev 10)
0000:02:0f.0 Class 0607: 104c:ac42
0000:02:0f.1 Class 0607: 104c:ac42
0000:02:0f.2 Class 0c00: 104c:8027

linux:/home/ryan # iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

eth1 IEEE 802.11-DS ESSID:"linksys" Nickname:"linux"
Mode:Managed Frequency:2.437GHz Access Point: 00:04:5A8:3B5
Bit Rate:11Mb/s Tx-Power=15 dBm Sensitivity:1/3
Retry min limit:8 RTS thrff Fragment thrff
Encryption keyff
Power Managementff
Link Quality:81/92 Signal level:-21 dBm Noise level:-149 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

sit0 no wireless extensions.


Last edited by fizgigtiznalkie; 08-31-2004 at 08:44 PM.
 
Old 08-31-2004, 08:44 PM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,782
Blog Entries: 1

Rep: Reputation: 413Reputation: 413Reputation: 413Reputation: 413Reputation: 413
Are you running eth0 and eth1 at the same time? That may be causing some problems. You can take down eth0 with ifconfig eth0 down and see if that improves the situation or next time boot without connecting the cat5 cable.

Quote:
but no nameserver info, I added those manually by IP
I'm assuming that means that you added your ISPs DNS servers to your /etc/resolv.conf file, but if that isn't true, then you need to do that.
 
Old 08-31-2004, 08:47 PM   #3
fizgigtiznalkie
LQ Newbie
 
Registered: Aug 2004
Posts: 20

Original Poster
Rep: Reputation: 0
I used the Yast wizard, but here is the content of that file:

### BEGIN INFO
#
# Modified_by: dhcpcd
# Backup: /etc/resolv.conf.saved.by.dhcpcd
# Process: dhcpcd
# Process_id: 7817
# Script: /sbin/modify_resolvconf
# Saveto:
# Info: This is a temporary resolv.conf created by service dhcpcd.
# The previous file has been saved and will be restored later.
#
# If you don't like your resolv.conf to be changed, you
# can set MODIFY_{RESOLV,NAMED}_CONF_DYNAMICALLY=no. This
# variables are placed in /etc/sysconfig/network/config.
#
# You can also configure service dhcpcd not to modify it.
#
# If you don't like dhcpcd to change your nameserver
# settings
# then either set DHCLIENT_MODIFY_RESOLV_CONF=no
# in /etc/sysconfig/network/dhcp, or
# set MODIFY_RESOLV_CONF_DYNAMICALLY=no in
# /etc/sysconfig/network/config or (manually) use dhcpcd
# with -R. If you only want to keep your searchlist, set
# DHCLIENT_KEEP_SEARCHLIST=yes in /etc/sysconfig/network/dhcp or
# (manually) use the -K option.
#
### END INFO
search h @h @
nameserver 206.141.193.55
nameserver 66.73.20.40

i will try rebooting with it unplugged again, i tried taking it down and that didn't solve the issue, and as i said the router's web interface came up, so it can use the card to connect
 
Old 08-31-2004, 09:14 PM   #4
fizgigtiznalkie
LQ Newbie
 
Registered: Aug 2004
Posts: 20

Original Poster
Rep: Reputation: 0
rebooting with the other card unplugged did not work

another oddity, i can access servers by IP on my LAN, but not external IPs or external domain names with the wireless card only, it's like it loses the gateway but can hit the access point
 
Old 08-31-2004, 09:18 PM   #5
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,782
Blog Entries: 1

Rep: Reputation: 413Reputation: 413Reputation: 413Reputation: 413Reputation: 413
Quote:
search h @h @
That line looks odd to me. You might try commenting it out (add a # and then save the file) and see if that helps.
 
Old 08-31-2004, 10:02 PM   #6
fizgigtiznalkie
LQ Newbie
 
Registered: Aug 2004
Posts: 20

Original Poster
Rep: Reputation: 0
i went to take that out, and this was the file contents:

### BEGIN INFO
#
# Modified_by: dhcpcd
# Backup: /etc/resolv.conf.saved.by.dhcpcd
# Process: dhcpcd
# Process_id: 4890
# Script: /sbin/modify_resolvconf
# Saveto:
# Info: This is a temporary resolv.conf created by service dhcpcd.
# The previous file has been saved and will be restored later.
#
# If you don't like your resolv.conf to be changed, you
# can set MODIFY_{RESOLV,NAMED}_CONF_DYNAMICALLY=no. This
# variables are placed in /etc/sysconfig/network/config.
#
# You can also configure service dhcpcd not to modify it.
#
# If you don't like dhcpcd to change your nameserver
# settings
# then either set DHCLIENT_MODIFY_RESOLV_CONF=no
# in /etc/sysconfig/network/dhcp, or
# set MODIFY_RESOLV_CONF_DYNAMICALLY=no in
# /etc/sysconfig/network/config or (manually) use dhcpcd
# with -R. If you only want to keep your searchlist, set
# DHCLIENT_KEEP_SEARCHLIST=yes in /etc/sysconfig/network/dhcp or
# (manually) use the -K option.
#
### END INFO
domain site
nameserver 206.141.193.55
nameserver 66.73.20.40
 
Old 09-01-2004, 06:52 AM   #7
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,782
Blog Entries: 1

Rep: Reputation: 413Reputation: 413Reputation: 413Reputation: 413Reputation: 413
Quote:
another oddity, i can access servers by IP on my LAN, but not external IPs or external domain names with the wireless card only, it's like it loses the gateway but can hit the access point
What is the output of route -n? Specifically, is the gateway set to your router IP address?
 
Old 09-01-2004, 07:26 AM   #8
PB0711
Member
 
Registered: Aug 2004
Location: London, UK
Distribution: Ubuntu 10.10, ubuntu 11.04, suse 9.2, OSX
Posts: 259

Rep: Reputation: 30
Probably won't do anything, but just try your firewall. Check that it isn't preventing the internet from getting in. Also i had forgotten this when I was setting up my network last month, proxy! Check to see if those settings are right.
You said that you know that your wireless is up and working, are you using anything to see the signal strength? I would recommend kwirelessmonitor.
Well those are my thoughts, i hope that they help you.
 
Old 09-01-2004, 09:22 AM   #9
fizgigtiznalkie
LQ Newbie
 
Registered: Aug 2004
Posts: 20

Original Poster
Rep: Reputation: 0
i've installed kwirelessmonitor and it shows good signal stregth but 0% link

that routing table shows eth0 as the interface to use for the gateway, is there a way to change that?

Last edited by fizgigtiznalkie; 09-01-2004 at 09:31 AM.
 
Old 09-01-2004, 05:25 PM   #10
fizgigtiznalkie
LQ Newbie
 
Registered: Aug 2004
Posts: 20

Original Poster
Rep: Reputation: 0
I got it working! Thanks for the help, the missing link was

linux:/opt/kde3/bin # route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
linux:/opt/kde3/bin # route add default gw 192.168.1.1 dev eth1
linux:/opt/kde3/bin # route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth1

Seems slower than in Windows though, although signal strength and link are high and noise is low and it's 11mbps

Last edited by fizgigtiznalkie; 09-01-2004 at 05:26 PM.
 
Old 09-05-2004, 09:09 AM   #11
fizgigtiznalkie
LQ Newbie
 
Registered: Aug 2004
Posts: 20

Original Poster
Rep: Reputation: 0
I am finding I have to type
route add default gw 192.168.1.1 dev eth1
at the command line as root every time I reboot. I have tried configuring the /etc/sysconfig/network/routes file from many examples online, and configuring the routing in YaST following the output of route -n exactly, but nothing has worked but "route add default gw 192.168.1.1 dev eth1"

any ideas?

Last edited by fizgigtiznalkie; 09-05-2004 at 11:03 AM.
 
Old 09-09-2004, 03:50 AM   #12
linuxtommy
LQ Newbie
 
Registered: Apr 2004
Posts: 9

Rep: Reputation: 0
I've had that problem my self. Every time I restart my wireless config dissapears. I solved it by writing a script with the commands I needed to get it up and running.
I.e:

#!/bin/bash
route add default gw 192.168.1.1 dev eth1

You can save this to your /usr/bin and run it manually. I used this solution because I move my laptop between to locations which requires different setups.
If you want this to be run automatically when you start up, it should work if you save your script to /etc/init.d/
 
Old 09-09-2004, 08:09 AM   #13
fizgigtiznalkie
LQ Newbie
 
Registered: Aug 2004
Posts: 20

Original Poster
Rep: Reputation: 0
I think it automatically reconfigures the network settings/gateway every time I boot and it sees eth0 is disconnected or tries to use eth0 to hit the gateway
 
Old 09-10-2004, 04:17 AM   #14
linuxtommy
LQ Newbie
 
Registered: Apr 2004
Posts: 9

Rep: Reputation: 0
The init.d directory contains commands that are run everytime you boot, so if you put a script in there should load your configuration on boot. Yoou may want to remove any other script trying to configure your network.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless Internet Card not Working ask_save Linux - Wireless Networking 5 12-25-2005 01:27 AM
Steps I need to take to get my laptop internet access via a wireless card? {-_-} Suse/Novell 2 11-18-2004 06:01 PM
Which is the best Wireless Access Point and Wireless Card? hamish Linux - Wireless Networking 13 05-04-2004 10:26 AM
Suse 9.0 wireless network card,cannot access internet masaood Linux - Wireless Networking 7 12-04-2003 08:51 PM
Wireless Lan card cant access internet bitablespore Linux - Wireless Networking 3 11-17-2003 06:38 PM


All times are GMT -5. The time now is 08:31 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration