LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 03-19-2006, 08:10 PM   #1
Cryptoniks
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Rep: Reputation: 0
Wireless card on startup configure help (slackware 10.2+ndiswrapper 1.10)


Hello All Cryptoniks here new user to linux (3 days now) and i normally was on the justlinux.com forums

Thus Far I am Loving Linux!

Some basic information you might need (that i know of thus far)

My setup is

Slackware 10.2 (full install)
Current Kernel Version 2.4.31

For the subject of this my first post here:

Ndiswrapper 1.10 successfully built and installed
Wireless card Broadcom 8011.2g Network Adapter with a lspci listing of : 14e4-4320 (rev 03) there for dictateing the use of the BCMWL5A.INF from the drivers listed in the wiki instalation notes for Ndiswrapper.

The Card was installed with 0 Errors and 0 warnings
The Card was configured manually with 0 Errors and 0 Warnings

iwconfig reports the following:

IEEE 802.11g ESSID:"myAPname here" Nickname:"myhostnamehere"
Mode:Managed Frequency:2.452 GHz Access Point: xx:xx:xx:xx:xx:xx
Bit Rate=54 Mb/s Tx-Power:15 dBm
RTS thr=ifyouneedthis B Fragment thr=ifyouneedthis B
Encryption key:mywep-key-here Security mode: open
Power Management: off
Link Quality:100/100 Signal level:-45 dBm Noise level:-256 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

basically everything is golden as far as basic config and operation

but everytime i reboot into linux i have to iwconfig my key then iwconfig my ESSID then i have to do a dhcpcd wlan0

What i am trying to do is get this setup to all be done at bootup with in the real of the startup scripts provided within slackware

i tried a couple of things i managed to google to noavail

one person said i should just write my own script to run all these commands for me but i know that the already exsisting scripts and or files (that i may not be aware of) can do this.

It seems like a bunk way of doing things if the system is already capable of doing it...in otherwords i know its not a system error but user error.

and as such making my own script just because i dont yet understand how to do it in the system seems to me like it would be giving up on understanding the systems capabilitys which are already in place.

That being said i have a few questions i am extremly new to this OS so do bear with me please

so far i have identified three files that are associated with the configuration of network information in slackware

1. /etc/rc.d/rc.wireless.conf
2. /etc/rc.d/rc.inet1
3. /etc/rc/d/rc.inet2

also though from what i understand /etc/rc.d/rc.local may be involved aswell but it is not strictly a network related file

/etc/rc.d/rc.inet1 and 2 have be restored to their original state because the many things i tried resulted in errors such as

:wlan0-start command not found
when i tryed to call rc.wireless from within rc.local it informed me that rc.wireless can only be ran from within rc.inet1

so my guess is the issue is simply putting in the proper setting in their proper syntax within rc.wireless and/or rc.inet1

ive already searched this forum and found some like issues being addressed but admittly it served only to confuse me more.

once again i am a true (<-- had to use it hehe)

That being said I thank each and everyone of you in advance for your input in helping me learn about and resolve this issue.

Yours
Cryptoniks
 
Old 03-19-2006, 08:16 PM   #2
DrEwMoNeY
Member
 
Registered: Jan 2006
Location: Vulcan
Distribution: *buntu - Slackware - Anything on USB
Posts: 254

Rep: Reputation: 30
According to ndiswrapper wiki:

Running at Startup:
Create module alias: Once everything works fine you can write the correct modprobe settings to load ndiswrapper automatically when wlan0 interface is used, by running

ndiswrapper -m

Note that this doesn't automatically load ndiswrapper module at boot time. If you want the module to be loaded automatically at boot time, you should configure your module setup, which depends on the distrbution. Most distributions will load all modules listed in /etc/modules at boot time. Mandrake 10.x uses /etc/modprobe.preload. For them, you can add a line

ndiswrapper

in /etc/modules.

If you had the ignoring unknown interface wlan0=wlan0 error earlier you will need to edit your /etc/network/interfaces file and change all occurences of eth0 to wlan0

http://ndiswrapper.sourceforge.net/m...p/Installation
 
Old 03-19-2006, 08:37 PM   #3
Cryptoniks
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Original Poster
Rep: Reputation: 0
beenthere done that
after the initial ndiswrapper -m it will report that alias ndiswrapper already exsists in modprobe.conf

i have no problems following instructions and once again im not getting errors and if that resolved my issue...well i wouldnt be asking about it here.

i need more indepth help trouble shooting this

not copy and paste from a doc ive already read over umtenth times =)

once again i have already determined that its simply putting the setting in the proper rc script can you give input to that?

Last edited by Cryptoniks; 03-19-2006 at 08:39 PM.
 
Old 03-19-2006, 08:57 PM   #4
DrEwMoNeY
Member
 
Registered: Jan 2006
Location: Vulcan
Distribution: *buntu - Slackware - Anything on USB
Posts: 254

Rep: Reputation: 30
From the Slackware Manual:

The vast majority of this work is done by iwconfig, so as always read the man page for iwconfig if you need more information.

Once you've gathered the above information, and assuming you've used modprobe to load the appropriate kernel driver, you can edit rc.wireless.conf and add your settings. The rc.wireless.conf file is a bit untidy. The least effort is to modify the generic section with your ESSID and KEY, and CHANNEL if required by your card. (Try not setting CHANNEL, and if it works, great; if not, set the CHANNEL as appropriate.) If you're daring, you can modify the file so that only the necessary variables are set. The variable names in rc.wireless.conf correspond to the iwconfig parameters, and are read by rc.wireless and used in the appropriate iwconfig commands.

http://www.slackbook.org/
 
Old 03-19-2006, 09:23 PM   #5
Cryptoniks
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Original Poster
Rep: Reputation: 0
okie your not understaing the question at hand or i am not presenting it properly

/etc/rc.d/rc.wireless.conf has been edited to reflect my current wlans needed settings or so i think


this is the generic rc.wireless.conf installed by slackware as shown here with my setting in the first part:

VERBOSE=1

case "$HWADDR" in

## NOTE : Comment out the following five lines to activate the samples below ...
## --------- START SECTION TO REMOVE -----------
## Pick up any Access Point, should work on most 802.11 cards
*)
INFO="NameofMYAP"
ESSID="MYAPNAME"
MODE="Managed"
KEY="mykeyhere"
CHANN="9"
;;
## ---------- END SECTION TO REMOVE ------------


# Here are a few examples with a few Wireless LANs supported...
# The matching is done on the first 3 bytes of the MAC address

# SMC2835W EZ Connect g 2.4GHz 54 Mbps Wireless Cardbus Adapter
00:04:E2:*)
INFO="SMC2835W EZ Connect g 2.4GHz 54 Mbps Wireless Cardbus Adapter"
# ESSID (extended network name) : My Network, any
ESSID="any"
# NWID/Domain (cell identifier) : 89AB, 100, off
NWID=""
# Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
MODE="Managed"
# Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
FREQ=""
CHANNEL="7"
# Sensitivity (cell size + roaming speed) : 1, 2, 3 ; -70 (dBm)
SENS=""
# Bit rate : auto, 1M, 11M,54M
RATE="auto"
# Encryption key : 4567-89AB-CD, sassword
# Example for 40-bit encryption:
#KEY="883e-aa67-21 [1] key 5501-d0da-87 [2] key 91f5-3368-6b [3] key 2d73-31b7-96 [4]
"
# Example for 104-bit encryption (aka 128-bit WEP):
#KEY="d5ad2f05abd048ecf10b1c80c7"
KEY=""
# RTS threshold : off, 500
RTS=""
# Fragmentation threshold : off, 1000
FRAG=""
# Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
IWCONFIG=""
# iwspy parameters : + 01:23:45:67:89:AB
IWSPY=""
# iwpriv parameters : set_port 2, set_histo 50 60
IWPRIV=""
;;

# Multiband Atheros based 802.11a/b/g universal NIC cards
00:05:4E:*)
INFO="Multiband Atheros based 802.11a/b/g universal NIC"
# ESSID (extended network name) : My Network, any
ESSID=""
# Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
MODE="Managed"
# Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
FREQ=""
CHANNEL="7"
# Bit rate : auto, 1M, 11M,54M
RATE="auto"
# Encryption key : 4567-89AB-CD, sassword
# Example for 40-bit encryption:
#KEY="883e-aa67-21 [1] key 5501-d0da-87 [2] key 91f5-3368-6b [3] key 2d73-31b7-96 [4]
"
# Example for 104-bit encryption (aka 128-bit WEP):
#KEY="d5ad2f05abd048ecf10b1c80c7"
KEY=""
# Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
IWCONFIG=""
# iwspy parameters : + 01:23:45:67:89:AB
IWSPY=""
# iwpriv parameters : set_port 2, set_histo 50 60
IWPRIV=""
;;

# Lucent Wavelan IEEE (+ Orinoco, RoamAbout and ELSA)
# Note : wvlan_cs driver only, and version 1.0.4+ for encryption support
00:60:1D:*|00:02:2D:*)
INFO="Wavelan IEEE example (Lucent default settings)"
ESSID="Wavelan Network"
MODE="Managed"
#RATE="auto"
KEY="s:secu1"
# To set all four keys, use :
#KEY="s:secu1 [1] key s:secu2 [2] key s:secu3 [3] key s:secu4 [4] key [1]"
# For the RG 1000 Residential Gateway: The ESSID is the identifier on
# the unit, and the default key is the last 5 digits of the same.
#ESSID="084d70"
#KEY="s:84d70"
;;

# Cisco/Aironet 4800/3x0
# Note : MPL driver only (airo/airo_cs), version 1.3 or later
00:40:96:*|00:02:8A:*)
INFO="Cisco/Aironet example (Cisco default settings)"
ESSID="any"
# To set all four ESSID, use iwconfig v21 and the same trick as above
MODE="Managed"
#RATE="11M auto"
#KEY="d5ad2f05abd048ecf10b1c80c7"
KEY="off"
;;

# Samsung MagicLan (+ some other PrismII cards)
# Note : Samsung binary library driver, version 1.20 or later
00:00:F0:*|00:02:78:*)
INFO="Samsung MagicLan example (Samsung default settings)"
ESSID="any"
MODE="Managed"
CHANNEL="4"
RATE="auto"
#KEY="883e-aa67-21 [1] key 5501-d0da-87 [2] key 91f5-3368-6b [3] key 2d73-31b7-96 [4]
"
#IWCONFIG="power on"
;;

# Raytheon Raylink/WebGear Aviator2.4
# Note : doesn't work yet, please use for debugging only :-(
00:00:8F:*|00:00:F1:*)
INFO="Raylink/Aviator2.4 example (Aviator default ad-hoc setting)"
ESSID="ADHOC_ESSID"
MODE="Ad-Hoc"
RATE="auto"
IWPRIV="set_framing 1"
;;

# Old Lucent Wavelan
08:00:0E:*)
INFO="Wavelan example (Lucent default settings)"
NWID="0100"
MODE="Ad-Hoc"
FREQ="2.425G"
KEY="off"
;;

# Netwave (Xircom Netwave/Netwave Airsurfer)
00:80:C7:*)
INFO="Netwave example (Netwave default settings)"
NWID="100"
KEY="00"
;;

# Proxim RangeLan2/Symphony (what is the MAC address ???)
XX:XX:XX:*)
INFO="Proxim RangeLan2/Symphony example"
NWID="0"
MODE="Master"
CHANNEL="15"
IWPRIV="setsubchan 1"
;;

# No Wires Needed Swallow 550 and 1100 setting (what is the MAC address ???)
XX:XX:XX:*)
INFO="NWN Swallow example"
ESSID="session"
KEY="0000-0000-00 open"
;;

# Symbol Spectrum24 setting (what is the MAC address ???)
XX:XX:XX:*)
INFO="Symbol Spectrum24 example"
ESSID="Essid string"
;;

# Generic example (decribe all possible settings)
*)
INFO="Fill with your own settings..."
# ESSID (extended network name) : My Network, any
ESSID=""
# NWID/Domain (cell identifier) : 89AB, 100, off
NWID=""
# Operation mode : Ad-Hoc, Managed, Master, Repeater, Secondary, auto
MODE=""
# Frequency or channel : 1, 2, 3 (channel) ; 2.422G, 2.46G (frequency)
FREQ=""
CHANNEL=""
# Sensitivity (cell size + roaming speed) : 1, 2, 3 ; -70 (dBm)
SENS=""
# Bit rate : auto, 1M, 11M
RATE=""
# Encryption key : 4567-89AB-CD, sassword
KEY=""
# RTS threshold : off, 500
RTS=""
# Fragmentation threshold : off, 1000
FRAG=""
# Other iwconfig parameters : power off, ap 01:23:45:67:89:AB
IWCONFIG=""
# iwspy parameters : + 01:23:45:67:89:AB
IWSPY=""
# iwpriv parameters : set_port 2, set_histo 50 60
IWPRIV=""
;;
esac

now i may have edited it wrong im not sure

I cant remember if i told rc.local to call rc.wireless or rc.wireless.conf now that i think about it

but what were trying to do is get the rc scripts to run the card at start up with my WEP key and ESSIS and call on dhcpcd to get an ip address
 
Old 03-19-2006, 09:34 PM   #6
DrEwMoNeY
Member
 
Registered: Jan 2006
Location: Vulcan
Distribution: *buntu - Slackware - Anything on USB
Posts: 254

Rep: Reputation: 30
If you read my last post, it tells you exactly where to put your ESSID and WEP key. If you want, I can edit the post and highlight it for you.

More importantly though, was the link. I recommend taking a look.
 
Old 03-19-2006, 10:15 PM   #7
Cryptoniks
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Original Poster
Rep: Reputation: 0
drew i appreciate your attempt to help me but if YOU read my script output you would see i HAVE put my key and ESSID in that place...its been in there longe before i even made the initial post...

the issue was and ill state it one last time was getting rc.wireless to be ran at startup

I made progress though which show even more lack of understanding my question i donot mean to berate you but i am now sure your more offbase on this then i

i appeneded /etc/rc.d/rc.inet1 wlan0-start to my rc.local file

the results have helped give a better pinpoint to the issue as i initially thought it would be..that being settings with in the rc.inet1 script

the results of my change to the rc.local script produced this at startup:

dhcpcd MAC address = xx:xx:xx:xx:xx:xx
Error for wireless request "Set Frequency"
Set failed on device wlan0 ; invalid Argument (8B04)
Error for wireless request "Set Encode"
Set failed on device wlan0 ; invalid argument (8B2A)
dhcpcd MAC address = xx:xx:xx:xx:xx:xx

(where the first MAC stringxx:xx:xx:xx:xx:xx is the MAC of my accesspoint and the second one is the MAC of my Wireless adapter)

what this is telling me and confirms for me
1. the setting we need to modify are in fact in the rc.inet1.conf file
2. the wireless card is now being called on at boot (which was the basis of the original post)

3. this leads me to think now that we simply need to add a couple more settings to the rc.inet1.conf file script

this is the layout of the rc.inet1.conf file wlan0 section:

## Example config information for wlan0. Uncomment the lines you need and fill
## in your info. (You may not need all of these for your wireless network)
IFNAME[4]="wlan0"
#IPADDR[4]=""
#NETMASK[4]=""
USE_DHCP[4]="yes"
#DHCP_HOSTNAME[4]="icculus-wireless"
#DHCP_KEEPRESOLV[4]="yes"
#DHCP_KEEPNTP[4]="yes"
#DHCP_KEEPGW[4]="yes"
#DHCP_IPADDR[4]=""
#WLAN_ESSID[4]=BARRIER05
#WLAN_MODE[4]=Managed
##WLAN_RATE[4]="54M auto"
WLAN_CHANNEL[4]="auto"
##WLAN_KEY[4]="D5AD1F04ACF048EC2D0B1C80C7"
##WLAN_IWPRIV[4]="AuthMode=WPAPSK EncrypType=TKIP WPAPSK=7B1ABEEB5D197741923ED26727569C36
5E31212096A0EAFAD563B268BAD01CAF TxRate=0"
#WLAN_WPA[4]="wpa_supplicant"
WLAN_WPADRIVER[4]="ndiswrapper"

## Some examples of additional network parameters that you can use.
## Config information for wlan0:
#IFNAME[4]="wlan0" # Use a different interface name nstead of
# the default 'eth4'
#HWADDR[4]="00:01:23:45:67:89" # Overrule the card's hardware MAC address
#MTU[4]="" # The default MTU is 1500, but you might need
# 1360 when you use NAT'ed IPSec traffic.
#DHCP_KEEPRESOLV[4]="yes" # If you dont want /etc/resolv.conf overwritten
#DHCP_KEEPNTP[4]="yes" # If you don't want ntp.conf overwritten
#DHCP_KEEPGW[4]="yes" # If you don't want the DHCP server to change
# your default gateway
#DHCP_IPADDR[4]="" # Request a specific IP address from the DHCP
# server
#WLAN_ESSID[4]=DARKSTAR # Here, you can override _any_ parameter
# defined in rc.wireless.conf, by prepending
# 'WLAN_' to the parameter's name. Useful for
# those with multiple wireless interfaces.
#WLAN_IWPRIV[4]="AuthMode=WPAPSK EncrypType=TKIP WPAPSK=thekey TxRate=0"
# Some drivers require a private ioctl to be
# set through the iwpriv command. If more than
# one is required, you can place them in the
# IWPRIV parameter (space-separated, see the
# example).

hehe i think ie already located the problem i forgot to uncomment some other lines but ill post this here eitherway even more so if i am right as i think it will help alot of other people
 
Old 03-19-2006, 10:33 PM   #8
Cryptoniks
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Original Poster
Rep: Reputation: 0
well after uncommenting the key and essid lines we still ran into the same problems which is intresting because settings in rc.inet1.conf and rc.inet1 should overrule rc.wireless

the battle conteniues lol not a big deal though not like i dont have net access in linux were just trying to get things automated is all the good way for me to think about it is its not a matter of if but a matter of when

because i know im close

i just gota resolve the set frequency and encode erros and see where we stand from there

linux is a thinking mans game thats for sure

also drew please note im not upsetat you at all im just furstrated because it seems your playing catch up with me on this issue and though your trying with out a doubt im sure to help thus far were just spinning the tires in the mud none the less thank you for the help thus far
 
Old 03-19-2006, 10:42 PM   #9
DrEwMoNeY
Member
 
Registered: Jan 2006
Location: Vulcan
Distribution: *buntu - Slackware - Anything on USB
Posts: 254

Rep: Reputation: 30
Quote:
What i am trying to do is get this setup to all be done at bootup with in the real of the startup scripts provided within slackware
Quote:
once again i have already determined that its simply putting the setting in the proper rc script can you give input to that?
Maybe I am missing something. These quotes lead me to believe that your wireless configuration is not being loaded at startup. As far as I can tell, you are asking how to remedy this. Am I wrong so far?

I first posted how to make sure ndiswrapper loads at startup. If it does not load at startup, iwconfig commands are useless. That was the whole point of that post.

Next I quoted the Slackware book. Once again, the link is far more important than the information I posted. The information on what and where to add, can be found here. Whether this is done correctly is entirely up to you.

But you're right, there is an obvious miscommunication here. I will leave any further advice to the rest of the LQ community.
 
Old 03-19-2006, 11:08 PM   #10
Cryptoniks
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Original Poster
Rep: Reputation: 0
hehe well we have the card and what not now coming up at boot its now just a matter of resolving

dhcpcd MAC address = xx:xx:xx:xx:xx:xx
Error for wireless request "Set Frequency"
Set failed on device wlan0 ; invalid Argument (8B04)
Error for wireless request "Set Encode"
Set failed on device wlan0 ; invalid argument (8B2A)
dhcpcd MAC address = xx:xx:xx:xx:xx:xx

i think once thats good well were good! lol

never the less thanx again man
 
Old 03-20-2006, 12:24 AM   #11
Cryptoniks
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Original Poster
Rep: Reputation: 0
Solved the Set Frequency Issue all that im getting error wise now is
Error for wireless request "Set Encode"
Set failed on device wlan0 ; invalid argument (8B2A)

I assum this has to do with my WEP key

I no longer have to set my ESSID with iwconfig as that appears to stick

i still have to:

iwconfig wlan0 key open mykey

then i can run dhcpcd wlan0 with no issues

so close i can taste it

googled the error nothing of signifacant help to me showed up

anyideas?
i know my key is correct
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cannot configure wireless pci (acx111) via ndiswrapper 1.7 fedora_user Linux - Wireless Networking 1 01-15-2006 09:41 PM
WMP54G Card, Trying to Configure NdisWrapper on SuSE 10.0 BetaMaster Linux - Wireless Networking 1 12-22-2005 07:33 AM
[Gentoo] Ndiswrapper Problem - Failed to configure wireless for wlan0 freek sanders Linux - Software 8 11-11-2005 03:12 AM
slackware 10 startup/hotplug ndiswrapper/acx100 driver jacksmernov Linux - Wireless Networking 3 09-07-2004 12:14 AM
slackware ndiswrapper startup! trey85stang Linux - Wireless Networking 5 07-06-2004 12:46 PM


All times are GMT -5. The time now is 07:59 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration