LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 07-23-2004, 03:53 PM   #1
bluntman
LQ Newbie
 
Registered: Jul 2004
Distribution: Slackware
Posts: 13

Rep: Reputation: 0
wireless card on network, no internet, i tried everything


I have a huge problem with the wireless card on my laptop. I can connect to my LAN but not the internet. The LAN is set up for DHCP but the card doesn't get an IP when I do "dhcpd -d ath0". It just sits there scanning. I do have a script that sets up the card with a static IP (that's how I'm on the LAN) For some reason when I do an NMap ping scan on the network It returns an extra ping from the laptop. I pinged both the address and they both came from the laptop. I don't think it's a DNS issue because I manually edited the resolv.conf file. I copied the format in which Knoppix does it (search earthlink.net nameserver ....) I don't know where to go from here.

Side question: how do I disable eth0 (wired connection) from starting at boot?

Thanks
 
Old 07-24-2004, 07:10 AM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,781
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Hm. Turning off eth0 is pretty easy. If your using Slack 10, then you need to edit your /etc/rc.d/rc.inet1.conf file and either remove the eth0 information or just comment out the lines for eth0. In earlier versions of Slack (and maybe 10 depending on how you set it up) that info is in the /etc/rc.d/rc.inet1 file.

As for why ath0 isn't working with dhcp, that could be more difficult. If eth0 is functional at the same time as you are trying to get ath0 working, it could just be that your computer is confused as to what interface to use. Your ping results kind of suggest this. Another thing to try is to turn off your eth0 with ifconfig eth0 down and then re-do your nmap.

Quote:
when I do "dhcpd -d ath0". It just sits there scanning
Just as a check, the proper command is dhcpcd not dhcpd. If this isn't a typo in your post, that could be the problem.
 
Old 07-24-2004, 10:32 PM   #3
bluntman
LQ Newbie
 
Registered: Jul 2004
Distribution: Slackware
Posts: 13

Original Poster
Rep: Reputation: 0
Thanks a lot. I'm typing this reply from my laptop. I wasted so many hours trying to figure this out and it was all because of one missing letter..
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless Internet Card not Working ask_save Linux - Wireless Networking 5 12-25-2005 01:27 AM
Wireless network up, but no internet Patchy Linux - Wireless Networking 5 09-19-2005 01:38 PM
Wireless internet card eam Linux - Wireless Networking 4 04-20-2004 12:56 PM
how do i get wireless internet? how do i configure my pc card? shapdaddy Linux - Wireless Networking 0 04-11-2004 04:02 PM
Suse 9.0 wireless network card,cannot access internet masaood Linux - Wireless Networking 7 12-04-2003 08:51 PM


All times are GMT -5. The time now is 12:45 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration