Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.


  Search this Thread
Old 07-07-2004, 12:47 PM   #1
LQ Newbie
Registered: Jul 2004
Posts: 4

Rep: Reputation: 0
Wireless Card (MN-520) still not working.

I am a noob to Linux and am having some serious trouble trying to get my laptop to work with the wireless card/router. I have a Microsoft MN-520 with the MN-500 basestation. I am running Linux Fedora Core 1 (I cannot get any of the updates to work when directly connected to the router, but thats different story all together.) I have followed these instructions from a previous post to get the pcmcia card to work... but with a few glitches.

add the following entry into /etc/pcmcia/config file right after the line that reads "# Wireless network adapters":

code:card "Microsoft Wireless Notebook Adapter MN-520 1.0.3"
version "Microsoft", "Wireless Notebook Adapter MN-520", "", "1.0.3"
bind "orinoco_cs"

restart your computer or restart your pcmcia by entering

code: /etc/rc.d/rc.pcmcia restart

then, in /etc/rc.d/rc.inet1.conf

make sure you have the line


where X is your ethernet interface.

next go to /etc/rc.d/rc.wireless.conf

you can use the examples that they have there to make an entry for your network. mine looks like:

code:## --------- START SECTION -----------
## Pick up any Access Point, should work on most 802.11 cards
INFO="Microsoft Wireless Notebook Adapter MN-520 1.0.3"
## ---------- END SECTION ------------

1) I can edit the "/etc/pcmcia/config" without problem and get the OS to recognize the wireless card.

2) This "/etc/rc.d/rc.pcmcia restart" command does not work. rc.pcmcia does not exist.

3) "/etc/rc.d/rc.inet1.conf" does not exist either so I cannot edit that.

4) Same with "/etc/rc.d/rc.wireless.conf"

5) I tried configuring the wireless card via the GUI but still no luck. When I try to activate the card it gives me some error message about how it cannot receive DHCP, and there is some DHclient script misssing.

I have only installed Fedora C1 and have not downloaded the updates. Its a clean install and thats all. Any information on how to get this to work would be GREATLY appriciated. I cannot express how badly I do not want to revert back to windows. PLEASE HELP!
Old 07-07-2004, 01:17 PM   #2
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 66
Moved: This thread is more suitable in Wireless Networking and has been moved accordingly to help your thread/question get the exposure it deserves.
Old 07-11-2004, 08:23 PM   #3
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
Did you solve this yet? It's been a few days since the post.
Old 07-11-2004, 10:05 PM   #4
Senior Member
Registered: Jan 2002
Location: Southern California
Distribution: Slackware
Posts: 1,876

Rep: Reputation: 49
The instructions you listed would work fine for Slackware. Fedora and similar distros use a little different structure.

To set up the wireless parameters, edit /etc/sysconfig/network-scripts/ifcfg-ethx with x being the number of your interface - 0, 1, 2, etc. Or, take the GUI route and run the Fedora network configuration tool. When you save the changes, it writes them to ifcfg-eth0.

To restart a service like card services (PCMCIA) or networking, type:
/etc/init.d/pcmcia restart
/etc/init.d/network restart

To run the script for the interface, bring it up and apply the network settings, click on the "activate" button in the network GUI or via command:
ifup eth0

Hope that gets things going for you.
Old 07-13-2004, 10:31 AM   #5
LQ Newbie
Registered: Jul 2004
Posts: 4

Original Poster
Rep: Reputation: 0
I took advice from another message board that I posted the same problem on. They told me to install Fedora Core 2 and it should recognize the card automatically. So I installed FC2 and during the install it recognized the card as another ethernet adapter (not wireless). The card appeared to be functioning during the install, the power light was solid and the wireless light was flashing. After the install I reboot the computer and nothing. No beeps on startup and no lights on the card. I try to install the card manually, and FC doesn't even recognize that its there. The entry for that exact same card is in the /etc/pcmcia/conf file. Now I'm completely lost. At least with FC1 I was able to enter the IP address in web brower and get to the Router config screen (no internet though). Any thoughts/suggestions would be appriciated.

Old 07-13-2004, 04:40 PM   #6
Registered: Nov 2003
Location: Jacksonville, FL
Distribution: Slackware & Arch
Posts: 825

Rep: Reputation: 31
Get Slackware. The instructions for it are posted here on LQ and they work. I used them.
Old 07-13-2004, 05:18 PM   #7
Senior Member
Registered: Jan 2002
Location: Southern California
Distribution: Slackware
Posts: 1,876

Rep: Reputation: 49
Tryr loading the socket module manually as described in this thread:
Then try the instructions I listed above. They should hold true for FC2. I'm still learning about the 2.6 kernel stuff, though.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
MN-520 Wireless Card and Mandrake 10 fairplayer1 Linux - Wireless Networking 6 10-22-2007 04:39 PM
Dwl-520 D-link wireless card need help? romanticnick4eva Linux - Wireless Networking 0 08-21-2005 02:03 AM
Novel Linux , MN-520 wireless card ford4x460 Linux - Wireless Networking 1 07-05-2005 05:27 PM
Thinkpad A20m, MS MN-520 Wireless card stopped working SignalFreak Linux - Laptop and Netbook 0 01-11-2005 04:55 PM
MN-520 wireless card not detected after reboot.... bowlingd Linux - Wireless Networking 0 10-07-2004 07:02 AM

All times are GMT -5. The time now is 10:36 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration