LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 04-10-2004, 01:23 PM   #1
rickenbacherus
Member
 
Registered: Mar 2003
Location: colorado springs. colorado
Distribution: Debian-Sid 2.6.24-rt1
Posts: 290

Rep: Reputation: 30
Wireless card connecting to wrong ap (I think)


My network is "cromagnonet". I presume the other 2 are windows users. :)

Code:
iwlist wlan0 scanning
wlan0     Scan completed :
          Cell 01 - Address: 00:0D:88:1E:A1:28
                    ESSID:"HOME"
                    Mode:Master
                    Frequency:2.412GHz
                    Quality:0/70  Signal level:-82 dBm  Noise level:-90 dBm
                    Encryption key:off
                    Bit Rate:1Mb/s
                    Bit Rate:2Mb/s
                    Bit Rate:5.5Mb/s
                    Bit Rate:11Mb/s
                    Extra:bcn_int=100
                    Extra:resp_rate=10
          Cell 02 - Address: 00:0F:66:00:7E:54
                    ESSID:"cromagnonet"
                    Mode:Master
                    Frequency:2.437GHz
                    Quality:0/70  Signal level:-37 dBm  Noise level:-91 dBm
                    Encryption key:on
                    Bit Rate:1Mb/s
                    Bit Rate:2Mb/s
                    Bit Rate:5.5Mb/s
                    Bit Rate:11Mb/s
                    Extra:bcn_int=100
                    Extra:resp_rate=10
          Cell 03 - Address: 00:30:AB:1E:11:AC
                    ESSID:"Janet Wireless"
                    Mode:Master
                    Frequency:2.437GHz
                    Quality:0/70  Signal level:-78 dBm  Noise level:-91 dBm
                    Encryption key:off
                    Bit Rate:1Mb/s
                    Bit Rate:2Mb/s
                    Bit Rate:5.5Mb/s
                    Bit Rate:11Mb/s
                    Extra:bcn_int=100
                    Extra:resp_rate=20

I have two systems w/ dwl-520e pci cards. The drivers build and load fine and the firmware uploads to the cards properly.

Asus box:
Code:
dhclient wlan0
Listening on LPF/wlan0/00:0d:88:50:8d:9e
Sending on   LPF/wlan0/00:0d:88:50:8d:9e
Sending on   Socket/fallback
DHCPREQUEST on wlan0 to 255.255.255.255 port 67
DHCPACK from 192.168.1.1
bound to 192.168.1.105 -- renewal in 42801 seconds.
Code:
iwconfig wlan0
wlan0     IEEE 802.11b  ESSID:"cromagnonet"  
          Mode:Managed  Frequency:2.437GHz  Access Point: 00:0F:66:00:7E:54  
          Bit Rate:11Mb/s   Sensitivity=1/3  
          Retry min limit:8   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality:39/70  Signal level:-48 dBm  Noise level:-88 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:169  Invalid misc:158024   Missed beacon:0

On the Compaq machine:

Code:
dhclient wlan0
wifi0: unknown hardware address type 801
wifi0: unknown hardware address type 801
Listening on LPF/wlan0/00:0d:88:4b:df:69
Sending on   LPF/wlan0/00:0d:88:4b:df:69
Sending on   Socket/fallback/fallback-net
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 7
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 12
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 14
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 20
DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 2
No DHCPOFFERS received.
No working leases in persistent database.

Sleeping.
The Compaq box seems to be trying the wrong ap.

Compaq box:
Code:
iwconfig wlan0       
wlan0     IEEE 802.11b  ESSID:"cromagnonet"  
          Mode:Managed  Frequency:2.467GHz  Access Point: 44:44:44:44:44:44  
          Bit Rate=2Mb/s   Sensitivity=1/3  
          Retry min limit:8   RTS thr:off   Fragment thr:off
          Encryption key:123-456-789-abc-def   Security mode:restricted
          Power Management:off
          Link Quality:0/70  Signal level:-73 dBm  Noise level:-73 dBm
          Rx invalid nwid:0  Rx invalid crypt:42  Rx invalid frag:0
          Tx excessive retries:113  Invalid misc:868   Missed beacon:0
I try
Code:
iwconfig wlan0 ap 00:0F:66:00:7E:54
I get no errors but the ap doesn't change. It's still at 44:44:44:44:44:44
Am I doing it wrong?

Additionally I can't change the rate w/ iwconfig.
Code:
iwconfig wlan0 rate 11M
The Compaq wireless card IS working- I can do iwlist scanning with it but I just can't get an i.p. I hope this makes sense and that someone can tell me what it is I'm doing wrong.
 
Old 04-10-2004, 01:28 PM   #2
david_ross
Moderator
 
Registered: Mar 2003
Location: Scotland
Distribution: Slackware, RedHat, Debian
Posts: 12,047

Rep: Reputation: 64
Moved: This thread is more suitable in Wireless Networking and has been moved accordingly to help your thread/question get the exposure it deserves.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless card not connecting to Access Point looks configured though embalmedlenin Linux - Wireless Networking 6 08-13-2005 07:23 AM
Wireless card starts up with wrong ESSID radioradio Linux - Wireless Networking 8 05-12-2005 01:58 PM
Wireless Card Problem Connecting On Boot FC3 mrsmiley Linux - Wireless Networking 1 02-03-2005 10:12 AM
Wireless Card Connecting / Disconnecting (11 2 11 2) phantompgr Linux - Wireless Networking 2 06-19-2004 10:17 AM
Suse 8.2 detecting the wrong pcmcia wireless card maker10 Linux - Wireless Networking 5 09-01-2003 11:11 PM


All times are GMT -5. The time now is 04:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration