LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 07-08-2003, 10:28 AM   #1
Alex_jacobson
Member
 
Registered: Jul 2003
Distribution: Slackware 10.1 on 2.4.29
Posts: 55

Rep: Reputation: 15
Wireless and routers


Hi all,

I'm using SuSE 8.2 with a WPC11 v.3 card that is supposed to work.. ( My laptop see it ) But when it comes the time to connect to the wireless router, there's nothing. I downloaded kwifimanager, the connection to my wireless is ultimate but I don't have a local IP, they say it's unavailable. And my access point is unknown. Do this problem is due to the fact that I did'nt know what to write in the wireless settings ? (Operating mode : ad-hoc, ESSID: nothing, NWID: nothing, Encryption key:nothing, Nickname: nothing) or is it because my card is a linksys and my router a networkeverywhere ? Don't forget that I am a newbie

Thanks in advance,

Alex Jacobson
 
Old 07-08-2003, 10:40 AM   #2
Alex_jacobson
Member
 
Registered: Jul 2003
Distribution: Slackware 10.1 on 2.4.29
Posts: 55

Original Poster
Rep: Reputation: 15
Oh I forgot, my card and router use DHCP
 
Old 07-08-2003, 07:29 PM   #3
akaBeaVis
Guru
 
Registered: Apr 2003
Location: Maryland
Distribution: Slack 9.1,10 Mandrake 10,10.1, FedCore 2,3, Mepis 2004, Knoppix 3.6,3.7, SuSE 9.1, FreeBSD 5.2
Posts: 1,109

Rep: Reputation: 45
I currently use D-Link, Belkin and SMC cards in conjunction with my SMC wireless router, all work correctly, WEP included.

So, I would guess the manufacturer mismatch is not the problem. Seems to me your problem is either with the hardware setup of your card or the configuration of it. If you'd like, I'd be interested in seeing the output from ifconfig -a and iwconfig.

Also, typically "ad-hoc" mode is for use when no router/access point is present, for use with an access point or router, you should use "managed" mode.

Last edited by akaBeaVis; 07-08-2003 at 07:32 PM.
 
Old 07-08-2003, 09:15 PM   #4
Alex_jacobson
Member
 
Registered: Jul 2003
Distribution: Slackware 10.1 on 2.4.29
Posts: 55

Original Poster
Rep: Reputation: 15
That's the output of ifconfig -a


eth0 Link encap:Ethernet HWaddr 00:B0:D0:A4:9B:36
inet addr:192.168.1.101 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::2b0:d0ff:fea4:9b36/64 Scope:Link
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:381 errors:0 dropped:0 overruns:0 frame:0
TX packets:436 errors:0 dropped:0 overruns:0 carrier:205
collisions:0 txqueuelen:100
RX bytes:142680 (139.3 Kb) TX bytes:60150 (58.7 Kb)
Interrupt:9 Base address:0xfc00

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:60 errors:0 dropped:0 overruns:0 frame:0
TX packets:60 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3912 (3.8 Kb) TX bytes:3912 (3.8 Kb)

sit0 Link encap:IPv6-in-IPv4
NOARP MTU:1480 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

wlan0 Link encap:Ethernet HWaddr 00:06:25:18:79:79
BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:5 Base address:0x100


and for iwconfig,

lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.

wlan0 IEEE 802.11-b ESSID:""
Mode:Managed Frequency:2.462GHz Access Point: 00:06:25:07:68:7B
Bit Rate:2Mb/s Tx-Power:2346 dBm
Retry min limit:8 RTS thr:off Fragment thr:off
Encryption key:off
Link Quality:92/92 Signal level:-40 dBm Noise level:-98 dBm
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0
 
Old 07-09-2003, 10:27 AM   #5
Alex_jacobson
Member
 
Registered: Jul 2003
Distribution: Slackware 10.1 on 2.4.29
Posts: 55

Original Poster
Rep: Reputation: 15
does someone can help me ?
 
Old 07-09-2003, 11:58 AM   #6
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,780
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
OK, does your router have an ESSID? Have you enabled WEP on the router? If you don't have either of these set properly, you won't get an IP address.

When I boot up Knoppix on my desktop machine (normally it runs XP), I have to do the following:

iwconfig eth0 essid "ESSID NAME"
iwconfig eth0 key keyvalue

After that, I have wireless, no problem. You'll probably have to subsitute wlan0 for eth0.
 
Old 07-09-2003, 12:58 PM   #7
Alex_jacobson
Member
 
Registered: Jul 2003
Distribution: Slackware 10.1 on 2.4.29
Posts: 55

Original Poster
Rep: Reputation: 15
Does'nt work either,

it says : SET failed on device wlan0 ; Function not implemented
 
Old 07-09-2003, 03:23 PM   #8
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,780
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
Are you root when you try to use iwconfig?
 
Old 07-09-2003, 07:01 PM   #9
Alex_jacobson
Member
 
Registered: Jul 2003
Distribution: Slackware 10.1 on 2.4.29
Posts: 55

Original Poster
Rep: Reputation: 15
Yup
 
Old 07-09-2003, 07:31 PM   #10
finegan
Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
Are you using the linux-wlan.net driver set? If so, if I remember right they still work by manipulating the setting in /etc/wlan/ and then hard restarting pcmcia. I don't think they've got wireless extensions support yet, am I wrong?

Cheers,

Finegan
 
Old 07-09-2003, 08:24 PM   #11
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,780
Blog Entries: 1

Rep: Reputation: 412Reputation: 412Reputation: 412Reputation: 412Reputation: 412
That might explain it finegan. On my desktop, the wireless card is in a PCI slot, not pcmcia.
 
Old 07-09-2003, 08:47 PM   #12
finegan
Guru
 
Registered: Aug 2001
Location: Dublin, Ireland
Distribution: Slackware
Posts: 5,700

Rep: Reputation: 57
The important thing is, are you using the linux-wlan.net drivers? I'm assuming so, they're the only ones that come with SuSe and identify a wireless device as wlan0. If I remember this stuff right you have to modify the settings in /etc/wlan/wlan.conf and/or use wlanctl-ng, the linux-wlan drivers are, last I checked, still not compliant with wireless extensions and therefore don't work with "iwconfig" and its friends. Check through the documentation in /etc/wlan, its probably explained there.

Also, there are the orinoco drivers which also cover prism2 chipsets and work with normal "iwconfig" commands.

Cheers,

Finegan
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
2 wireless routers, 2 wireless devices installed joltz Linux - Wireless Networking 1 11-16-2005 04:51 AM
Wireless Cards and Routers that work or don't acidblue Fedora 2 02-11-2005 11:05 PM
Wireless ADSL Modem Routers for MDK10.0 He He Man Mandriva 0 10-04-2004 05:52 AM
Wireless - Routers - Firewalls - Slack 9 Culbert Slackware 1 05-06-2003 06:47 PM
Routers... bac()n Linux - Newbie 3 03-28-2003 11:26 PM


All times are GMT -5. The time now is 11:06 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration