LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   wifi wep... almost done (http://www.linuxquestions.org/questions/linux-wireless-networking-41/wifi-wep-almost-done-300452/)

kermit 03-11-2005 12:35 PM

wifi wep... almost done
 
Hi all,

I've installed ndiswrapper and a us robotics 5410 pcmcia card, following a couple of tutorials and everything works correctly but (yeap, there's always a but hehe) I can't connect to the internet.

I can associate correctly to the AP, do DHCP to receive an ip address but after that I try to ping to the gateway and:

ping: sndmsg: Operation not permitted

I'm using debian sarge 2.6.8-1-686

any clues?

thanks a lot!!

snecklifter 03-11-2005 01:31 PM

ping: sndmsg: Operation not permitted

This isnt right. Are you just running:

ping 192.168.2.1

or something like that from the shell? If you are then you might need to be su but I cant for the life of me understand why. Maybe DOS attack prevention or something.

kermit 03-11-2005 01:57 PM

Yeap snecklifter I'm doing that ping from shell, but it's still the same with root user.

thanks!!

snecklifter 03-11-2005 04:17 PM

Just out of interest, can you run a traceroute to any destination ip? This also uses ICMP - it would be good to know at which OSI layer this is happening. Does
ping 127.0.0.1
work?
If so, then try pinging you own computer's IP like 192.168.2.2 or whatever.
Let me know the results.
Cheers
Chris

kermit 03-13-2005 06:25 AM

Thanks a lot snecklifter!!

Both pings that you suggest work fine (127.0.0.1 and 192.168.123.106)

that tells you anything?

snecklifter 03-13-2005 05:08 PM

Certainly. This means that your network stack isnt screwed. Just a configuration problem. What is the router's ip? It should be something like 192.168.123.1? Can you also post back your netmask and gateway settings as well as your dns ip address or hostname. Its going to be one of these.
Regards
Chris

kermit 03-14-2005 02:00 PM

Thanks man you're my salvation! You have an invitation to some spanish beers and drinks in Madrid whenever you want!

The netmask 255.255.255.0 and the router is 192.168.123.254. The DNS are handled also by the router, so it would be that same ip.

snecklifter 03-14-2005 02:31 PM

Woah, we aint there yet! Thanks for the invite though.

Unfortunately it all looks fine from the info you've post back. So I need a bit more. Can you post back the output from
Code:

route -n
However its about time to try something. Can you change the IP address of the router to 192.168.123.1? Then try re-associating with it using dhclient. There's nothing really wrong with placing a router at the end of the ip range but by default they are placed at the beginning and if there is anything playing funny buggers that doing this will eliminate that concern.

Regards
Chris

kermit 03-14-2005 03:36 PM

Yeap we are not there yet but your time wasted thinking/writing deserves that drinks!!

I changed the router to 192.168.123.1 but it's still the same. The routing table was:

dest gateway genmask flags metric ref use iface
192.168.1.0 0.0.0.0 255.255.255.0 U 0 0 0 eth0
192.168.123.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
0.0.0.0 192.168.1.1 0.0.0.0 UG 0 0 0 eth0
0.0.0.0 192.168.123.1 0.0.0.0 UG 0 0 0 wlan0

After that I disabled eth0 (even though the cable is unplugged) and get:

dest gateway genmask flags metric ref use iface
192.168.123.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
0.0.0.0 192.168.123.1 0.0.0.0 UG 0 0 0 wlan0

but still the same:

#ping 192.168.123.1
PING 192.168.123.1 (192.168.123.1) 56(84) bytes of data.
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted
....

Notice that the connection to the AP looks like it's ok: The router and the AP are different devices, and the dhclient wlan0 works fine. I changed the password to try and could not get a valid DHCP ip address.

snecklifter 03-14-2005 04:08 PM

So you set the WEP key before you get the IP address - I guess you must do or the router would say "no dice". Therefore it must be a problem on the router end. From what you've posted I cant see a problem with your configuration. This is mine:

Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.2.0 0.0.0.0 255.255.255.0 U 0 0 0 eth1
169.254.0.0 0.0.0.0 255.255.0.0 U 0 0 0 eth1
0.0.0.0 192.168.2.1 0.0.0.0 UG 0 0 0 eth1

therefore I'm assuming its an incorrect association with the router or some MAC address filtering or something happening. Is there anything odd in the router setup page?

kermit 03-14-2005 04:20 PM

No, in fact I went through it when changing the ip and everything was quite clear.

I don't think it has to do with the AP, when trying in windows it works smoothly :(

Both the network card and the router are US Robotics, and the AP is Ovislink, can it be something about incompatibility between the brands? :confused:

Thanks a lot again!

snecklifter 03-15-2005 04:52 AM

kermit,

Do you have any firewall running on debian at the moment? If so, try temporarily disabling it. This might be the cause of your problems.
Regards
Chris

n0xvb 03-15-2005 06:39 AM

Quote:

Originally posted by kermit

I changed the router to 192.168.123.1 but it's still the same. The routing table was:
After that I disabled eth0 (even though the cable is unplugged) and get:

dest gateway genmask flags metric ref use iface
192.168.123.0 0.0.0.0 255.255.255.0 U 0 0 0 wlan0
0.0.0.0 192.168.123.1 0.0.0.0 UG 0 0 0 wlan0

Notice that the connection to the AP looks like it's ok: The router and the AP are different devices, and the dhclient wlan0 works fine. I changed the password to try and could not get a valid DHCP ip address.
What do you get back when you run iwconfig?

Also, you might add the AP IP into your route table as a host entry:

route add 192.168.123.1 wlan0

and then

route add default gw 192.168.123.1

This last command may give you an error about that route already existing, that's okay.
Then give your ping command another try, but use traceroute

traceroute 192.168.123.1

If you run dhcpcd wlan0, this should be automatically set up. When you say you changed the password and now cannot get DHCP address are you connected?


All times are GMT -5. The time now is 03:32 AM.