LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 05-16-2005, 02:32 PM   #1
ArchiMark
Member
 
Registered: Sep 2004
Location: Silicon Valley
Distribution: Debian/Linux Mint/Archbang/Angstrom
Posts: 79

Rep: Reputation: 15
Question WiFi Setup on Fujitsu P1120 Subnotebook?


Just installed Debian 'Sarge' on my new little Fujitsu P1120 subnotebook...Dual boots with WinXP now. Overall, works great so far!

Right now I can connect OK to my network at home using built-in ethernet port.

Now, I'd like to get the built-in WiFi working too!

I have tried to search for info on this but have found very little that seems to apply to this situation.

Also, I have seen several references to using 'iwconfig', but when I tried typing that in terminal, I got message that it wasn't found.

So, what should I do or need to get to get this working?

If there's any good reference info on this somewhere that would be great too!

Most other sites refer to using separate PCMCIA PC cards for WiFi not built-in. Don't know if that makes much difference in setting this up.

Thanks for any and all help!

Mark
 
Old 05-16-2005, 05:21 PM   #2
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
We (and you) will need to know the chipset of the card before we can do much.

Make sure that the card is enabled in BIOS, that it's turned on - some wireless cards have a key sequence or a physical switch, then run lspci to see what's there.
 
Old 05-16-2005, 06:39 PM   #3
ArchiMark
Member
 
Registered: Sep 2004
Location: Silicon Valley
Distribution: Debian/Linux Mint/Archbang/Angstrom
Posts: 79

Original Poster
Rep: Reputation: 15
Smile

Thanks for your help, 2Gnu!

Makes sens what you're saying.....

Will check it out and report back later....

Thanks!

Mark
 
Old 05-17-2005, 12:14 PM   #4
ArchiMark
Member
 
Registered: Sep 2004
Location: Silicon Valley
Distribution: Debian/Linux Mint/Archbang/Angstrom
Posts: 79

Original Poster
Rep: Reputation: 15
Quote:
We (and you) will need to know the chipset of the card before we can do much.
Intersil Corporation Prism 2.5 Wavelan Chipset (rev 01)

Quote:
Make sure that the card is enabled in BIOS, that it's turned on - some wireless cards have a key sequence or a physical switch, then run lspci to see what's there.
Code:
#lspci -v
0000:00:12.0 Network Controller: Intersil Corporation Prism 2.5 Wavelan Chipset (rev 01)
Subsystem: Fujitsu Ltd.: Unknown device 1169
Flags: medium devsel, IRQ 9
Memory at e8103000 (32-bit, prefetchable) [size=4K]
Capabilities: [dc] Power Management version 2

Built-in WiFi is turned on, has switch on laptop....

Thanks,

HTH,

Mark
 
Old 05-17-2005, 02:40 PM   #5
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
You're in fat city. That chipset is well-supported.

modprobe orinoco_cs will load the driver you need (this assumes that the vanilla Sarge kernel includes wireless support - I'd be very surprised to learn otherwise).

The iwconfig command will list the available wireless interfaces - probably eth1 in your case. Add some options - iwconfig eth1 essid herb where "herb" is the SSID, for example - to set the wireless parameters.

Someone who knows Debian can tell you where to put those settings to make them persist after a reboot - in a network control script.
 
Old 05-17-2005, 03:18 PM   #6
ArchiMark
Member
 
Registered: Sep 2004
Location: Silicon Valley
Distribution: Debian/Linux Mint/Archbang/Angstrom
Posts: 79

Original Poster
Rep: Reputation: 15
WOW, 2Gnu, think I've got WiFi!

Won't know for sure till I go home and test on my WiFi network, but it
appears from what I see in terminal that it's recognized and working...

Will report back later to confirm...

THANKS for your help!

Mark


Quote:
Originally posted by 2Gnu
You're in fat city. That chipset is well-supported.

modprobe orinoco_cs will load the driver you need (this assumes that the vanilla Sarge kernel includes wireless support - I'd be very surprised to learn otherwise).

The iwconfig command will list the available wireless interfaces - probably eth1 in your case. Add some options - iwconfig eth1 essid herb where "herb" is the SSID, for example - to set the wireless parameters.

Someone who knows Debian can tell you where to put those settings to make them persist after a reboot - in a network control script.
 
Old 05-17-2005, 10:28 PM   #7
ArchiMark
Member
 
Registered: Sep 2004
Location: Silicon Valley
Distribution: Debian/Linux Mint/Archbang/Angstrom
Posts: 79

Original Poster
Rep: Reputation: 15
Angry

Well....at home now and just tried to get WiFi up....NO GO... ;-(

When I type 'modprobe orinocco_cs' I get the following:

FATAL: Module or orinocco_cs not found.

Now when I check what modules are loaded, I see:

orinocco_pci and orinocco, but not no orinocco_cs

However, when I do 'modprobe orinocco_pci' or 'modprobe orinocco''
I still get same error message......

Any suggestions???

Thanks,

Mark
 
Old 05-17-2005, 11:32 PM   #8
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
OK, the bus architecture of the card is mini-PCI so my mistake with the orinoco_cs. You want to modprobe orinoco_pci. Not sure why it's erroring when you modprobe it, though, especially if lsmod shows that it's already there.

Check your spelling. You typed orinocco - probably just a typo in your post vs. a bad command.

Irrespective of the above, assuming orinoco_pci is loaded, what does iwconfig display? eth1 or wlan0 should as active. Set the mode (managed) the ESSID and any encryption with iwconfig, then try to pull an IP from the router.
 
Old 05-18-2005, 12:27 AM   #9
ArchiMark
Member
 
Registered: Sep 2004
Location: Silicon Valley
Distribution: Debian/Linux Mint/Archbang/Angstrom
Posts: 79

Original Poster
Rep: Reputation: 15
Question

OK, 2Gnu, my bad too...

OK, so I can't spell orinoco....

Anyway.....

modprobe OK now...

iwconfig says:

eth1 IEEE 802.11-DS ESSID: "key" Nickname: "Prism I"
Mode: Managed Access Point: 00:00:00:00:00:00 Bit Rate: 11 Mb/s
Tx-Power=15 dBm Sensitivity: 1/3
Retry min limit: 8 RTS thr: off Fragment thr: off
Encryption key: 4xxx-xxxx-xx Security mode: open
Power Management: Off

Also, did
#iwconfig eth1 essid NetworkName key xxxxxxxxx
#ifconfig eth1 up
#chclient eth1
After a bunch of text, I got:
sit0: unknown hardware address type 776
Listening on LPF/eth1/00:e0:00:d3:f4:8e
Sending on LPF/eth1/00:e0:00:d3:f4:8e
Sending on Socket/fallback/fallback-net
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 6
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 9
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 10
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 13
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 20
DHCPDISCOVER on eth1 to 255.255.255.255 port 67 interval 2
No DHCPOFFERS received.
No working leases in persistent database.

Sleeping.

#

Any more ideas??

Thanks,

Mark
 
Old 05-18-2005, 01:14 AM   #10
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
The all zeros for the access point says that you're not associated.
Are you running MAC address filtering by any chance? If so, turn it off.
Is the SSID being broadcast? Some configs don't work properly with it off.
Is "key" your ESSID? If so, as least that part worked.
Have you tried without WEP? If that works, maybe just a key entry error.
This line: #chclient eth1 should be dhclient eth1. Again, I'm assuming a typo, but just checking.

That's all I can think of for now.
 
Old 05-18-2005, 09:24 AM   #11
ArchiMark
Member
 
Registered: Sep 2004
Location: Silicon Valley
Distribution: Debian/Linux Mint/Archbang/Angstrom
Posts: 79

Original Poster
Rep: Reputation: 15
Quote:
Originally posted by 2Gnu
The all zeros for the access point says that you're not associated.
Yes, figured that...

Quote:
Are you running MAC address filtering by any chance? If so, turn it off.
Using Apple AirPort Base Station for WiFi AP. From what I can tell in AirPort Admin Utility
I don't think so...just 40bit WEP...

There is a checkbox to select 'Create a closed network', but it's unchecked.

Quote:
Is the SSID being broadcast? Some configs don't work properly with it off.
Again, I think so...when I've connected in the past with other laptops, it picks it up...

Quote:
Is "key" your ESSID? If so, as least that part worked.
No, I thought you needed to type in 'key' before entering your WEP key string....
I'm entering 10 characters for key itself....

[/QUOTE]
Have you tried without WEP? If that works, maybe just a key entry error.
[/QUOTE]

OK, turned off WEP and now my laptop can see my network!!

wconfig says:

eth1 IEEE 802.11-DS ESSID: "MarksAirport" Nickname: "Prism I"
Mode: Managed Frequency: 2.412 GHz Access Point: 00:30:65:1D:9D:9F
Bit Rate: 11 Mb/s Tx-Power=15 dBm Sensitivity: 1/3
Retry min limit: 8 RTS thr: off Fragment thr: off
Encryption key: off
Power Management: Off
Link Quality=90/92 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

Also, I opened up KWiFiManager app and now for the first time it shows my network. It says
'Local IP: 10.0.1.3'

Quote:
This line: #chclient eth1 should be dhclient eth1. Again, I'm assuming a typo, but just checking.
That's all I can think of for now.
you're right that was a typo.... it works now!

Just tried Firefox and got online!

So....now I need to

1) Get this working with my WEP key and

2) Create script (?) to make all this happen each time I boot up, right?

3) Also, how do you deal with having both WiFi and ethernet port on my laptop in terms of usually when one is used,
the other is not, usually???

Or can they both be active at the same time???

Hope you get what I'm trying to get at.....



Thanks,

Mark
 
Old 05-18-2005, 03:36 PM   #12
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
To automate, you can do one of several things (mostly, it's a personal preference but there can be a "right" way depending on certain timings - that is, you shouldn't be trying to ask for an IP address until you set up the wireless parameters.):

1. If there's a wireless configuration file, put the desired values there. In Slack, it's /etc/rc.d/rc.wireless.conf. Debian devotees, help us out, here.

2. There is usually a network script. In Red Hat, for example, it's /etc/sysconfig/network-scripts/ifcfg-eth1. Wireless parameters can go here, along with dhcp requests, etc.

3. Local. Be it /etc/rc.d/rc.local or similar, there's always a place of last resort to put things that happen on boot. Be sure to use the full path.

Module loading in 2.6 kernels is in /etc/modprobe.conf. For Sarge and a stock kernel, I think you're still using /etc/modules.conf.

Lastly, the dual interfaces:
I simply take one down before bringing the other up via the command line as needed. (ifconfig eth0 down. If you have a script, like RH, it might be ifup eth0) You can use both interfaces for certain situations, but generally wouldn't want to. Look around for ip masquerading HOWTOs.

Hope that helps.

edit - forgot the WEP key thing.

iwconfig eth1 key 12345abde will set it manually or in a local script. Look at the syntax in the network config or interface script for Debin to get the right setting. The Airport, IIRC, has a 0x prefix for the key to denote hex vs. ASCII. Linux assumes hex. If the Airport shows the key as 0x12345abcde, enter it in your laptop as iwconfig eth1 key 12345abcde. Some config files use hyphens: 1234-5abc-de. Strange, but true.

Last edited by 2Gnu; 05-18-2005 at 03:41 PM.
 
Old 05-18-2005, 04:10 PM   #13
ArchiMark
Member
 
Registered: Sep 2004
Location: Silicon Valley
Distribution: Debian/Linux Mint/Archbang/Angstrom
Posts: 79

Original Poster
Rep: Reputation: 15
Thanks as always, 2Gnu for all your help and advice.

Wouldn't be able to keep moving forward (inch by inch it seems somedays....) in LinuxLand without
the great help from people like you!

Will keep plugging at away this....if I get to a point where I have some specific questions I'll post them here....

Thanks,

Mark
 
Old 05-18-2005, 04:24 PM   #14
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
Happy to help. My head still hurts from the wall-banging I did trying to get wireless going under Red Hat 7.2 on a PII 266 Dell laptop when I was too new to even be able to spell Linux. (Can you say "train wreck?")

Wish I could help more with Debian, but I ran it for all of a few days several months ago. Try the LQ Debian forum or here: http://forums.debian.net/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setup Touchscreen & Suspend on Fujitsu P1120 Subnotebook? ArchiMark Linux - Laptop and Netbook 6 05-24-2005 05:24 AM
Using Built-in WiFi on Fujitsu P1120 ArchiMark Debian 2 05-16-2005 02:41 PM
How do I setup wireless on a Fujitsu Lifebook S6120 joffa Debian 3 03-21-2005 09:28 AM
Fujitsu P1120 Slackware Install No CD hotplainrice Slackware 12 03-06-2004 08:15 PM
fujitsu c1020 fedora modem setup wizzboy Fedora 0 02-24-2004 03:57 PM


All times are GMT -5. The time now is 03:16 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration