LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
LinkBack Search this Thread
Old 12-24-2008, 01:03 AM   #1
leontini
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Fedora Core 8-10
Posts: 61

Rep: Reputation: 15
wifi connection instantly dissassociating on hp2510p using iwlagn driver


Hello all,

I almost have my wireless card working under Fedora 10 out of the box. However, I cannot get a usable connection. Here is what I can describe of the problem so far:

Left-clicking the NetworkManager applet (in the system tray at the bottom right-hand side in KDE 4.1), I am presented with a list of all the wireless networks in my apartment building, with a status bar showing the connection strength of each.

Left-clicking on my home network, I am presented with a screen asking for authentication details. The wireless security dropdown list correctly defaults to "WPA & WPA2 personal".

I enter the WPA key, and the NetworkManager icon in the system tray changes to a spinning "thinking" icon, and hovering the mouse over it displays the message "Requesting network address from my_network_name".

Eventually this stops with the message "The network connection has been disconnected". This seems weird, because I don't seem to have been connected in the first place!

Checking the dmesg output, it appears that the card initially connects to my wireless router, but then just as quickly drops it, citing "reason=3" (I don't know what that means, or where to find out). The relevant dmesg output is shown below (I've blanked out the access point address, but it is certainly that of my wireless router):

Code:
wlan0: associate with AP XX.XX.XX.XX.XX.XX
wlan0: RX ReassocResp from XX.XX.XX.XX.XX.XX (capab=0x401 status=0 aid=2)
wlan0: associated
wlan0: disassociating by local choice (reason=3)
wlan0: associate with AP XX.XX.XX.XX.XX.XX
wlan0: RX ReassocResp from XX.XX.XX.XX.XX.XX (capab=0x401 status=0 aid=2)
wlan0: associated
wlan0: disassociating by local choice (reason=3)
The last 5 lines of this output repeat a number of times.

My first guess was that this was a problem with the WPA security level, so I reset the router to be unsecured. However, I got essentially the same result. Again, the relevant dmseg output is below:

Code:
wlan0: authenticate with AP XX.XX.XX.XX.XX.XX
wlan0: authenticated
wlan0: associate with AP XX.XX.XX.XX.XX.XX
wlan0: RX AssocResp from XX.XX.XX.XX.XX.XX (capab=0x401 status=0 aid=2)
wlan0: associated
wlan0: disassociating by local choice (reason=3)
wlan0: associate with AP XX.XX.XX.XX.XX.XX
wlan0: RX ReassocResp from XX.XX.XX.XX.XX.XX (capab=0x401 status=0 aid=2)
wlan0: associated
wlan0: disassociating by local choice (reason=3)
The last 5 lines of this are repeated another 22 times (I guess this matches a retries count in a config file somewhere).

After this, I suspected a driver problem. However, would I get such accurate reporting of the state of the wireless networks around me if the driver didn't work? Also, nm-tool seems to say everything is fine. It reports the driver as iwlagn, as well as reporting that WPA2 is supported. The output is below:

Code:
- Device: wlan0 ----------------------------------------------------------------
  Type:              802.11 WiFi
  Driver:            iwlagn
  State:             disconnected
  Default:           no
  HW Address:        XX.XX.XX.XX.XX.XX

  Capabilities:
    Supported:       yes

  Wireless Settings
    WEP Encryption:  yes
    WPA Encryption:  yes
    WPA2 Encryption: yes

  Wireless Access Points
    Network 1: Infra, XX:XX:XX:XX:XX:XX, Freq 2462 MHz, Rate 54 Mb/s, Strength 31 WPA
    Network 2:              Infra, XX:XX:XX:XX:XX:XX, Freq 2462 MHz, Rate 54 Mb/s, Strength 31 WPA
    Network 3:         Infra, XX:XX:XX:XX:XX:XX, Freq 2437 MHz, Rate 54 Mb/s, Strength 79 WEP
    Network 4: Infra, XX:XX:XX:XX:XX:XX, Freq 2437 MHz, Rate 54 Mb/s, Strength 45 WEP
    Network 5:        Infra, XX:XX:XX:XX:XX:XX, Freq 2437 MHz, Rate 54 Mb/s, Strength 42 WEP
    my_network_name: Infra, XX:XX:XX:XX:XX:XX, Freq 2462 MHz, Rate 54 Mb/s, Strength 91 WPA2
    Network 6:         Infra, XX:XX:XX:XX:XX:XX, Freq 2437 MHz, Rate 54 Mb/s, Strength 28 WEP
Has anybody seen a problem like this before? Is the iwlagn driver new? I am having trouble digging up information on it by googling. lspci -v reports that the network card is an Intel Corporation PRO/Wireless 4965 AG or AGN Controller, and the kernel driver and kernel module in use are iwlagn.

Any help getting this going would be greatly appreciated, it seems it's almost there! (I guess it was a bit hopeful for everything to work out of the box...)

Thanks in advance,
 
Old 12-25-2008, 12:41 PM   #2
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,381
Blog Entries: 3

Rep: Reputation: 169Reputation: 169
let me guess a cable modem your router is connected to. if not any way configure the connection. When you configured your router was it with windows . hard wire to your router go to it.s gateway you know the 192.168.11.1 somthing like that. then go to your security setting and look at the what type of wep or wpa is used. then make sure after logging out of the router that you configure your wifi conection and configure your passphrase the same as your wep 128 wep 64/128 hex or web 64 asc 11 what ever it is. If this does not work then this tells me you may have a cable modem reconfigure your router. to use the wifi card. yeap take it back to factory setting then reboot your computer the you can choose to to use the wifi card or hard line to configure the wan and lan as dhcp then set the wep then set the wificard conection pasphrase. to the matching wep or wpa.
For some reason cable modems remember macs a little different not sure but. I spent the last two weeks doing cable modem and dsl modems. the cable modems hooked to the same type of routers did not make the hand shake with the wifi card. drove me nuts had to reconfigure every router connected to cable modems. these were all hrs54gs routers linksys and buffalo. and one net gear.

Last edited by Drakeo; 12-25-2008 at 12:46 PM.
 
Old 12-28-2008, 07:45 AM   #3
leontini
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Fedora Core 8-10
Posts: 61

Original Poster
Rep: Reputation: 15
Drakeo,

Thanks for the reply, and apologies for my late response, but things have been a little busy over christmas.

I'm having a bit of trouble interpreting what you have said. You seem to be hinting that the way my router connects to the internet is affecting whether my laptop can connect to the router? I don't see how that is possible. But anyway, for future reference, the router connects to the internet via the mobilephone network with SIM card.

To change the security settings, I was using a second laptop that was connected to the router (wirelessly) using Windows XP. That allowed me to configure the router (at 192.168.1.1) through a web interface. Regardless of the security settings, the Compaq laptop I am having the problem with could connect to the router wirelessly when running Windows Vista (it is dual booting).

Do you have any other advice with this new information? Maybe I missed something from your initial post.

Thanks,
 
Old 12-29-2008, 03:46 PM   #4
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,381
Blog Entries: 3

Rep: Reputation: 169Reputation: 169
wpa if you are going to use wpa you need to get the wcid from slackware extras read it good. I also use wifi_radar both work well there is now way to hook up the moment the wifi card bradcast and the router returns if you do not have the key for it and the program it will screw up. /etc/rc.d/rc.inet1.conf eth4=yes I do not dhcp=yes for eth4 becuse it slows my boot down and I want to be able to pic the wifi connection I want when I run wifi-radar.
I also found that sence I was using a broadcom bcm43xx that the huge kernel was loading two drivers for the same card and it would shut the card down.
I also found on the wifi router if you do not have the key right it will kick you out and not let you back in it remembered the mac of my card and no matter what it would not let me in had to start all over.
 
Old 12-29-2008, 07:39 PM   #5
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,381
Blog Entries: 3

Rep: Reputation: 169Reputation: 169
every one of those are security key problems. I had this happen to me I am using the newer wicd program they have about 8 different types of security and the program does not explain it's self very well. so it took me about four different setting to get it. the other one I was using it was a bit different. as you typed in the letters at 5 letters it would be 64 bit wep and then 13 would be wep 128 so. Like you. even putting in the wpa I had 4 different types. And I was real lost because the router had another way of expressing what it wanted .
so finally this week I add wicd program to Ubuntu slackware and pclinux and as of tonight all my stuff auto dhcp real nice here is the site. Read what you have to do. But it turned it all into on click then auto.
http://wicd.sourceforge.net/ I am very happy now. all my stuff is working little hit and miss on one wep key but that was ok then went to wpa and it seemed to do it better little slower connection but it is ok. I am glad you caught me in the middle of upgrading my systems because I would have never had theses issues.

Last edited by Drakeo; 12-29-2008 at 07:40 PM.
 
Old 03-03-2009, 02:31 AM   #6
leontini
Member
 
Registered: Aug 2003
Location: Melbourne, Australia
Distribution: Fedora Core 8-10
Posts: 61

Original Poster
Rep: Reputation: 15
To anyone stumbling across this thread:

The hardware mentioned is working now - in a way. It is very flaky, and appears to be a bug in the iwlagn driver, especially when connecting to n-type wireless networks (I'm not exactly sure what that means). Many people using intel cards have had the same issue, see bug http://www.intellinuxwireless.org/bu...ug.cgi?id=1871. The problem is that the card associates fine with the AP, but cannot then acquire a network address through DHCP.

The way I have made the card work is:
First close down all NetworkManager stuff and associated services,
/etc/init.d/NetworkManager stop
/etc/init.d/wpa_supplicant stop
/sbin/dhclient -r

Then reloaded the kernel module with the option to disable n-type connections,
modprobe -r iwlagn
modprobe iwlagn 11n_disable=1

Then started wpa_supplicant from the command line (with all debugging)
/usr/sbin/wpa_supplicant -Dwext -dd -t -i wlan0 -c /etc/wpa_supplicant.conf

Then, in another terminal, I have run arping to see when the wireless card becomes ready to accept inward traffic,
arping 192.168.1.1 -I wlan0 -D

Other users in the bug report have mentioned that once this completes, you are ready to go. I've found I have to rerun arping until I got to the stage where I only needed one broadcast for one response. Anyway.

Then, run dhclient,

dhclient -v wlan0

This should associate and set up a new lease from the DHCP server.

Now, with all of this, even though dhclient told me I was associated, and had been given an IP address, the IP address was not added to the interface, at least not as reported by ifconfig. So, I did the natural thing and rebooted.

As the system came back up, NetworkManager INSTANTLY CONNECTED TO THE WIRELESS NETWORK! Why, I'm not exactly sure. I thought maybe it was just falling back on a lease that was acquired with all the command line tools, but there is nothing in /var/log/messages that shouws falling back to an old lease. Also, I didn't think that the kernel module options would hold after the reboot. My only theory is that something gets saved at the AP end of things. I'll try and monitor this more closely, and if I learn anything useful, I'll report it here.

Happy networking,
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
How to prioritise LAN connection over WiFi connection __spc__ Linux - Wireless Networking 0 09-05-2008 02:38 PM
Ubuntu WiFi connection kaspin6.75 LinuxQuestions.org Member Success Stories 3 03-18-2008 05:39 PM
wifi connection gibney Linux - Hardware 1 10-13-2007 01:26 PM
wifi connection DonaldUK Slackware 2 10-06-2006 03:05 PM
Loosing wifi connection stav53 Linux - Newbie 8 05-18-2006 09:11 AM


All times are GMT -5. The time now is 03:12 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration