LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   WiFi Connection Failure on Intel Corporation WiFi Link 5100 (http://www.linuxquestions.org/questions/linux-wireless-networking-41/wifi-connection-failure-on-intel-corporation-wifi-link-5100-a-873863/)

physicsguru 04-08-2011 06:01 PM

WiFi Connection Failure on Intel Corporation WiFi Link 5100
 
I am currently installing Scientific Linux on a laptop and, except for now, there have been no issues. I find that the Wireless connection is not working.

I am using the Scientific Linux 5

uname -r
2.6.18-238.5.1.el5

ipconfig:

Quote:

[root@localhost ~]# iwconfig > iwconfig.txt
lo no wireless extensions.

eth0 no wireless extensions.

sit0 no wireless extensions.
lspci:

Code:

00:00.0 Host bridge: Intel Corporation Mobile 4 Series Chipset Memory Controller Hub (rev 07)
00:01.0 PCI bridge: Intel Corporation Mobile 4 Series Chipset PCI Express Graphics Port (rev 07)
00:1a.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #4 (rev 03)
00:1a.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #5 (rev 03)
00:1a.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #6 (rev 03)
00:1a.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #2 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 03)
00:1c.0 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 1 (rev 03)
00:1c.1 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 2 (rev 03)
00:1c.2 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 3 (rev 03)
00:1c.4 PCI bridge: Intel Corporation 82801I (ICH9 Family) PCI Express Port 5 (rev 03)
00:1d.0 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #1 (rev 03)
00:1d.1 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #2 (rev 03)
00:1d.2 USB Controller: Intel Corporation 82801I (ICH9 Family) USB UHCI Controller #3 (rev 03)
00:1d.7 USB Controller: Intel Corporation 82801I (ICH9 Family) USB2 EHCI Controller #1 (rev 03)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 93)
00:1f.0 ISA bridge: Intel Corporation ICH9M-E LPC Interface Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation ICH9M/M-E SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801I (ICH9 Family) SMBus Controller (rev 03)
01:00.0 VGA compatible controller: nVidia Corporation G94 [GeForce 9800M GTS] (rev a1)
02:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8071 PCI-E Gigabit Ethernet Controller (rev 16)
04:00.0 Network controller: Intel Corporation WiFi Link 5100
0d:06.0 FireWire (IEEE 1394): O2 Micro, Inc. Firewire (IEEE 1394) (rev 02)
0d:06.2 SD Host controller: O2 Micro, Inc. Integrated MMC/SD Controller (rev 02)
0d:06.3 Mass storage controller: O2 Micro, Inc. Integrated MS/xD Controller (rev 01)


When opening the Networks, I see the ethernet (eth0) active and it is functioning fine. The wlan0 is inactive and attempts to activate it give the following:

Quote:

Error for wireless request "Set Mode" (8B06) :
SET failed on device wlan0 ; Invalid argument.
Error for wireless request "Set Encode" (8B2A) :
SET failed on device wlan0 ; Invalid argument.

Determining IP information for wlan0...
I also checked the HCL for any asstistance and didn't see the network card listed anywhere. Any help would be greatly appreciated.

Lawrence

physicsguru 04-08-2011 06:41 PM

NetWork Manager
 
After going through the setup, I discovered the NetworkManager had been disabled during setup by default. Once enabled, connection is working fine.


All times are GMT -5. The time now is 03:34 AM.