LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 10-03-2011, 02:19 PM   #1
couf
LQ Newbie
 
Registered: Sep 2011
Distribution: Bodhi Linux
Posts: 28

Rep: Reputation: Disabled
wicd - No wireless networks found


It was suggested to me to install wicd so I could connect to the internet while using Fluxbox. Under GNOME/Metacity I'm able to connect automatically and my network is detected. However, when I try to connect using Fluxbox it does not detect my network. How can I resolve this?
 
Old 10-03-2011, 02:41 PM   #2
derstephen
Member
 
Registered: Sep 2011
Location: Northern Colorado
Distribution: Slackware64
Posts: 79

Rep: Reputation: Disabled
Hi, me again. Have you tried the manual method I suggested? What's the output of
Code:
sudo iwconfig
?

Last edited by derstephen; 10-03-2011 at 02:47 PM.
 
Old 10-03-2011, 02:44 PM   #3
couf
LQ Newbie
 
Registered: Sep 2011
Distribution: Bodhi Linux
Posts: 28

Original Poster
Rep: Reputation: Disabled
Here it is. I did it in a GNOME session, if that's relevant.
Quote:
lo no wireless extensions.

eth0 no wireless extensions.

eth2 IEEE 802.11 ESSID:"(name of my network)"
Mode:Managed Frequency:2.437 GHz Access Point: 00:21:29:AC:80:25
Bit Rate=54 Mb/s Tx-Power:24 dBm
Retry min limit:7 RTS thr:off Fragment thr:off
Encryption key:off
Power Managementmode:All packets received
Link Quality=5/5 Signal level=-48 dBm Noise level=-88 dBm
Rx invalid nwid:0 Rx invalid crypt:12 Rx invalid frag:0
Tx excessive retries:271 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.
 
Old 10-03-2011, 03:01 PM   #4
derstephen
Member
 
Registered: Sep 2011
Location: Northern Colorado
Distribution: Slackware64
Posts: 79

Rep: Reputation: Disabled
Alright so now try:

Code:
sudo iwlist eth2 scan | grep nameofyournetwork
where nameofyournetwork is the name (a.k.a. essid) of the network you're trying to connect to.

Also, what kind of encryption does this network use? WPA2?
 
Old 10-03-2011, 03:16 PM   #5
couf
LQ Newbie
 
Registered: Sep 2011
Distribution: Bodhi Linux
Posts: 28

Original Poster
Rep: Reputation: Disabled
The terminal said to that command:

Quote:
essid="nameofmynetwork"
It has WPA/WPA2 security.
 
Old 10-03-2011, 03:50 PM   #6
derstephen
Member
 
Registered: Sep 2011
Location: Northern Colorado
Distribution: Slackware64
Posts: 79

Rep: Reputation: Disabled
Good, that means your wireless card can see the network. Strange that wicd can't see it...

Well, what follows is a manual way of setting up the network. I did this successfully in Slackware, so now it detects the network automatically on boot and everything. So you can follow this if you're up to it or wait for someone with more wicd experience who may know what's up with that. It's not that hard; you just have to edit a configuration file.

Not sure but at least at one point Debian called this file /etc/network/interfaces. Slackware calls it /etc/rc.d/rc.inet1.conf, just to give you other ideas if you can't find it.

By the way, the official Debian manual for this can be found here, look at "The Wireless LAN Interface with WPA/WPA2", so defer to that if my suggestions don't work.

What it comes down to is adding this to the file:
Code:
allow-hotplug eth2
iface eth2 inet dhcp
wpa-ssid nameofyournetwork
wpa-psk yournetworkpassphrase
and you can comment out the entries that come before it using #'s at the beginning of the lines.

But make sure you have the wpasupplicant package installed too:
Code:
sudo apt-get install wpasupplicant
Save and close the file and run:
Code:
sudo /etc/init.d/networking restart
And cross your fingers!
 
Old 10-03-2011, 03:54 PM   #7
rokytnji
Senior Member
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 13 , Various Puppys (MacPup,Slack0),MX-14
Posts: 2,475
Blog Entries: 16

Rep: Reputation: 779Reputation: 779Reputation: 779Reputation: 779Reputation: 779Reputation: 779Reputation: 779
Better check with OP to see if they are running Network Manager also, since there might be a conflict with wicd with both of them running.
 
Old 10-03-2011, 04:11 PM   #8
couf
LQ Newbie
 
Registered: Sep 2011
Distribution: Bodhi Linux
Posts: 28

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by rokytnji View Post
Better check with OP to see if they are running Network Manager also, since there might be a conflict with wicd with both of them running.
Yes, I have NetworkManager running, what should I do?
 
Old 10-03-2011, 04:24 PM   #9
rokytnji
Senior Member
 
Registered: Mar 2008
Location: Waaaaay out West Texas
Distribution: AntiX 13 , Various Puppys (MacPup,Slack0),MX-14
Posts: 2,475
Blog Entries: 16

Rep: Reputation: 779Reputation: 779Reputation: 779Reputation: 779Reputation: 779Reputation: 779Reputation: 779
If deciding to keep Fluxbox and Gnome as dual desktop environments. You are going to have to make a decision and uninstall Network Manager and just run Wicd only.

Wicd conflicts with Network Manager and that is probably why wicd is not seeing your wireless networks and is probably the reason this whole thread was started.
 
Old 10-03-2011, 08:18 PM   #10
frankbell
Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Debian, Mageia, Mint
Posts: 7,411

Rep: Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404Reputation: 1404
It would help to set your ~/.fluxbox/startup file to start wicd (or whatever network manager you eventually use) automatically, by adding

Code:
wicd &
in the correct location in the file.

The wicd icon will appear in Fluxbox's system tray and be accessible for checking status and logging on to a new network if you happen to be in the presence of one.

See the Fluxbox wiki for more.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] wicd does not detect wireless networks djmb Linux - Wireless Networking 2 02-18-2011 10:42 PM
No wireless networks found abh Linux - Wireless Networking 2 09-07-2010 02:11 AM
No Wireless networks found under Wicd nickboarder27 Linux - Wireless Networking 5 05-26-2010 09:18 PM
Wicd doesn't show wireless networks, other than my own. aes canis Linux - Wireless Networking 3 03-15-2010 10:58 AM
No Wireless Networks Found After Ubuntu 9.10 Upgrade Using a IBM Wireless-B Card mepis1 Ubuntu 15 02-01-2010 08:52 PM


All times are GMT -5. The time now is 03:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration