LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 05-11-2005, 10:55 AM   #1
harshnoise
Member
 
Registered: Feb 2005
Location: Newcastle, England
Distribution: SuSE Pro 9.2
Posts: 35

Rep: Reputation: 15
Why does my router keep disconnecting?


Its more annoying than anything else. Basically if I do not access a web page after a period of a couple of minutes my Belkin wireless router simply disconnects my ADSL connection.

The only way I seem to be able to get round this problem is if I leave something like amsn running, but I don't always want that on.

This has been happening since I installed Linux a few months back it never happened when I was using Windows. Any ideas about what the heck is going on?
 
Old 05-12-2005, 09:11 PM   #2
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
Is your router configured to drop the connection after time idle? Also, is it connected via ethernet, or is one of those crappy (IMHO) USB routers?
 
Old 05-13-2005, 05:44 AM   #3
harshnoise
Member
 
Registered: Feb 2005
Location: Newcastle, England
Distribution: SuSE Pro 9.2
Posts: 35

Original Poster
Rep: Reputation: 15
I don't think so, it doesn't do this if I boot the computer in Windows. The router (which is also the ADSL modem) is connected via the ethernet card on another machine.

ADSL line ---> Wireless Router -----> Ethernet ----> Computer running Windows XP
. . . . . . . . . . . . . . . .^
. . . . . . . . . . . . . . . .|
Computer running Linux
 
Old 05-13-2005, 10:03 PM   #4
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
The ADSL is disconnected? Or the link to the Linux box? Is the linux box connected via hardwired ethernet or wireless?
 
Old 05-14-2005, 07:04 AM   #5
harshnoise
Member
 
Registered: Feb 2005
Location: Newcastle, England
Distribution: SuSE Pro 9.2
Posts: 35

Original Poster
Rep: Reputation: 15
The Linux box uses a wireless card to connect to the router. But that doesn't get disconnected, its the actual adsl connection. It has to be something to do with how Linux because I could leave it on for days with Windows and it wouldn't disconnect.
 
Old 05-14-2005, 07:36 AM   #6
harshnoise
Member
 
Registered: Feb 2005
Location: Newcastle, England
Distribution: SuSE Pro 9.2
Posts: 35

Original Poster
Rep: Reputation: 15
Actually, just got an email back from Belkin support center. Tried what they suggested and it seems to be working now Thanks anyway man.
 
Old 05-14-2005, 01:36 PM   #7
Matir
Moderator
 
Registered: Nov 2004
Location: San Jose, CA
Distribution: Ubuntu
Posts: 8,507

Rep: Reputation: 118Reputation: 118
For future reference, what did Belkin suggest?
 
Old 05-14-2005, 04:42 PM   #8
harshnoise
Member
 
Registered: Feb 2005
Location: Newcastle, England
Distribution: SuSE Pro 9.2
Posts: 35

Original Poster
Rep: Reputation: 15
Basically they told me there was a variable for setting the 'idle time' which I was not aware of, so they said set it to 0. They told me to set the MTU value to 1400. I don't know what that does, but it seems to work. Lastly I had to enable 'dial on demand' which I havn't done yet.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
KInternet disconnecting Lang Suse/Novell 4 08-09-2005 01:08 PM
disconnecting dialup jmartinph Linux - Networking 1 03-21-2004 05:20 AM
Wireless keeps disconnecting from AP mickeyboy Red Hat 17 01-07-2004 08:24 PM
Disconnecting Kppp mike35 Linux - Newbie 1 10-20-2003 08:47 PM
Router Disconnecting raxxor Linux - Networking 0 09-28-2003 02:03 PM


All times are GMT -5. The time now is 02:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration