LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Why can't I authenticate my wireless WEP Key (even though it is correct) (http://www.linuxquestions.org/questions/linux-wireless-networking-41/why-cant-i-authenticate-my-wireless-wep-key-even-though-it-is-correct-858208/)

DaveEnfield 01-23-2011 08:18 PM

Why can't I authenticate my wireless WEP Key (even though it is correct)
 
I switched to the b43xx (lp-phy) driver, as opposed to the broadcom STA driver which I previously had. I have dell 8312b/g lp-phy(mini) wireless card.


I have the wireless detection, but when I attempt to connect to Fios WiFi it continuously asks for my WEP (I have the correct WEP and I have typed it in correctly) and fails to connect. I have also configured the network manager correctly, as I previously have for this connection.

I've read about the driver and firmware on linuxwireless and kernel.wireless. org.

http://pastebin.com/w44Xbgw3 (lspci -nnk output)
http://pastebin.com/C5BDhgZ9 (iwconfig output - this printed while trying to access the network)

Why is this happening? How can I fix this?

reed9 01-24-2011 08:42 AM

First, just to make sure, you did install the b43 firmware, yes?

And second, the b43 driver requires a couple of options to work with your wireless card. Are you using those options?

Code:

sudo modprobe -r b43
sudo modprobe b43 pio=1 qos=0

Load module with the options at boot
Code:

echo "options b43 pio=1 qos=0" | sudo tee -a /etc/modprobe.d/modprobe.conf

DaveEnfield 01-25-2011 11:22 AM

Yes I installed the firmware; I used the b43-fwcutter. I am going to give those command options a go and get back to ya. Thanks for the help it is appreciated.

DaveEnfield 01-25-2011 01:24 PM

Quote:

Originally Posted by reed9 (Post 4235983)
First, just to make sure, you did install the b43 firmware, yes?

And second, the b43 driver requires a couple of options to work with your wireless card. Are you using those options?

Code:

sudo modprobe -r b43
sudo modprobe b43 pio=1 qos=0

Load module with the options at boot
Code:

echo "options b43 pio=1 qos=0" | sudo tee -a /etc/modprobe.d/modprobe.conf

Thanks a lot it all worked out ! I ended up using
Code:

sudo modprobe -r b43
sudo rmmod b43
sudo modprobe b43 pio=1 qos=0

It works perfectly.

chintan169 02-14-2011 08:05 PM

I have WUSB600N v2 and have Ubuntu 10.10 32 Bit. I have this same problem. But I don't know how to fix it. Please please help me.


All times are GMT -5. The time now is 03:45 AM.