LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 12-16-2005, 03:05 PM   #1
jonsmel-pf
LQ Newbie
 
Registered: Dec 2005
Posts: 2

Rep: Reputation: 0
Unhappy WEP key errors


Does anyone know what is going wrong here. I have been trying to get WEP enabled on my linux AP. Here is what I have in my interfaces file.

#iface br0 inet static
address 10.0.0.11
netmask 255.255.255.0
network 10.0.0.0
broadcast 10.0.0.255
bridge_ports eth0 ath0
pre-up ifconfig eth0 0.0.0.0 up
pre-up ifconfig ath0 0.0.0.0 up
pre-up /sbin/iwpriv ath0 mode 1 #0=abg,1=a,2=b,3=g
pre-up /sbin/iwconfig ath0 mode master
pre-up /sbin/iwconfig key 123456789012345678901234567
pre-up /sbin/iwconfig ath0 essid test
pre-up /sbin/sysctl -w dev.ath0.diversity=1
pre-up brctl addbr br0
pre-up brctl addif br0 eth0
pre-up brctl addif br0 ath0
post-down ifconfig eth0 0.0.0.0 down
post-down ifconfig ath0 0.0.0.0 down
post-down brctl delif br0 eth0
post-down brctl delif br0 ath0
post-down brctl delbr br0

This is the error I get when I try to bring up the device

Error for wireless request "Set Encode" (8B2A) :
SET failed on device ath0 ; Invalid argument.
Failed to bring up ath0.

I have tried just bringing up the wireless card itself not in the bridge and it still gets the same error. I don't know what is going wrong here, this is supposed to be easy.

Thanks for any help.

Jon

P.S. I am running on Debian 3 and have an atheros 5213a card. Everything works fine with the access point, just can't get WEP enabled and running.
 
Old 12-16-2005, 06:38 PM   #2
jonsmel-pf
LQ Newbie
 
Registered: Dec 2005
Posts: 2

Original Poster
Rep: Reputation: 0
WEP Resolved

I found out what it was, you have to have the wlan_wep module loaded to have wep keys. There were no instructions about this until I contacted the wireless card driver developer. madwifi.org
 
Old 08-24-2006, 10:12 AM   #3
dunkert
LQ Newbie
 
Registered: Aug 2006
Location: Montreal
Distribution: fedora
Posts: 19

Rep: Reputation: 0
Smile WEP ath0

I beleive the problem is with the file keys-ath0
I found that by removing the file keys-ath0 and adding WEP={key}
in the file ifcfg-ath0 instead solved the problem (at least for me).
Also I tried changing the file key-ath0 by removing the s: in
key=s:{key} to key={key} solved the problem.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Have to enter WEP-key over and again artificialGekko Linux - Wireless Networking 2 11-07-2005 08:11 AM
WEP key thoyyib Linux - Wireless Networking 2 09-29-2005 04:22 AM
What if I don't know the WEP key? death_au Linux - Wireless Networking 1 04-26-2005 07:40 PM
WEP Key HashBang Linux - Wireless Networking 1 01-25-2004 02:55 AM
How exactly do I specify a WEP key? Electrode Linux - Wireless Networking 3 09-02-2003 09:50 AM


All times are GMT -5. The time now is 12:30 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration