LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 04-24-2004, 10:50 AM   #1
apu95
Member
 
Registered: Apr 2004
Location: Montreal, Canada
Distribution: Ubuntu
Posts: 39

Rep: Reputation: 15
weird...wireless connects to router but not internet


i just finished installing the wlan drivers for a dell truemobile 1180 usb adapter (uses prism2 chipset). i finally figured out how to properly connect to my router, and i tested the connection using ping and linneighborhood to see for my windows pc's.
i configured the resolv.conf file to my nameservers (in the format of:

nameserver IP Address

and I saved the file. i went into a browser and went into my router's config, everything worked perfectly, asked for my password and I was in. the problem is that that is the only page i can connect to. if i try any normal website (www.hotmail.com for example), it wont go into it. i tried a bunch of pages, just in case the other ones could've been down, but no webpages other than the router's config load up.

im not sure where the problem might be lying cuz i have my ip properly configured (as far as i know) and i ran the instructions exactly on the wlan driver's guide.

it says i have to do a port reset (due to a bug in the prism driver) so i just unplug my adapter, plug it back in, i run the rc.wlan script, then i run the commands in order to load the driver into memory (wlanctl-ng, ifconfig, etc), and thats it, im connected to the router.

as far as i know, it should be loading up pages....anyone have any ideas on why this is happening?

thx!
Apu
 
Old 04-24-2004, 11:46 AM   #2
antwerx
LQ Newbie
 
Registered: Apr 2004
Posts: 3

Rep: Reputation: 0
Hello,

How to you connect to the Internet? Dial up, cable or dsl.

What brand of router do you have?

Cycle the power on the router and cable/dsl modem and try the Internet again.
 
Old 04-24-2004, 12:13 PM   #3
apu95
Member
 
Registered: Apr 2004
Location: Montreal, Canada
Distribution: Ubuntu
Posts: 39

Original Poster
Rep: Reputation: 15
no, thats not it cuz when i boot into windows it works perfectly and in the router config it also shows that its connected properly.
its weird cuz i can go into the router, as well as linneighbourhood....
 
Old 04-24-2004, 09:24 PM   #4
zaphodiv
Member
 
Registered: Oct 2003
Distribution: Slackware
Posts: 388

Rep: Reputation: 30
Sounds like you are manually setting an ip address on your computer and you have neglected to set the gateway address.
 
Old 04-24-2004, 10:24 PM   #5
apu95
Member
 
Registered: Apr 2004
Location: Montreal, Canada
Distribution: Ubuntu
Posts: 39

Original Poster
Rep: Reputation: 15
where do i assign the gateway address so it stays configured, rather than having to configure it everytime i boot into mdk?

thx!

Apu
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WPC54G Connects to the router but not the net worldgnat Linux - Wireless Networking 7 07-11-2005 09:10 PM
wireless-G Braoband Router-4 port switch no internet master Linux - Wireless Networking 11 01-23-2005 12:30 PM
Connects to router, but no internet Lee_B_H Linux - Wireless Networking 4 01-08-2005 08:54 PM
wireless connection to router works, but no internet g4rr3tt Linux - Wireless Networking 10 04-02-2004 02:27 PM
dsl/ wireless router no internet stratowalker Linux - Wireless Networking 1 12-16-2003 08:04 PM


All times are GMT -5. The time now is 10:17 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration