LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices



Reply
 
Search this Thread
Old 11-20-2004, 02:37 PM   #1
Qarbon
LQ Newbie
 
Registered: Nov 2004
Posts: 1

Rep: Reputation: 0
vector 4.3 wifi-ethernet bridge for XP client


Howdy,

First time post, long time reader. I loaded a lightweight distro called vector 4.3 ( basically a trimmed down version of slack ) running kernel 2.6. It's on a 200mmx with 64MB ram and i must say i'm pretty impressed so far. It is a router/firewall for my network using gShield as the firewall. I want to set up my wife's XP system (upstairs) on the network (in the basement) using wifi (2 motorola wpci810g cards). Here are the interfaces on the router: eth0(dhcp) outside internet, eth1(192.168.1.1) internal gateway, wlan0(wpci810g wifi card). From what i have read i need to bridge eth1 and wlan0 together for it to work. I have downloaded and installed: ndiswrapper, bridge-utils, openvpn. They all installed and work fine from what i can tell, but i seem to be missing the mark somewhere. Here is my ifconfig:

br0 Link encap:Ethernet HWaddr 00:0F:66:E6:62:C8
inet addr:192.168.1.1 Bcast:192.168.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:4 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:468 (468.0 b) TX bytes:0 (0.0 b)

eth0 Link encap:Ethernet HWaddr 00:80:AD:70:C6:46
inet addr:24.17.233.34 Bcast:255.255.255.255 Mask:255.255.254.0
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:847807 errors:17 dropped:0 overruns:0 frame:17
TX packets:119735 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:322615333 (307.6 Mb) TX bytes:8433622 (8.0 Mb)
Interrupt:3 Base address:0xe000

eth1 Link encap:Ethernet HWaddr 00:40:F4:5E:7B:E6
UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1
RX packets:120126 errors:0 dropped:0 overruns:0 frame:0
TX packets:205988 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:8953182 (8.5 Mb) TX bytes:282886886 (269.7 Mb)
Interrupt:9 Base address:0xd800

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:55 errors:0 dropped:0 overruns:0 frame:0
TX packets:55 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:6160 (6.0 Kb) TX bytes:6160 (6.0 Kb)

tap0 Link encap:Ethernet HWaddr 00:FF:FB:80:B2:64
UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:4 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

wlan0 Link encap:Ethernet HWaddr 00:0F:66:E6:62:C8
UP BROADCAST RUNNING PROMISC MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:994 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:173679 (169.6 Kb)
Interrupt:10 Memory:e6000000-e6001fff

I noticed the MAC for wlan0 and br0 are the same.
All the clients in the LAN can ping each other and br0.
winXP cant ping anything or be pinged (pung?). I manually set its ip configuration with my router settings.
Now the questions: Are the physical locations a problem? Do i really need to bridge eth1 and wlan0? Can i make my router an access point? Do i need to make an ad-hoc or managed network?

Any help in this matter would be greatly appreciated by me and my wife.
If you need any more info please let me know.



Thanks so much for reading this drivel
chris
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
WIFI Bridge Under Suse 9.1 Cypher04 Linux - Wireless Networking 0 01-15-2005 03:06 AM
try an ethernet to wireless bridge!! leec11 Linux - Wireless Networking 0 10-10-2004 10:42 PM
Network Bridge- IR to Ethernet systemparadox Linux - Networking 2 08-18-2004 09:51 AM
Ethernet Bridge bogging out finegan Linux - Networking 4 04-28-2004 04:21 AM
Ethernet Bridge Tables on kernel 2.6.* carboncopy Linux - Networking 1 03-14-2004 12:42 PM


All times are GMT -5. The time now is 08:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration