LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 03-24-2005, 01:06 PM   #1
amam
Member
 
Registered: Jul 2001
Location: Ohio
Distribution: Ubuntu (Hoary)
Posts: 30

Rep: Reputation: 15
ubuntu not detecting dlink dwl-g520


I purchases the dwl-g520 rev. b it has the atheros chipset. Everything I have seen says it should work out of the box with ubuntu. When I try to run ifup ath0 it cannot find the interface. I know the modules are loaded. All the posts I've found are how to get it working with ifconfig already able to detect it. Mine won't even be detected by it.
 
Old 03-24-2005, 07:19 PM   #2
ignorant_savant
Member
 
Registered: Oct 2004
Location: Phoenix, AZ
Distribution: Slackware, SuSE
Posts: 54

Rep: Reputation: 15
Lets test it

look at the chipset
Code:
#lspci
I bought a d-link and it had a different chipset than I thought I had.
If it is the correct chipset then,

Check the module
Code:
#modprobe
if you don't see atheros you've found your problem.

Everything check out so far? Try ifdown eth0 before ifup ath0 to solve your problem.

Still having problems, post back.
 
Old 03-25-2005, 10:15 AM   #3
amam
Member
 
Registered: Jul 2001
Location: Ohio
Distribution: Ubuntu (Hoary)
Posts: 30

Original Poster
Rep: Reputation: 15
lspci gave me
Code:
0000:00:09.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abgNIC (rev 01)
and dmesg gave
Code:
ath%d unable to attach hardware; HAL status 13
I am using linuxants driverloader now but it stops working after a few minutes every time i load it . Before I installed driverloader lsmod said ath_pci was loaded along with ath_hal, ath_rate_onoe and wlan.

Last edited by amam; 03-25-2005 at 10:18 AM.
 
Old 03-25-2005, 10:36 PM   #4
amam
Member
 
Registered: Jul 2001
Location: Ohio
Distribution: Ubuntu (Hoary)
Posts: 30

Original Poster
Rep: Reputation: 15
I am being disconnected every 5-10 min. with the linuxant driverloader and would really like to get the madwifi working does "ath%d unable to attach hardware; HAL status 13" just mean it is not supported by the drivers?
 
Old 03-26-2005, 02:11 AM   #5
amam
Member
 
Registered: Jul 2001
Location: Ohio
Distribution: Ubuntu (Hoary)
Posts: 30

Original Poster
Rep: Reputation: 15
it works now in ndiswrapper kinda funny ndiswrapper works without dropping out but driverloader which costs money doesn't good thing i was on a trial license
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dlink DWL-G520+ Mes Fedora 1 07-16-2008 10:20 AM
Best distro for DLink DWL-G520 antisocialiting Linux - Networking 2 08-08-2005 11:31 AM
dlink dwl-g520+ wireless cards linuxuser_2004 Linux - Wireless Networking 1 08-09-2004 12:48 PM
dlink dwl-g520 for desktop with slack true_atlantis Linux - Wireless Networking 4 06-21-2004 08:03 AM
Need driver for a Dlink DWL-G520+ Deadeye Linux - Hardware 4 06-03-2004 04:16 PM


All times are GMT -5. The time now is 02:35 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration