LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Wireless Networking (http://www.linuxquestions.org/questions/linux-wireless-networking-41/)
-   -   Ubuntu 8.04 wireless problems on t60 thinkpad using atheros wireless adapter AR5212 (http://www.linuxquestions.org/questions/linux-wireless-networking-41/ubuntu-8-04-wireless-problems-on-t60-thinkpad-using-atheros-wireless-adapter-ar5212-664301/)

NuxIT 08-21-2008 05:54 AM

Ubuntu 8.04 wireless problems on t60 thinkpad using atheros wireless adapter AR5212
 
Hi, I've been trying to get my atheros based adapter on my t60 with WPA1 TKIP encryption to work for days. Basically, I used to have 128bit WEP encryption working fine on my previous load of 7.10. I was using the built in linux drivers and didn't have any issues. Ever since I upgraded to 8.04 my wireless has been dead in the water. I'm running a dual-boot XP/Ubuntu load and ending up trying to follow this guide to use ndiswrapper:

https://help.ubuntu.com/community/Wi...er/Ndiswrapper

I just grabbed the windows wireless drivers from my windows/system32 directory and used the command line to install the wireless driver in linux with ndiswrapper utility. This is my wireless adapter:
Atheros Communications Inc. AR5212 802.11abg NIC (rev 01)

The driver appears to be successfully installed judging from this command.
Code:

styles@t60:/etc/network$ ndiswrapper -l
net5211 : driver installed
        device (168C:1014) present (alternate driver: ath_pci)

Also, I've blacklisted the appropriate drivers using in /etc/modprobe.d/blacklist:
# causes issues with atheros wireless driver
blacklist ath_pci

# disable linux wireless
blacklist ath_hal

I seem to have to manually start ndiswrapper using the command modprobe ndiswrapper in order for the wireless adapter to come up under system > network. I then enter my 63 character WPA1 key. After that it tries to enable the adapter but will give me a non-routeable IP (169.x.x.x) after timeout from DHCP request to my router.
Code:

ath0      Link encap:Ethernet  HWaddr 00:19:7e:4c:15:eb
          inet6 addr: fe80::219:7eff:fe4c:15eb/64 Scope:Link
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:727 errors:0 dropped:0 overruns:0 frame:0
          TX packets:890 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:82151 (80.2 KB)  TX bytes:125569 (122.6 KB)
          Interrupt:21 Memory:edf00000-edf10000

ath0:avahi Link encap:Ethernet  HWaddr 00:19:7e:4c:15:eb
          inet addr:169.254.6.229  Bcast:169.254.255.255  Mask:255.255.0.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Interrupt:21 Memory:edf00000-edf10000

Here's some more info:
Code:

styles@t60:/etc/network$ iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

irda0    no wireless extensions.

ath0      IEEE 802.11g  ESSID:"ROCCO"
          Mode:Managed  Frequency:2.442 GHz  Access Point: 00:11:50:5E:FC:1F
          Bit Rate=54 Mb/s
          Power Management:off
          Link Quality:64/100  Signal level:-55 dBm  Noise level:-96 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0  Missed beacon:0

Code:

styles@t60:/etc/network$ sudo cat interfaces
auto lo
iface lo inet loopback
address 127.0.0.1
netmask 255.0.0.0


#iface eth0 inet dhcp

auto eth1
#iface eth1 inet dhcp

auto eth2
#iface eth2 inet dhcp


auto wlan0
#iface wlan0 inet dhcp





iface ath0 inet dhcp
wpa-driver wext
wpa-key-mgmt WPA-PSK
wpa-proto WPA
wpa-ssid ROCCO



iface eth0 inet dhcp



auto ath0

auto eth0

I also tried using the wicd utility and it would show all the wireless networks and I could enter my WPA key but that utility didn't work either. Any ideas what the heck is wrong? Thanks a lot.


All times are GMT -5. The time now is 03:44 AM.