LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 03-07-2007, 11:22 PM   #1
Feelin' Fine
LQ Newbie
 
Registered: Feb 2007
Location: Canada
Distribution: Ubuntu 6.10
Posts: 10

Rep: Reputation: 0
Unhappy Trying everything, but cannot connect D-Link/Atheros 0023 wireless card to network


Just took the plunge and wiped XP to install Ubuntu 6.10. So far I'm liking everything I see.
BUT - I can't seem to get the wireless network card to connect to my wireless router.

Wireless card is D-Link DWA 542 / chipset is Atheros 0023

Using ndiswrapper -l: I know that the net5416.inf driver is installed and that the system is seeing the wireless card.

iwlist scan:

wlan0 Scan completed :
Cell 01 - Address: 00:19:5B:04:CD:90
ESSID:"Hudson Family Network"
Protocol:IEEE 802.11g
Mode:Managed
Frequency:2.452 GHz (Channel 9)
Quality:0/100 Signal level:-1 dBm Noise level:-256 dBm
Encryption keyff
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
9 Mb/s; 12 Mb/s; 18 Mb/s; 24 Mb/s; 36 Mb/s
48 Mb/s; 54 Mb/s
Extra:bcn_int=100
Extra:atim=0

iwconfig:

wlan0 IEEE 802.11g ESSIDff/any Nickname:"Hudson Family Network"
Mode:Managed Frequency:2.422 GHz Access Point: Not-Associated
Bit Rate=54 Mb/s
Power Managementff
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

To me.....this says that the system sees the wireless card and the wireless card sees the router/network. I have also employed wifi radar and it reports a good, strong signal. However, when I ask it to connect ot the network, it returns "Could not get IP address!"

Why is this? If it's not already apparent, I'm very new to Linux, and really need some detailed help here. (READ: talk to me like I'm 4 years old).
Even some pointers on how to better diagnose what the problem is would be most appreciated.
 
Old 03-07-2007, 11:25 PM   #2
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
Have you run "ifconfig wlan0 up"?
 
Old 03-08-2007, 11:47 PM   #3
Feelin' Fine
LQ Newbie
 
Registered: Feb 2007
Location: Canada
Distribution: Ubuntu 6.10
Posts: 10

Original Poster
Rep: Reputation: 0
ok. Just tried that and got the result:

alphaomega@alphaomega-desktop:~$ ifconfig wlan0 up
SIOCSIFFLAGS: Permission denied

I haven't the slightest idea what SIOCSIFFLAGS is, but it doesn't sound good.

No change in connectivity. I connect with a hard-line just fine, but through wireless...nothing.

Feelin' a little helpless....
 
Old 03-08-2007, 11:49 PM   #4
jschiwal
Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655Reputation: 655
Run the ifup command as root. Also, you need to configure encryption before you can associate with your router.
 
Old 03-09-2007, 12:07 AM   #5
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Squeeze 2.6.32.9 SMP AMD64
Posts: 3,245

Rep: Reputation: 121Reputation: 121
Thanks J.

"Permission denied"

My bad. I need to put a sign on my monitor to remind me that the new user may not automatically know to run these commands as root. It's probably better to get into the habit of running these things as sudo, though. It'll ask for the root password, but will help keep you from doing really bad things like doing "rm -rf *" while logged in as root.

Example:
Code:
sudo ifconfig wlan0 up
The system prompts for password. You enter the root password, and it's good to go.

It looks to me like your AP's encryption key is actually off, but that's a different issue at this point.
 
Old 03-11-2007, 10:06 PM   #6
Feelin' Fine
LQ Newbie
 
Registered: Feb 2007
Location: Canada
Distribution: Ubuntu 6.10
Posts: 10

Original Poster
Rep: Reputation: 0
Okay....feelin' better.

With all security protocols turned off (open network), I have successfully connected to the router and can go on the net. Huzzah! Thanks so much for your help!

Now if I could prevail upon you to help me secure the network.
Every time I switch the router to WPA security, I can no longer connect. I'm thinking this is because I am somehow not entering the right info into Wifi Radar or other connection tool.

....or if there is something else that I need to be doing?

Feelin' a little more confident, but still going to need basic instructions.
 
Old 03-11-2007, 11:52 PM   #7
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
WPA requires a software utility called a supplicant. There are two choices for Linux- XSupplicant and wpa_supplicant. wpa_supplicant is the more common of the two. If it's not already installed, grab wpa_supplicant with Synaptic, along with NetworkManager (a GUI for setting up the wireless device).
 
Old 03-12-2007, 12:17 AM   #8
Feelin' Fine
LQ Newbie
 
Registered: Feb 2007
Location: Canada
Distribution: Ubuntu 6.10
Posts: 10

Original Poster
Rep: Reputation: 0
ok. got both. Not sure what to do now.

Incidentally, I have the NetworkManager applet up in the top right corner of my screen. It is not detecting my wireless connection, even though I am connected.
When I hard-wire into the router, the applet says connected and all is good. When the hard-line is disconnected, I'm moving about wirelessly, but the applet still indicates "No Network Connection" and has the little red 'x' through the icon.

Related at all?
 
Old 03-12-2007, 12:23 AM   #9
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
Hmm. Don't know if it's related or not. I've only used Ubuntu a little - mostly just so I could be a little more help to people who use it - and NM worked fine with an Atheros card and wpa_supplicant.

I manually configured wpa_supplicant and used NM. Both worked, but since you're having trouble with the GUI, you may want to try manually editing /etc/wpa_supplicant.conf. The file is pretty well documented.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't connect to wireless network when SSID broadcast is disabled, Atheros card/SuSE9 baters Linux - Wireless Networking 19 01-15-2007 07:56 AM
Wireless card won't connect to network Ragnarok Warrior Linux - Wireless Networking 1 11-20-2006 03:41 PM
WiFi card Atheros (D-Link 520) doesn't start martincho *BSD 0 07-15-2006 02:40 PM
Howto: Install D-Link DWL-G650 Atheros Wireless PCMCIA Card on UserLinux (Debian Sarg jsaints Linux - Wireless Networking 2 04-17-2006 12:11 AM
Network Configuration Errors Setting D-Link DW650+ Wireless Card tznomani Linux - Newbie 6 10-29-2003 05:31 AM


All times are GMT -5. The time now is 09:24 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration