LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 03-12-2007, 10:05 AM   #1
doubleDog
LQ Newbie
 
Registered: Mar 2007
Location: TX
Distribution: SUSE 10.2
Posts: 11

Rep: Reputation: 0
SuSE 10.2 Network Manager Non-functional


Greetings,

Following some of the threads here and other places I was able to install ndiswrapper for the Dell 1390 MiniPCI WLAN card, the light now comes on, and the wireless manager can measure the signal (albeit with SU login to config sub menu). However, selecting Network Manager from the menu does not launch anything -- nothing happens. YaST says it's installed.

So, should I abandon hope for Network Manager and configure the wireless connection with YaST on the card itself?

All help appreciated.
 
Old 03-12-2007, 12:22 PM   #2
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
Things I would try, in order:

* Run NetworkManager from a terminal (as root) to see if you get an error message.

* Use the command line entirely to set the wireless parameters and configure the interface.

* Try YaST
 
Old 03-12-2007, 09:10 PM   #3
doubleDog
LQ Newbie
 
Registered: Mar 2007
Location: TX
Distribution: SUSE 10.2
Posts: 11

Original Poster
Rep: Reputation: 0
Closer

Hello 2Gnu,

As soon as I entered knetworkmanager into the terminal I received indications Network Manager was already running. I looked at the System Tray of the Kicker I noticed two incons representing a network wall socket and plug (so that's what that is). So I clicked that and a list of nearby wireless networks show up. CLOSE, but still a problem.

I attempted to connect using the correct passphrase(key) and the progress bar gets to about 57% configured and quits. Still no network access, but REALLY close. What might be wrong?

Hub Details:
WEP-Open

Selected YaST Details, Wireless Card
Module Name: ndiswrapper
Network Setup Method: User Controlled with Network Manager
Firewall Zone: Internal Zone
Device Activation: On Cable Connection

Wireless Device Settings
Operating Mode: Managed
Authentication Mode: Open
Key Input Type: Passphrase
everything else blank

Last edited by doubleDog; 03-12-2007 at 09:32 PM.
 
Old 03-12-2007, 10:23 PM   #4
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
Can you get it to work via CLI?

Bring down the wired interface (if one is running):
ifconfig eth0 down
Bring up the wireless interface:
ifconfig wlan0 up
Set the wireless:
iwconfig wlan0 mode managed essid <your_ssid> key <your_wep_key>
Obtain an IP address:
dhclient wlan0

If that works, maybe someone more familiar with NM and SuSE can help you with the GUI pieces. If not, post the output of ifconfig and iwconfig, along with any errors.
 
Old 03-14-2007, 09:54 AM   #5
doubleDog
LQ Newbie
 
Registered: Mar 2007
Location: TX
Distribution: SUSE 10.2
Posts: 11

Original Poster
Rep: Reputation: 0
slight delay

Will be delayed trying this until Thurs. evening. Thx
 
Old 03-14-2007, 10:23 AM   #6
Inchcape
Member
 
Registered: Jan 2007
Location: Switzerland
Distribution: Linux Mint bianca, Xubuntu, Puppy
Posts: 45

Rep: Reputation: 16
I believe networkmanager is just the backend. The frontend (on my suse 10.2/KDE is Knetworkmanager.

with mine, the plug and socket applet means it's connected to a wired network, whereas small blue bar graph signifies a wireless network.

I configured the network connection in yast (network devices, network card) and chose "on cable connection" for the wired device and "at boot up" for the wireless.

I had a problem with the computer connecting to a "phantom" wired network (no cable plugged in!) and the wireless activating to 57% and no further. Double clicking the wifi network bar after right-clicking the applet would connect the wireless network with no problem.

I re-configured the wired network in yast to be a "manual connection". Since then the phantom wired network no longer prevents the wireless from connecting at bootup.

I think Knetworkmanager (or the backend) has problems with WEP keys (did with mine at least). Finally I removed the WEP security and did a MAC address filter on the router for the family's 4 computers.
 
Old 03-15-2007, 08:45 PM   #7
doubleDog
LQ Newbie
 
Registered: Mar 2007
Location: TX
Distribution: SUSE 10.2
Posts: 11

Original Poster
Rep: Reputation: 0
Unhappy no luck

Being a noob, perhaps I did not implement your suggestions correctly, but I tried. The exception is I did not change over to MAC address networking -- I am still hoping to avoid that.

(note: MAC addresses changed to protect the innocent)

Code:
linux-3zps:/home/doubledog # ifconfig 
eth0      Link encap:Ethernet  HWaddr 00:FF:FF:FF:0E:8A
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:217

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:54 errors:0 dropped:0 overruns:0 frame:0
          TX packets:54 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3500 (3.4 Kb)  TX bytes:3500 (3.4 Kb)

wlan0     Link encap:Ethernet  HWaddr 00:FF:FF:FF:90:C3
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:6192 (6.0 Kb)
          Interrupt:169 Memory:efcfc000-efd00000

linux-3zps:/home/doubledog # iwconfig
lo        no wireless extensions.

wlan0     IEEE 802.11g  ESSID:off/any  Nickname:"linux-3zps"
          Mode:Managed  Frequency:2.437 GHz  Access Point: Not-Associated
          Bit Rate:54 Mb/s   Tx-Power:32 dBm
          RTS thr:2347 B   Fragment thr:2346 B
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

eth0      no wireless extensions.

sit0      no wireless extensions.
 
Old 03-15-2007, 09:44 PM   #8
doubleDog
LQ Newbie
 
Registered: Mar 2007
Location: TX
Distribution: SUSE 10.2
Posts: 11

Original Poster
Rep: Reputation: 0
Progress

I took a visit to the log file:
/var/log/NetworkManager
and noticed something funny:

Code:
Mar 15 21:12:40 linux-3zps NetworkManager: <info>  Activation (wlan0/wireless) Stage 2 of 5 (Device Configure) successful.  Connected to access point '2WIRE313'.
Mar 15 21:12:40 linux-3zps NetworkManager: <info>  Activation (wlan0) Stage 3 of 5 (IP Configure Start) scheduled.
Mar 15 21:12:40 linux-3zps NetworkManager: <info>  Activation (wlan0) Stage 3 of 5 (IP Configure Start) started...
Mar 15 21:12:41 linux-3zps NetworkManager: <info>  Activation (wlan0) Beginning DHCP transaction.
Mar 15 21:12:41 linux-3zps NetworkManager: <info>  Activation (wlan0) Stage 3 of 5 (IP Configure Start) complete.
Mar 15 21:12:41 linux-3zps NetworkManager: <info>  DHCP daemon state is now 12 (successfully started) for interface wlan0
Mar 15 21:12:41 linux-3zps NetworkManager: <info>  DHCP daemon state is now 1 (starting) for interface wlan0
Mar 15 21:13:26 linux-3zps NetworkManager: <info>  Device 'wlan0' DHCP transaction took too long (>45s), stopping it.
Mar 15 21:13:27 linux-3zps NetworkManager: <info>  Activation (wlan0) Stage 4 of 5 (IP Configure Timeout) started...
When I checked my 2WIRE DSL modem DHCP was not enabled! So I copied down the assigned IP address (and network mask) and switched the Network Address Setup for the wireless card to the Static Address Setup -- plugged in the values and wha-la! After clicking finish I was able to click on my network in Network Manager, supplied the WEP key and the blue bars and the Wallet showed up.

So NOW I am connected to the home network BUT my browser will not hook up to anything. SO IT IS CLOSE, but something is still off.
 
Old 03-15-2007, 10:04 PM   #9
2Gnu
Senior Member
 
Registered: Jan 2002
Location: Southern California
Distribution: Slackware 14.0
Posts: 1,874

Rep: Reputation: 49
If you're using a static IP, you'll also need a default gateway and DNS servers.

In /etc/resolv.conf, put the DNS server list for your ISP. Example for mine:
search oc.cox.net
nameserver 68.4.16.30
nameserver 68.4.16.25
nameserver 68.6.16.30

Then add the gateway:
route add default gw 192.168.1.1 (again, my example - use the IP address of your router)
 
Old 03-16-2007, 09:00 PM   #10
doubleDog
LQ Newbie
 
Registered: Mar 2007
Location: TX
Distribution: SUSE 10.2
Posts: 11

Original Poster
Rep: Reputation: 0
Unhappy not working

must be some incompatibility between my 2WIRE DSL modem and my setup -- getting blue bars, the wlan0 card gets loaded instead of eth0 (set device activation to manual). NetworkManager and the KWallet are starting as expected. Watching the log files -- Network manager complained about the hard-coded gateway/nameservers. So left the IP Address as Static but the Hostname and Name Server as DHCP.

The NetworkManager log file reaches Activation (wlan0) Stage 5 of 5 (IP Configure Commit) complete. The blue bars show up (I entered the WEP key into 0 position of the WEP Keys list. It all LOOKS OK, I can even see traffic on my DSL monitor -- BUT my attempts to access the internet with Konqueror yield the dreaded *Unknonwn host* message.
 
Old 03-24-2007, 04:47 PM   #11
doubleDog
LQ Newbie
 
Registered: Mar 2007
Location: TX
Distribution: SUSE 10.2
Posts: 11

Original Poster
Rep: Reputation: 0
I gave up on SUSE and just today installed Fedora 6. I have yet to try the network card -- but the software has already recognized my ATI video card. Things are looking up.
 
Old 04-02-2007, 03:58 PM   #12
Adrian Baker
Member
 
Registered: Apr 2004
Distribution: PCLinuxOS 2007 on my laptop and Suse 10.2 on my desktop.
Posts: 341

Rep: Reputation: 30
I had all kinds of problems in Suse 10.2 with knetworkmanager. Kinternet worked a dream with Suse 10.0, but my laptop wireless hasn't been as stable since I upgraded to 10.2. No idea why...

If the blue bars are up, you're connected! I had a problem with my router not supporting IPv6 and had to turn of this option in Firefox (via about:config) in order for my browser to work. This may have been your problem with Konqueror.

If you still have problems with Fedora, it is your router. Mine is a D-link ADSL router and due to its inherent problems, GAIM refuses to work, Firefox only works with IPv6 disabled and Kubuntu won't update unless I change the DNS settings manually every time I log on!
 
Old 04-04-2007, 05:06 PM   #13
doubleDog
LQ Newbie
 
Registered: Mar 2007
Location: TX
Distribution: SUSE 10.2
Posts: 11

Original Poster
Rep: Reputation: 0
Wireless Working with Fedora 6

Thanks for your post Adrian.

I got my wireless card (Dell 1390) to work just fine in Fedora 6, although perhaps I owe some credit to all the *practice* I got with ndiswrapper on SuSE 10.2.

The information on the ndiswrapper wiki (installation and troubleshooting) was most helpful.

I was able to follow the compile instructions (make) even-though I had no idea what I was doing -- other than I knew I was compiling.
The troubleshooting page looks like it was written for the Dell laptop.

I had previously downloaded the very large installation file from Dell Support for my card. I expanded and halted the installation and grabbed a copy of the DRIVER folder and ignored the megabytes of everything else (its a big download).

I still have a couple of glitches to work out with NetworkManager. My current routine is:

1. open a terminal and su -
2. modprobe ndiswrapper
3. go to the system tray in the upper task bar (Gnome/Fedora) and de-select enable networks, then enable them again.

The first time step 3 was performed I was prompted to set up the password manager thingy and input the ESSID and WEP passphrase. To my surprise the passphrase format was a key selection, I had been selecting the first (128) choice, but my key worked great with the second choice 64/128 hex something.

Sorry I can't be more accurate -- doing this from memory.

Steps one two and three need to be repeated each time -- but there are some low level cures (rc scripts) which can remedy this, but I haven't tried them yet so I don't want to mislead anyone.

Once the password manager has been fed, you never need to supply the key again.

Last edited by doubleDog; 04-05-2007 at 10:12 AM.
 
Old 04-14-2007, 10:47 AM   #14
doubleDog
LQ Newbie
 
Registered: Mar 2007
Location: TX
Distribution: SUSE 10.2
Posts: 11

Original Poster
Rep: Reputation: 0
Cool Wireless Card Working Great!

If you have been following this thread this post represents the END OF THE STORY.

Just to recap, I attempted to use openSuSE 10.2. My limited experience with openSuSE suggests there is definately a *tiered* experience going on there -- but its a fine product, I wish them luck. Perhaps I could have gotten my network card and NetworkManager to work on that platform if I had selected the correct encryption for my WEP passkey (doh!)

Anyway, I switched to Fedora 6 (FC6)and was pleasantly surprised that it recognized my ATI Radeon Mobility graphics card, which openSuSE did not. With openSuSE I was going to have to download/compile/etc. well...stuff.

Anywho...I now have Fedora hooking me up through my Dell 1390 wireless card everytime I boot. If your experience is like mine -- you have wandered through many posts and tales of woe about this baby. So check out the posts above for the install notes about *ndiswrapper* and the three step thing I was stuck in for awhile. Then try this (FC6 only): edit the file

/etc/rc.local

and add these two lines to the bottom of the file:

modprobe ndiswrapper
/sbin/service NetworkManager restart

Save your edits and reboot.

DONE!

The password manager dialog will appear after you boot up and log-in.

EPILOG ==================
If at some point in the future you apply a package/update to the kernel you may need to recompile and install ndiswrapper. So, save all those source files,drivers and instructions in a convenient place on the hard drive.

Last edited by doubleDog; 04-16-2007 at 01:13 PM.
 
  


Reply

Tags
broadcom, fedora 6, ndiswrapper, network manager, suse10


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
ipw3945 and SuSE Network Manager Troubles Erebus Bat Linux - Wireless Networking 3 09-13-2006 12:42 PM
SuSE 10.1 network manager keeps prompting me for wireless SSIDs Blade2006 Suse/Novell 6 08-18-2006 09:56 AM
no functional modem in suse 10 littlemissy1029 Linux - Hardware 1 05-04-2006 04:02 PM
functional problems (network cards) taphy Linux - Hardware 2 10-13-2005 12:28 AM
non functional network redhat9 coneccting thru xp slimis Linux - Networking 3 12-26-2003 12:14 PM


All times are GMT -5. The time now is 12:40 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration