LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 12-10-2009, 09:36 AM   #1
rafe101
LQ Newbie
 
Registered: Dec 2009
Location: Michigan, USA
Distribution: Ubuntu
Posts: 8

Rep: Reputation: 0
Static IP with WICD at Startup


I reserved a small range of IP addresses for my laptops, and let friends' get their addresses from DHCP. I configured WICD to pick specific IP addresses when on the home network, but wanted to leave them open to dynamic addresses on other networks. Now, all but one of the laptops work as intended—all except the one I use most often.

It's not a big deal, but a minor inconvenience. It doesn't obtain the IP address I designated for it automatically at startup. It's supposed to be 192.168.1.2, but it's almost always 15 (unless a foreign computer already has that address). If I disconnect and reconnect, it becomes 2, but never on startup.

Any ideas?

Ubuntu 8.04
kernel: 2.6.24-26-generic
Gnome 2.22.3

Last edited by rafe101; 12-10-2009 at 09:52 AM.
 
Old 12-10-2009, 09:39 AM   #2
repo
LQ 5k Club
 
Registered: May 2001
Location: Belgium
Distribution: Linux Mint
Posts: 8,496

Rep: Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883Reputation: 883
Did you configured the static ip in wicd ?
 
Old 12-10-2009, 09:54 AM   #3
rafe101
LQ Newbie
 
Registered: Dec 2009
Location: Michigan, USA
Distribution: Ubuntu
Posts: 8

Original Poster
Rep: Reputation: 0
Oh, yeah. Even when it's set at 15, I can go into the properties for the connection and see "192.168.1.2" staring back at me, and, yes, the box for "use static IP" is checked.

Like I said, if I reconnect the connection, it works, but not at startup.
 
Old 12-10-2009, 10:07 AM   #4
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Quote:
Originally Posted by rafe101 View Post

If I disconnect and reconnect, it becomes 2, but never on startup.

Any ideas?

Ubuntu 8.04
kernel: 2.6.24-26-generic
Gnome 2.22.3
Because DHCP daemon stars at boot time and gets that ip for you.
 
Old 12-10-2009, 10:11 AM   #5
rafe101
LQ Newbie
 
Registered: Dec 2009
Location: Michigan, USA
Distribution: Ubuntu
Posts: 8

Original Poster
Rep: Reputation: 0
I don't want to disable that, but can I delay it or move it's loading after WICD?
 
Old 12-10-2009, 10:16 AM   #6
rafe101
LQ Newbie
 
Registered: Dec 2009
Location: Michigan, USA
Distribution: Ubuntu
Posts: 8

Original Poster
Rep: Reputation: 0
Or does WICD perform the same function as that daemon? Can I disable the DHCP daemon and have WICD still dynamically get addresses from networks other than my home?
 
Old 12-10-2009, 03:06 PM   #7
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Try to disable DHCP on boot time, WICD will activate dhcp later
 
Old 12-10-2009, 07:46 PM   #8
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
You know, may be it is not dhcp starts at boot time, but interface activates at the boot time and therefore dhcp gives it IP address. Check it. I'm not sure.
Check network configuration setting - should be plenty options about dhcp and interface activation.

May be someone from the forum correct me.
 
Old 12-10-2009, 09:19 PM   #9
rafe101
LQ Newbie
 
Registered: Dec 2009
Location: Michigan, USA
Distribution: Ubuntu
Posts: 8

Original Poster
Rep: Reputation: 0
The only option I can really find is to disable the call to dhclient in WICD's setup, but that's a global thing. I wish it was just for individual networks. Since it's almost always 15, I'm thinking of reserving that number for this computer, setting that in WICD just to be sure, updating all the references to this computer's IP, and pretending it works correctly. It may always bother me that I can't do it right, but I can't find any other way.
 
Old 12-10-2009, 09:52 PM   #10
nimnull22
Senior Member
 
Registered: Jul 2009
Distribution: OpenSuse 11.1, Fedora 14, Ubuntu 12.04/12.10, FreeBSD 9.0
Posts: 1,571

Rep: Reputation: 92
Should be an option how interface is activated: at boot time, manualy, hot plug ....
And as well an option - enable/disable dhsp.
Also check if your interfaces are configured at boot time.

If you use network manager (WICD) - you really do not need it to be activated since boot time.
 
  


Reply

Tags
netwoking, wicd, wireless


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
annoying wicd message after system startup fastestOS Slackware 12 09-08-2009 10:21 PM
wicd won't let me use static ip on wireless card unclejed613 Slackware 9 06-09-2009 12:07 AM
How to initialize a static array of a class in a static member function lali.p Programming 9 02-16-2008 09:27 AM
Howto Assign Multiple Static Public IP Addresses under SBC's PPPoE Static Ip system o trekgraham Linux - Networking 8 04-17-2007 10:51 AM
FC2 Overriding static if in favor of dhcp system set for static pkraus109 Linux - Networking 8 09-21-2004 11:13 AM


All times are GMT -5. The time now is 09:08 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration