LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking > Linux - Wireless Networking
User Name
Password
Linux - Wireless Networking This forum is for the discussion of wireless networking in Linux.

Notices

Reply
 
Search this Thread
Old 03-20-2006, 11:06 AM   #1
Cryptoniks
LQ Newbie
 
Registered: Mar 2006
Posts: 8

Rep: Reputation: 0
Startup Errors with wireless networking Error for wireless request "Set Encode"


Error for wireless request "Set Encode"
Set failed on device wlan0 ; invalid argument (8B2A)

after poking around all night i still havent been able to resolve this issue

this occurs at bootup when trying to initialize my wireless connection

i had another thread that dealt with getting the wireless to be called at boot and that has been resolved hehe dispite any communacation errors between me and the guy that helped me lol

i am assuming thios has to do with my WEP key

the setup:
slackware 10.2
Kernel 2.4.31
ndiswrapper 1.10

i placed my wireless setting in the rc.wireless.conf file

i have double and triple checked my WEP key

apon further reading i have found WEP isnt the best choice for encryption anymore

should i try to go with WPA instead

this will require me to reconfigure my router
and change some things

but the O.C.D in me has a need to get this error resolved before trying somthing different LOL

so at the risk of being redundant

Error for wireless request "Set Encode"
Set failed on device wlan0 ; invalid argument (8B2A)

does anybody know how to resolve this in regards to WEP keys
 
Old 03-21-2006, 08:06 AM   #2
Hangdog42
LQ Veteran
 
Registered: Feb 2003
Location: Maryland
Distribution: Slackware
Posts: 7,791
Blog Entries: 1

Rep: Reputation: 414Reputation: 414Reputation: 414Reputation: 414Reputation: 414
I've found that using rc.wireless.conf with Slackware doesn't always work with ndiswrapper. Instead of using that, try adding the appropriate commands to your /etc/rc.d/rc.local file and see if it works any better.

If you have the choice of WPA or WEP, WPA is definitely the way to go, but it does complicate matters in that you need to use wpa_supplicant in addition to ndiswrapper.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error for wireless request "Set Mode" on Linksys WPC11 v 3 army180 Linux - Wireless Networking 2 09-04-2006 07:32 PM
Error for wireless request "Set Bit Rate" (8B20) king_scott_2 Linux - Wireless Networking 3 06-26-2006 06:27 PM
Error for wireless request "Set Encode" (8B2A) for ath0 Suse 9.0 debasisdan Linux - Wireless Networking 2 04-19-2006 02:28 AM
FC4 install errors, "diabling IRQ #10" "nobody cares" error message??? A6Quattro Fedora 6 07-20-2005 01:49 PM
"unable to set up wireless lan usb adapter" pathak Linux - Hardware 1 04-27-2005 02:01 AM


All times are GMT -5. The time now is 04:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration